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BrightAuthor is a software application that allows you to create and publish digital-signage presentations for BrightSign players. You can play
BrightAuthor presentations on all BrightSign models. Your presentations can include various types of content:

®* Images

® Videos

® Live video: Supported on the XD1230, XD1132, 4K1142, and XT1143
® Audio

® HTMLS5 pages

® |P Streaming audio/video

® Text

® Date and time

® RSS, MRSS, and Twitter feeds

® BrightSign Network features: Dynamic Playlists, Live Data feeds (RSS), Live Media feeds (MRSS)
¢ SignChannel

Note
A subscription is required to use SignChannel. Go to http://www.signchannel.com/ for details.

What Types of Presentation Can | Create?

You can create three types of presentation in BrightAuthor:

® Non-Interactive: A playlist of media (images, video, audio) that plays in a continuous loop. You can play non-interactive presentations on
all BrightSign models.

® |nteractive: A presentation that transitions between media based on input from a user via button board, touchscreen, remote control, or
similar input device. All models support at least one type of interactive event. The event types supported by a player model depend on
the connectors and inputs that player has (for example, players with a USB port support touch screen and button board events, and
players with an Ethernet port support UDP events).

® BrightWall™: A non-interactive playlist of media (video files or live video) that is closely synchronized across multiple players. BrightWall
presentations are ideal for video-wall applications.

What Types of Screen Layout Can | Use?

You can choose from a variety of ready-to-use layout templates. You can also create your own template. Layout templates fall into two basic
categories:
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® Full Screen: The media (images, video, HTML) occupies the entire screen (this can be used for audio-only presentations as well).

® Multi-Zone: The presentation contains content in separate regions of the screen. The screen can include multiple Clock, Text, Ticker, and
Images zones, as well as (depending on the player model) multiple Video Only zones.

Requirements

~ BrightAuthor Version 4.7
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To create presentations with BrightAuthor and publish them to your player, you will need the following:

* Windows PC

® BrightSign player

® Display

® Storage device

® Card reader/writer (optional if using USB storage)
® Input device

Windows PC — Any Windows PC that meets or exceeds the following minimum requirements:

® 2.3GHz CPU
® 2 GB RAM required (4 GB recommended)
® 100 MB available hard disk space for program files (additional disk space required if storing content and/or presentations on your hard
disk)
® One of the following operating systems:
® Windows Vista (32 or 64 bit)
® Windows 7 (32 or 64 bit)
® Windows 8 (32 or 64 bit)
® Windows 10 (32 or 64 bit)

The following are recommended requirements:

® Network connection (optional if publishing for Standalone)
® Bonjour 2.0.4 or later
¢ DirectX 9.0 or later

BrightSign Player — Any of the following models:

® XT243, XT1143

® 4K242,4K1042, 4K1142

® XD233, XD1033

* XD232, XD1032, XD1132

® XD230, XD1030, XD1230

* HD223, HD1023

HD222, HD1022

HD120, HD220, HD1020, HD970, AU320
LS423

LS322, LS422

Display — Any monitor, TV, or touchscreen with one of the following types of inputs:

* HDMI
® VGA (on all model lines except 4Kx42)
® Component (supported with a VGA converter on all model lines except 4Kx42)

Storage Device — Any of the following:
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microSD card (for XTx43, XDx33, HDx23, LS423 models) or SD card (for all other models)
USB Flash Drive (supported on models with a USB port)

SSD (XTx43, XDx33 models only)

MSATA drive (4K models only)

Note

We recommend formatting your SD/microSD card using FAT32 or exFAT. The exFAT format allows you to store files larger than 4GB,
but it is only supported on Series 3 players (XTx43, XDx33, HDx23, LS423) using firmware 6.2.94 or later. The NTFS format also allows
for files larger than 4GB, but the player will not be able to receive network updates or generate logs.

Card Reader/Writer — Only required if using an SD/microSD card. The card reader/writer must be connected to your PC and must be compatible
with your storage card.

Input Device — Required for interactive presentations only. Depending on the model, BrightSign players support one or more of the following
types of input device:

Touchscreen equipped with a supported touch controller. See this link for a list of all supported touch controllers.
BrightSign BP200 and BP900 USB button panels

Many brands of USB keyboards

Many brands of USB mice or trackballs

Many brands of USB bar code scanners

Quadravox Serial Button Board

AMX, Crestron, and similar control devices

Any GPIO (open/close contact switch) button, signal, or LED (your custom board or LED display)

PC (via UDP or serial)

IR input/output devices using the NEC or Pronto Hex remote control protocols.

Getting Started

= BrightAuthor Version 4.7
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® Step 1: Install BrightAuthor

® Step 2: Launch BrightAuthor

® Step 3: Set up your BrightSign player
® Step 4: Add your Content

® Step 5: Create your Presentations

® Step 6: Publish your Presentations

Tip
View this tutorial video to get an overview of using BrightAuthor.

If you're new to BrightAuthor, follow the below steps to get started.

Step

1: Install BrightAuthor

Download the latest software and install it on your PC:

1.
2.
3.

Go to the BrightSign Downloads page.
Locate the model series of your player.

Click the BrightAuthor link to download the current official release of BrightAuthor. To download a beta release (if there currently is one),
click the More Downloads link and select the Beta Release of BrightAuthor.

. Unzip the contents of the downloaded .zip file.
. Double-click the setup .exe file to begin the installation.
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6. Follow the onscreen instructions to install BrightAuthor on your PC.

Note

BrightAuthor requires the latest version of Microsoft .Net Framework. If this component is not already on your PC, BrightAuthor installs it
during the installation. However, if BrightAuthor needs to install Microsoft .Net Framework, the installation may take up to 45 minutes to
complete and you may need to restart your PC to complete the installation process.

Step 2: Launch BrightAuthor

1. Double-click the BrightAuthor icon on your desktop.

2. (Optional) If prompted, sign in to BrightSign Network (account required). See the BrightSign Network publishing instructions for more
details.

Step 3: Set up your BrightSign player

1. Depending on how you want to publish your presentations, create the appropriate setup files for your BrightSign player.
2. Insert an SD card or USB flash drive containing the setup files into the player.
3. Connect your player to a display and power it on.

Step 4: Add your Content

BrightAuthor presentations can include video, audio, image, and HTML files. See the following links to learn more about supported content types:

® Video: Supported formats, codecs, bitrates, etc.
® Audio: Supported formats, sampling rates, etc.
® Images: Supported formats

® HTML: Developer's guide

Step 5: Create your Presentations

Now you're ready to start using BrightAuthor to create presentations. To get started, create a simple full-screen presentation. You can then go on
to create more complex multi-zone and interactive presentations.

Step 6: Publish your Presentations

After creating presentations, use one of the publishing options to deliver them to your BrightSign players.

Setting up BrightSign Players

~ BrightAuthor Version 4.7
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Before you can publish presentations, you must first set up your BrightSign player(s). Follow these steps to set up a player:

Navigate to Tools > Setup BrightSign Unit.

Configure your unit for one of the four publishing options described below.
Save the setup files to a storage device (SD card or USB flash drive).
Insert the storage device into the BrightSign player and power it up.

WO NPE

Once the storage device is inserted, your BrightSign player is ready to receive and play presentations.

Note
The storage device must remain inside the player during playback—BrightSign players have no internal storage and, therefore, cannot
download or play content without a storage device connected.

Publishing Options
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There are four publishing options, depending on how you want to publish presentations to your players:

® BrightSign Network: Use the BrightSign Network cloud-based content-management system (CMS) to remotely schedule presentations,
distribute content, assign players to groups, and monitor the health of players.

® |ocal File Networking: Publish presentations and schedules to players over your local network.
® Simple File Networking: Publish presentations and schedules remotely using your own web server.

® Standalone: Publish presentations directly to your player using an SD card or USB drive. Use this method if your player doesn’t have a
network connection or if you do not plan to update the presentation frequently.

If you're using the BrightSign Network, Local Networking, or Simple File Networking to publish your presentations, you must connect your
player(s) to the local network via Ethernet or WiFi. Alternatively, you can set up players for use as standalone units that are not connected to a
network. With this option, you will need to manually update the player storage (SD card or USB flash drive) each time you want to update
presentations. For more details on the publishing process, see the Publishing Presentations section.

Note

Local File Networking supports a maximum of 10 players on a local network. Exceeding this recommended number may cause
unreliable behavior when publishing to players. For larger deployments, we recommend using the Simple File Network or BrightSign
Network publishing methods instead.

BrightSign Network Setup
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® Sign in to BSN

8 Name Specification
® Network Properties
® Advanced Network Setup
® Unit Configuration
® Wired/Wireless
® Diagnostics
® Firmware
® Splash Screen
® Unit Configuration
® Beacons
® |ogging
® Remote Snapshot
® RF Channel Scan Data (optional)
® Screen Color
® Creating and Installing the Setup Files

You must have a BrightSign Network Account to set up players for the BrightSign Network (BSN). Contact BrightSign Sales or your BrightSign
vendor to purchase BSN subscriptions.

Tip
This tutorial video outlines the basic steps for setting up a player for the BrightSign Network.

Sign in to BSN

To create BrightSign Network setup files, you must first sign in to BSN in BrightAuthor. Once you have your BSN account credentials, follow these
steps:

1. Navigate to Tools > Sign In to BrightSign Network. If you don't see this option, navigate to Edit > Preferences > Networking and check
the Enable BrightSign Network box.

2. Enter your Account, User name, and Password.

3. (Optional) Check the Remember account and user name box if you don't want to perform these steps every time you open
BrightAuthor.

4. Click Sign In.
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5. Navigate to Tools > Setup BrightSign Unit.

@ BrightSign Unit Setup ===
Name Specification Unit Configuration Logging
Name: Player 1 Enable diagnostic web server Enable playback logging

Enable event logging

Description: Diagnostic Server Authentication {optional)
escription: Enable state logging
Customization: User name: | admin Enable diagnostic logging
~) Use name only Password:  eeeessssee Enable variable logging
@ Append unit ID Upload logs
Network Properties Enable local web server [ On startup
[T Enable wircless Local Web Server Authentication (optional) 7 At specific time each day
SSID: User name:  admin Upload time: |00 ~| ¢ |00
Security key: . wes .
Password: Relative URL for log handler: (e.g., loghandler.php)
Show password Enable Update Notifications.
Network Connection Priority )
Wired Standalone Remate Snapshot (4Kx42, XDx32, XDx30, HDx22 onl|
- Networked with Local File Networking . B ) : only)
@ Networked with the BrightSign Network Enable remote snapshot

Advanced Network Setup | © Group [ca Los Gatos )

BrightWall Group

Remote snapshot every 15 minutes.

Time zone: IPST: US Pacific Time - Saveupto 5 images (1 - 100) on local storage.
Content Check Frequency: [Every 5 minutes |
Time server:  httpy//time.brightsignnetwork.com PEG quality level 50 (0 - 100).
Update Health Frequency: [Every 15 minutes - ‘ quality leve ( !
. o = < [T] Display snapshots in portrait mode
Firmware Networked with Simple File Networking

Specify Firmware Updats ‘ Relative URL for remote snapshot handler: (e.g., remoteSnapshotHandler.php)

Splash Screen
@ Standard Splash Screen RF Channel Scan Data (optional)

~) Custom Splash Screen Beacons (XT/4K/2K, XDx33, HDx23, 15423 only) Add Baacon | 4 Browse |

Name Type
Screen Color

Select a color to display when BrightSign is idle

I (-

[ Create Setup Files | [ Cancel |

Name Specification

®* Name: Enter a name for the player.

® Description:(Optional) Enter a description for the player.

® Customization: Select one of the following:
* Append unit ID: Appends the serial number of the player to the end of the player name.
® Use name only: Does not append anything to the player name.

Network Properties

® Enable Wireless: Check this box to connect the player to the local network using a wireless connection. In order to use a wireless
connection, you must purchase a Wireless Module for your BrightSign player. If the player is connecting to a secured network, enter the
following:

® SSID: Enter the SSID of the wireless network.
® Security key: Enter the password for the wireless network.
® Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless connection. The BrightSign player
will always attempt to download and upload using the first option, and will only use the second option if the first is unavailable.

® Time zone: Select the time zone where the player is located.

® Time server:(Optional) Specify the server (using a supported protocol) that the player should use to synchronize its clock. Players use
the BrightSign Network time server by default.

Advanced Network Setup

Click the Advanced Network Setup button to customize advanced settings for your networked player.

Unit Configuration
Use the Unit Configuration tab to specify the following:

® Specify hostname: Check this box to specify a custom hostname for the player on the network. By default, the player serial number is
used to generate a unique hostname (i.e. "brightsign-<serial_number>").
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® Use Proxy: Check this box if you want the player to use a proxy server.
® Address: Enter the address of the proxy. If you need to provide a user name and password for the proxy, use this format: <user
name>:<password>@-<proxy server address> (e.g. “admin:root@myproxy.com”).
® Port: Enter the port number of the proxy. If you do not specify a port number, the player will default to using port 1080.
®* Proxy Bypass: Use the Add Host button to add host names to the proxy bypass list. Host names that are checked will be
accessed directly, rather than using the specified proxy server. Entering a host name such as "example.com" will exempt
"example.com”, "example.com:80", and "www.example.com" from the proxy setting. This feature includes bypass options for the
BrightSign Network (content downloads, log uploads) and BrightSign Network Feeds (Dynamic Playlists, Live Media Feeds,
Live Text Feeds) by default.
® Limit content downloads: Check this box to restrict player content downloads to a certain time of day. This is helpful if you want to limit
network traffic during peak hours.
® Start of Range: The beginning of the time frame during which content downloads can occur.
* End of Range: The end of the time frame during which content downloads can occur.
® Limit health updates: Check this box to limit when the player sends health updates to the BrightSign Network. This is helpful if you know
a player will be powered off or otherwise disabled during a certain time of day.
® Start of Range: The beginning of the time frame during which health updates can be sent.
® End of Range: The end of the time frame during which health updates can be sent.

® Copy content from the current published schedule: Check this box to copy the current scheduled presentation(s) of the group to the
storage device along with the setup files. Use this option if you don’t want the player downloading large content files from the BrightSign
Network right after it is set up.

Wred/ Wrel ess
Use the Wired and Wireless tabs to specify the following:

® Data Types Enabled: Use these checkboxes to determine the data types that can be transferred using the connection. You can
enable/disable downloads (Content, Text Feeds, Media Feeds), as well as uploads (Health, Log Updates).
® Connection Settings: Indicate whether the IP address is auto-generated (via DHCP) or static. If you're using a static IP address, enter
the parameters in the fields.
® Rate Limit Network Download Traffic: Set rate limitations for downloading content. The options are divided into three categories: Outsi
de content download window, During content download window, and During initial downloads. The "content download window"
described by the first two options corresponds to the Limit content downloads interval set in the Unit Configuration tab.
® Unlimited download rate: Sets no limit on downloads.
® Default limit: Sets the default limit (2000 Kibit/s) on downloads.
® Specify limit: Sets a customized limit. Enter a limit in the text field (in Kbit/s).

Di agnostics
Use the Diagnostics tab to specify the following:

® Enable network diagnostics: Check this box to have the player display the network diagnostics screen during setup.
® Test Ethernet: The player will indicate whether or not it was able to attain an IP address over Ethernet.
® Test Wireless: The player will indicate whether or not it was able to attain an IP address over wireless.
® Test Internet Connection: The player will indicate whether or not it was able to communicate with a remote server.

Firmware

Click the Specify Firmware Update button to include a firmware update with the setup files. The firmware update will be performed after you
insert the storage device containing the setup files into the player and power it up. Locate the section corresponding to your BrightSign model and
select one of the following:

® Production Release: The current official release of BrightSign firmware
® Beta Release: The current beta release of BrightSign firmware

®* Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The
minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.

® Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will download
the update file from BrightSign when the setup files are created.

Splash Screen

® Standard Splash Screen: The player will display the BrightSign logo when booting up.
® Custom Splash Screen: The player will display a custom logo when booting up. Click Browse to locate and select the image you wish
to use. See this FAQ for image size and format restrictions.
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Unit Configuration

Select the Networked with the BrightSign Network option. Then configure the following:

® Enable diagnostic web server:(Optional) Check this box to enable the Diagnostic Web Server. You can include a username and
password in the text fields below for added security.

® Enable local web server:(Optional) Check this box to enable the Local Web Server. You can include a username and password in the
text fields below for added security.

® Enable Update Notifications:(Optional) Check this box to have the player automatically refresh the User VVariables webpage wh
enever variable values change on the player.

® Group: Select this option to include the player in a standard BSN group. Use the dropdown list to select a BSN group for the player.
Groups allow you to publish presentation schedules to multiple players. See the Publishing with BrightSign Network page for more
details.

® BrightWall Group: Select this option to include the player in a BSN BrightWall group. Use the dropdown list to select a BrightWall group
for the player. Each BrightWall group includes one or more BrightWall(s) that share a common configuration file, and each BrightWall in a
BrightWall group plays the same presentation.

Tip
You can create BrightWall groups in the Manage > Status section.

® BrightWall Name: Use the dropdown list to assign the player to a BrightWall within the BrightWall group. If you haven't created
the BrightWall yet, click Add BrightWall and enter the BrightWall name. Note that a new BrightWall will utilize the configuration
file that is assigned to the BrightWall group.
® Screen Number: Specify the section of the BrightWall to which the player belongs. Screens are 1 2 3 -
numbered by row, starting from the top-left section of the BrightWall (the example diagram to the
right shows the numbering of a 4x3 BrightWall).
® Content Check Frequency: Specify how often the player should communicate with the BSN servers to
determine if there is new scheduled content to download.
® Update Health Frequency: Specify how often the player should send health status updates to the BSN
servers. This determines how up-to-date the Player Status colors are.
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Beacons

This section allows you to configure persistent BLE beaconing. Beacons can also be paired with presentations.

¢ Name: Enter a name for the beacon.
® Type: Use the dropdown list to select the beaconing mode/format:
® iBeacon: A simple beaconing format
® UUID: A string representation of a UUID, which can be in 16-bit, 32-bit, or 128-bit format. A 16-bit UUID must be exactly
four hex digits with no punctuation; a 32-bit UUID must be exactly eight hex digits with no punctuation; and a 128-bit
UUID must be punctuated exactly as follows: "cd7b6f81-f738-4cad-aebf-d2a2ea36d996".
® Major: An integer specifying the 2-byte Major value (0 to 65535)
® Minor: An integer specifying the 2-byte Minor value (0 to 65535)

®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSl in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

® Eddystone URL: The Eddystone-URL format
® URL: The URL to encapsulate in the advertisement packet.
® TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

® Eddystone UID: The Eddystone-UID format
®* Namespace: A 6-byte value expressed as 12 hexadecimal digits

® |nstance: A 10-byte value expressed as 20 hexadecimal digits

® TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

Note
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The TxPower value does not modify the power level of the Bluetooth transmitter (this requires physical attenuation). Rather, the TxPow
er value is transmitted to Bluetooth clients in the BLE advertisement. Clients can then compare this value to the current RSSI of the
signal to determine their approximate distance from the beacon.

Logging

Use the check boxes to enable/disable logs and specify log upload settings. You can view logs in the Current Usage tab of the BSN WebUI or in
the currentLog folder on the player storage.

Enable playback logging: Records playback start and end times, zone names, media types, and file names.
Enable event logging: Records timestamps, state names, zone names, event types, and event data.

Enable state logging: Records current and last state names, timestamps, and media types.

Enable diagnostic logging: Records timestamps, firmware and script versions, and the current presentation.

Enable Variable logging: Records the current and default values of all User VVariables in the presentation. This log is only generated
when logs are uploaded to the BSN servers.

Upload logs: Check either of the following:
® On startup: Uploads log files each time the player is powered on.
® At specific time each day: Uploads log files daily at the specified time. Use the dropdown lists to pick a time.

Tip
See this FAQ to learn how to read player logs.

Remote Snapshot

Check the Enable remote snapshot box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of the
presentation display.

Note
The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

Remote snapshot every [ ] minutes: Specify how often the player should take a snapshot of the presentation display.

Save up to [ ] images (1 - 100) on local storage: Specify how many JPEG snapshot images can be stored on the local storage of the
player.

JPEG quality level [] (0 - 100): Specify the quality level (and thus the file size) of each image file.

Display snapshots in portrait mode: Check this box to have the player rotate the snapshots to portrait mode before saving and
uploading them.

RF Channel Scan Data (optional)

Use this field to publish RF channel scan settings to an XD1230 player. This option is useful if you need to publish identical channel scan settings
to multiple XD1230 players. See Publishing Channel Scan Results for more details.

Screen Color

Click Choose to specify what screen color the player should display after it has successfully completed the setup process. When the player
displays this color, it is ready to receive content.

Creati

ng and Installing the Setup Files

Now that you've configured the setup files, you need to publish them to your player:
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Click Create Setup Files.

. Browse to and select an SD card (recommended) or USB flash drive. Ensure the setup files are written to the root folder of the storage

device.

. Click OK.

. Turn off the BrightSign player by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
. Insert the SD card or USB flash drive into the player.

. Turn on the BrightSign player by reconnecting the power.


http://docs.brightsign.biz/display/DOC/Current+Usage+Tab
http://docs.brightsign.biz/display/DOC/Advanced+Features#AdvancedFeatures-publishing_channel_scan_results
https://brightsign.zendesk.com/hc/en-us/articles/115000724413
http://support.brightsign.biz/hc/en-us/articles/218067077-How-do-I-interpret-BrightSign-player-logs-

Note

We recommend formatting your SD/microSD card using FAT32 or exFAT. The exFAT format allows you to store files larger than 4GB,
but it is only supported on Series 3 players (XTx43, XDx33, HDx23, LS423) using firmware 6.2.94 or later. The NTFS format also allows
for files larger than 4GB, but the player will not be able to receive network updates or generate logs.

Important
The storage device must remain in the player at all times while playing presentations.

Local File Network Setup

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions
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Tip
This tutorial video outlines the basic setups for setting up a player for Local File Networking.

Local File Networking allows you to publish presentations to your BrightSign player over the local network. To set up a player for Local File
Networking, navigate to Tools > Setup BrightSign Unit.

Important

Local File Networking supports a maximum of 10 players on a local network. Exceeding this recommended number may cause
unreliable behavior when publishing to players. For larger deployments, we recommend using the Simple File Network or BrightSign
Network publishing methods instead.

Name Specification

® Name: Enter a name for the player

® Description:(Optional) Enter a description for the player.

® Customization: Select one of the following:
® Append unit ID: Appends the serial number of the player to the end of the player name.
® Use name only: Does not append anything to the player name.
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@ BrightSign Unit Setup

Name Specification
Name: Player 1

Description:

Unit Configuration
Enable diagnostic web server

Diagnostic Server Authentication (optional)

Logging
Enable playback logging
Enable event logging

Enable state logging
Customization: User name: | admin Enable diagnostic logging

! Use name only P [ —— Enable variable logging
@ Append unit 1D
Upload logs
Network Properties Enable local web server Dy i
[ Enable wireless Local Web Server Authentication (aptional) At specific time each day
SSID: User name:  admin Upload time: | 00 |00
Security key: x sssessssee
P Relative URL for log handler: (e.g,, loghandler.php}
Show password Enable Update Notifications.
Network Connection Priority
Wired Standalone
_— @ Networked with Local File Networking Remote Snapshot (4Kx42, XDx32, XDx30, HDx22 only)
Networked with the BrightSign Network Enable remote snapshot
Advanced Network Setup | Networked with Simple File Networking i
Remate snapshot every 15 minutes.
Time zone: [PST: US Pacific Time - Saveupto 5 images (1 - 100) on local storage.
Time server:  hitp://time brightsignnetwork.com JPEG quality level 50 (0 - 100).
Firmware [ Display snapshots in portrait mode

:Specﬁy Femware.Update. | Relative URL for remote snapshot handler: (e.g., remoteSnapshotHandler.php)

Splash Screen
@ Standard Splash Screen RF Channel Scan Data (optional)

) Custom Splash Screen Beacons (XT/4K/2K. XDx33. HDx23. L5423 only) Add Beacon [ 4 Browse |

Name Type
Screen Color

Select a color to display when BrightSign is idle
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| Create Setup Fies | [ cancel |

Network Properties

® Enable Wireless: Check this box to connect the player to the local network using a wireless connection. In order to use a wireless
connection, you must purchase a Wireless Module for your BrightSign player. If the player is connecting to a secured network, enter the
following:

® SSID: Enter the SSID of the wireless network.
® Security key: Enter the password for the wireless network.

® Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless connection. The BrightSign player
will always attempt to download and upload using the first option, and will only use the second option if the first is unavailable.

® Time zone: Select the time zone where the player is located.

® Time server:(Optional) Specify the server (using a supported protocol) that the player should use to synchronize its clock. Players use
the BrightSign Network time server by default.

Advanced Network Setup

Click the Advanced Network Setup button to customize advanced settings for your networked player.

Unit Configuration

Use the Unit Configuration tab to specify the following:

® Specify hostname: Check this box to specify a custom hostname for the player on the network. By default, the player serial number is
used to generate a unique hostname (i.e. "brightsign-<serial_number>").

® Use Proxy: Check this box if you want the player to use a proxy server.

® Address: Enter the address of the proxy. If you need to provide a user name and password for the proxy, use this format: <user
name>:<password>@-<proxy server address> (e.g. “admin:root@myproxy.com”).

® Port: Enter the port number of the proxy. If you do not specify a port number, the player will default to using port 1080.

®* Proxy Bypass: Use the Add Host button to add host names to the proxy bypass list. Host names that are checked will be
accessed directly, rather than using the specified proxy server. Entering a host name such as "example.com" will exempt
"example.com”, "example.com:80", and "www.example.com" from the proxy setting. This feature includes bypass options for the

BrightSign Network (content downloads, log uploads) and BrightSign Network Feeds (Dynamic Playlists, Live Media Feeds,
Live Text Feeds) by default.

Wred/ Wrel ess
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Use the Wired and Wireless tabs to specify the following:

® Data Types Enabled: Use these checkboxes to determine the data types that can be transferred using the connection. You can
enable/disable downloads (Content, Text Feeds, Media Feeds), as well as uploads (Health, Log Updates).

® Connection Settings: Indicate whether the IP address is auto-generated (via DHCP) or static. If you're using a static IP address, enter
the parameters in the fields.

Di agnostics
Use the Diagnostics tab to specify the following:

® Enable network diagnostics: Check this box to have the player display the network diagnostics screen during setup.
® Test Ethernet: The player will indicate whether or not it was able to attain an IP address over Ethernet.
® Test Wireless: The player will indicate whether or not it was able to attain an IP address over wireless.
® Test Internet Connection: The player will indicate whether or not it was able to communicate with a remote server.

Firmware

Click the Specify Firmware Update button to include a firmware update with the setup files. The firmware update will be performed after you
insert the storage device containing the setup files into the player and power it up. Locate the section corresponding to your BrightSign model and

select one of the following:

® Production Release: The current official release of BrightSign firmware
® Beta Release: The current beta release of BrightSign firmware

® Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The
minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.

® Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will download
the update file from BrightSign when the setup files are created.

Splash Screen

® Standard Splash Screen: The player will display the BrightSign logo when booting up.
® Custom Splash Screen: The player will display a custom logo when booting up. Click Browse to locate and select the image you wish
to use. See this FAQ for image size and format restrictions.

Unit Configuration

Select the Networked with Local File Networking option. Then configure the following:

® Enable diagnostic web server:(Optional) Check this box to enable the Diagnostic Web Server. You can include a username and
password in the text fields below for added security.
® Enable local web server: This box must be checked to use Local File Networking. You can add a username and password in the text
fields below for added security.
® Enable Update Notifications:(Optional) Check this box to have the player automatically refresh the User VVariables webpage wh
enever variable values change on the player.

Beacons

This section allows you to configure persistent BLE beaconing. Beacons can also be paired with presentations.

® Name: Enter a name for the beacon.
® Type: Use the dropdown list to select the beaconing mode/format:
® Beacon: A simple beaconing format
® UUID: A string representation of a UUID, which can be in 16-bit, 32-bit, or 128-bit format. A 16-bit UUID must be exactly
four hex digits with no punctuation; a 32-bit UUID must be exactly eight hex digits with no punctuation; and a 128-bit
UUID must be punctuated exactly as follows: "cd7b6f81-f738-4cad-aebf-d2a2ea36d996".
® Major: An integer specifying the 2-byte Major value (0 to 65535)
® Minor: An integer specifying the 2-byte Minor value (0 to 65535)
®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.
® Eddystone URL: The Eddystone-URL format
® URL: The URL to encapsulate in the advertisement packet.
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®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

® Eddystone UID: The Eddystone-UID format

®* Namespace: A 6-byte value expressed as 12 hexadecimal digits

® |nstance: A 10-byte value expressed as 20 hexadecimal digits

* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

Note

The TxPower value does not modify the power level of the Bluetooth transmitter (this requires physical attenuation). Rather, the TxPow
er value is transmitted to Bluetooth clients in the BLE advertisement. Clients can then compare this value to the current RSSI of the
signal to determine their approximate distance from the beacon.

Logging
Use the check boxes to enable/disable logs and specify log upload settings. You can view logs in the currentLog folder on the player storage.

®* Enable playback logging: Records playback start and end times, zone names, media types, and file names.
® Enable event logging: Records timestamps, state names, zone names, event types, and event data.

® Enable state logging: Records current and last state names, timestamps, and media types.

® Enable diagnostic logging: Records timestamps, firmware and script versions, and the current presentation.

®* Enable Variable logging: Records the current and default values of all User Variables in the presentation. This log is only generated
when logs are uploaded to custom log handler URL.

Tip
See this FAQ to learn how to read player logs.

Remote Snapshot

Check the Enable remote snapshot box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of the
presentation display.

Note
The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

®* Remote snapshot every [ ] minutes: Specify how often the player should take a snapshot of the presentation display.

® Save upto[]images (1 - 100) on local storage: Specify how many JPEG snapshot images can be stored on the local storage of the
player.

® JPEG quality level [] (0 - 100): Specify the quality level (and thus the file size) of each image file.

® Display snapshots in portrait mode: Check this box to have the player rotate the snapshots to portrait mode before saving and
uploading them.

RF Channel Scan Data (optional)

Use this field to publish RF channel scan settings to an XD1230 player. This option is useful if you need to publish identical channel scan settings
to multiple XD1230 players. See Publishing Channel Scan Results for more details.

Screen Color

Click Choose to specify what screen color the player should display after it has successfully completed the setup process. When the player

displays this color, it is ready to receive content.

Creating and Installing the Setup Files
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Now that you've configured the setup files, you need to publish them to your player:

1. Click Create Setup Files.
. Browse to and select an SD card (recommended) or USB flash drive. Ensure the setup files are written to the root folder of the storage
device.

. Click OK.

. Turn off the BrightSign player by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
. Insert the SD card or USB flash drive into the player.

. Turn on the BrightSign player by reconnecting the power.
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Note

We recommend formatting your SD/microSD card using FAT32 or exFAT. The exFAT format allows you to store files larger than 4GB,
but it is only supported on Series 3 players (XTx43, XDx33, HDx23, LS423) using firmware 6.2.94 or later. The NTFS format also allows
for files larger than 4GB, but the player will not be able to receive network updates or generate logs.

Important
The storage device must remain in the player at all times while playing presentations.

Simple File Network Setup
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Tip
This video tutorial outlines basic steps for setting up a player for Simple File Networking.

A player set up for Simple File Networking will retrieve content and schedule updates from your server at regular intervals. The setup files
generated here provide settings for your network and point the player to the web server that it will use for updates. To set up a player for Simple
File Networking, navigate to File > Setup BrightSign Unit.

Name Specification

® Name: Enter a name for the player

® Description:(Optional) Enter a description for the player.

® Customization: Select one of the following:
® Append unit ID: Appends the serial number of the player to the end of the player name.
® Use name only: Does not append anything to the player name.
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@ BrightSign Unit Setup

Name Specification
Name: Player 1
Description:

Customization:
! Use name only
@ Append unit 1D

Network Properties
[] Enable wireless
SSID:
Security key:
Show password

Network Connection Priority
Wired

Wireless

Advanced Network Setup |

Time zone: [PST: US Pacific Time hd

Time server:  http://time.brightsignnetwork.com

Firmware
Specify Firmware Update ‘

Splash Screen
@ Standard Splash Screen
) Custom Splash Screen

Unit Configuration
Enable diagnostic web server
Diagnostic Server Authentication (optional)
User name: | admin
Password:  weeesseses
Enable local web server
Local Web Server Authentication (optional)
User name:  admin

e ssssssssss

Enable Update Notifications

Standalone

Networked with Local File Networking

Networked with the BrightSign Network
@ Networked with Simple File Networking

URL for web folder: (e.g., http://www.brightsign.com/files/)
http:/fwww.brightsign.com/files/

Content Check Frequency: | Every 5 minutes A ‘

Simple File ing Authentication (opti

User name:
Password:
[] Enable basic authentication

Beacons (XT/4K/2K. XDx33, HDx23, L5423 only) Add Beacon (4

Name Type

Logging
Enable playback logging
Enable event logging
Enable state logging
Enable diagnostic logging
Enable variable logging

Upload logs

[7] On startup
[ At specific time each day

Upload time: | 00 |00

Relative URL for log handler: (e.g., loghandler.php)

Remote Snapshot (4Kx42, XDx32, XDx30, HDx22 only)

Enable remote snapshot

Remote snapshot every 15

minutes.

Saveupto 5  images (1 - 100) on local storage.

JPEG quality level 50 (D - 100).

[ Display snapshots in portrait mode

Relative URL for remote snapshot handler: (e.g., remoteSnapshotHandler.php)

RF Channel Scan Data (optional)

Screen Color

Browse |

Select a color to display when BrightSign is idle
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Network Properties

® Enable Wireless: Check this box to connect the player to the local network using a wireless connection. In order to use a wireless

connection, you must purchase a Wireless Module for your BrightSign player. If the player is connecting to a secured network, enter the

following:

® SSID: Enter the SSID of the wireless network.
® Security key: Enter the password for the wireless network

® Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless connection. The BrightSign player

will always attempt to download and upload using the first option, and will only use the second option if the first is unavailable.
® Time zone: Select the time zone where the player is located.

® Time server:(Optional) Specify the server (using a supported protocol) that the player should use to synchronize its clock. Players use
the BrightSign Network time server by default.

Advanced Network Setup

Click the Advanced Network Setup button to customize advanced settings for your networked player.

Unit Configuration

Use the Unit Configuration tab to specify the following:

® Specify hostname: Check this box to specify a custom hostname for the player on the network. By default, the player serial number is
used to generate a unique hostname (i.e. "brightsign-<serial_number>").

® Use Proxy: Check this box if you want the player to use a proxy server.

® Address: Enter the address of the proxy. If you need to provide a user name and password for the proxy, use this format: <user

name>:<password>@-<proxy server address> (e.g. “admin:root@myproxy.com”).
® Port: Enter the port number of the proxy. If you do not specify a port number, the player will default to using port 1080.

®* Proxy Bypass: Use the Add Host button to add host names to the proxy bypass list. Host names that are checked will be
accessed directly, rather than using the specified proxy server. Entering a host name such as "example.com" will exempt

"example.com”, "example.com:80", and "www.example.com" from the proxy setting. This feature includes bypass options for the
BrightSign Network (content downloads, log uploads) and BrightSign Network Feeds (Dynamic Playlists, Live Media Feeds,

Live Text Feeds) by default.

® Limit content downloads: Check this box to restrict player content downloads to a certain time of day. This is helpful if you want to limit
network traffic during peak hours.

® Start of Range: The beginning of the time frame during which content downloads can occur.
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®* End of Range: The end of the time frame during which content downloads can occur.

Wred/ Wrel ess
Use the Wired and Wireless tabs to specify the following:

® Data Types Enabled: Use these checkboxes to determine the data types that can be transferred using the connection. You can
enable/disable downloads (Content, Text Feeds, Media Feeds), as well as uploads (Health, Log Updates).
® Connection Settings: Indicate whether the IP address is auto-generated (via DHCP) or static. If you're using a static IP address, enter
the parameters in the fields.
® Rate Limit Network Download Traffic: Set rate limitations for downloading content. The options are divided into three categories: Outsi
de content download window, During content download window, and During initial downloads. The "content download window"
described by the first two options corresponds to the Limit content downloads interval set in the Unit Configuration tab.
® Unlimited download rate: Sets no limit on downloads.
® Default limit: Sets the default limit (2000 Kibit/s) on downloads.
® Specify limit: Sets a customized limit. Enter a limit in the text field (in Kbit/s).

Di agnostics
Use the Diagnostics tab to specify the following:

® Enable network diagnostics: Check this box to have the player display the network diagnostics screen during setup.
® Test Ethernet: The player will indicate whether or not it was able to attain an IP address over Ethernet.
® Test Wireless: The player will indicate whether or not it was able to attain an IP address over wireless.
® Test Internet Connection: The player will indicate whether or not it was able to communicate with a remote server.

Firmware

Click the Specify Firmware Update button to include a firmware update with the setup files. The firmware update will be performed after you
insert the storage device containing the setup files into the player and power it up. Locate the section corresponding to your BrightSign model and

select one of the following:

® Production Release: The current official release of BrightSign firmware

® Beta Release: The current beta release of BrightSign firmware

®* Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The
minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.

® Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will download
the update file from BrightSign when the setup files are created.

Splash Screen

® Standard Splash Screen: The player will display the BrightSign logo when booting up.
® Custom Splash Screen: The player will display a custom logo when booting up. Click Browse to locate and select the image you wish
to use. See this FAQ for image size and format restrictions.

Unit Configuration

Select the Networked with Simple File Networking option. Then configure the following:

® Enable diagnostic web server:(Optional) Check this box to enable the Diagnostic Web Server. You can include a username and
password in the text fields below for added security.
® Enable local web server:(Optional) Check this box to enable the Local Web Server. You can include a username and password in the

text fields below for added security.
® Enable Update Notifications:(Optional) Check this box to have the player automatically refresh the User VVariables webpage wh

enever variable values change on the player.
® URL for the web folder: Specify the location from which the player will download content updates. Do not use trailing slashes in your
URL; some web servers do not support trailing slashes.

Important
The URL for the web folder must be identical to the URL you use when publishing presentations. See the Simple File Networking

publishing page for details. If you're having trouble getting players to communicate with your web server, see this FAO for
troubleshooting tips.

® Content Check Frequency: Set how often you want the player to check your server for updates.
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® Simple File Networking Authentication:(Optional) Enter a User name and password to enable digest authentication between the
BrightSign player and the server.
® Enable basic authentication: Check this box to have the player pass credentials to the web server in unsecured packets. Use
this option only if it is absolutely required by the configuration of your web server.

Beacons

This section allows you to configure persistent BLE beaconing. Beacons can also be paired with presentations.

® Name: Enter a name for the beacon.
® Type: Use the dropdown list to select the beaconing mode/format:
® iBeacon: A simple beaconing format
® UUID: A string representation of a UUID, which can be in 16-bit, 32-bit, or 128-bit format. A 16-bit UUID must be exactly
four hex digits with no punctuation; a 32-bit UUID must be exactly eight hex digits with no punctuation; and a 128-bit
UUID must be punctuated exactly as follows: "cd7b6f81-f738-4cad-aebf-d2a2ea36d996".
® Major: An integer specifying the 2-byte Major value (0 to 65535)
® Minor: An integer specifying the 2-byte Minor value (0 to 65535)
®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.
® Eddystone URL: The Eddystone-URL format
® URL: The URL to encapsulate in the advertisement packet.
®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.
® Eddystone UID: The Eddystone-UID format
® Namespace: A 6-byte value expressed as 12 hexadecimal digits
® |nstance: A 10-byte value expressed as 20 hexadecimal digits
®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

Note
The TxPower value does not modify the power level of the Bluetooth transmitter (this requires physical attenuation). Rather, the TxPow

er value is transmitted to Bluetooth clients in the BLE advertisement. Clients can then compare this value to the current RSSI of the
signal to determine their approximate distance from the beacon.

Logging
Use the check boxes to enable/disable logs and specify log upload settings. You can view logs in the currentLog folder on the player storage.

®* Enable playback logging: Records playback start and end times, zone names, media types, and file names.
® Enable event logging: Records timestamps, state names, zone names, event types, and event data.
® Enable state logging: Records current and last state names, timestamps, and media types.
® Enable diagnostic logging: Records timestamps, firmware and script versions, and the current presentation.
® Enable Variable logging: Records the current and default values of all User Variables in the presentation. This log is only generated
when logs are uploaded to custom log handler URL.
Upload logs: Check either of the following:
® On startup: Uploads log files each time the player is powered on.
® At specific time each day: Uploads log files daily at the specified time. Use the dropdown lists to pick a time.
Relative URL for log handler: Specify the location on the server where you want logs to be uploaded and parsed.

Tip
See this FAQ to learn how to read player logs.

Remote Snapshot
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Check the Enable remote snapshot box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of the
presentation display.

Note
The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

®* Remote snapshot every [ ] minutes: Specify how often the player should take a snapshot of the presentation display.

® Save upto[]images (1 - 100) on local storage: Specify how many JPEG snapshot images can be stored on the local storage of the
player.

® JPEG quality level [] (0 - 100): Specify the quality level (and thus the file size) of each image file.

® Display snapshots in portrait mode: Check this box to have the player rotate the snapshots to portrait mode before saving and
uploading them.

RF Channel Scan Data (optional)

Use this field to publish RF channel scan settings to an XD1230 player. This option is useful if you need to publish identical channel scan settings
to multiple XD1230 players. See Publishing Channel Scan Results for more details.

Screen Color

Click Choose to specify what screen color the player should display after it has successfully completed the setup process. When the player
displays this color, it is ready to receive content.

Creating and Installing the Setup Files

Now that you've configured the setup files, you need to publish them to your player:

1. Click Create Setup Files.
. Browse to and select an SD card (recommended) or USB flash drive. Ensure the setup files are written to the root folder of the storage

device.

. Click OK.
Turn off the BrightSign player by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).

. Insert the SD card or USB flash drive into the player.
. Turn on the BrightSign player by reconnecting the power.
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note
We recommend formatting your SD/microSD card using FAT32 or exFAT. The exFAT format allows you to store files larger than 4GB,

but it is only supported on Series 3 players (XTx43, XDx33, HDx23, LS423) using firmware 6.2.94 or later. The NTFS format also allows
for files larger than 4GB, but the player will not be able to receive network updates or generate logs.

Important
The storage device must remain in the player at all times while playing presentations.

Standalone Setup

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions
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Standalone players are not connected to a network and must be updated manually. To change presentations/schedules, you must remove the
storage card (or USB flash drive), update it on your computer, and reinsert it into the player. Updating standalone units is the only case in which
you should remove the storage card after setting up the unit.

Tip

If your player has a USB flash drive slot, we recommend that you use an SD card when setting up the unit and keep it in the player as
the internal storage. You can then update the content on the SD card via a USB flash drive. See the Local Storage publishing page for
details.

To set up a player for standalone use, navigate to Tools > Setup BrightSign Unit.

Name Specification

®* Name: Enter a name for the player

® Description:(Optional) Enter a description for the player.

® Customization: Select one of the following:
* Append unit ID: Appends the serial number of the player to the end of the player name.
® Use name only: Does not append anything to the player name.
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@ BrightSign Unit Setup

Name Specification
Name: Player 1
Description:

Customization:
! Use name only
@ Append unit1D

Network Properties
[] Enable wireless
SSID:
Security key:
Show password

Network Connection Pricrity
Wired

Wireless

Advanced Network Setup |

Time zone: [PST: US Pacific Time bt

Time server:  http://time.brightsignnetwork.com

Firmware
Specify Firmware Update ‘

Splash Screen
@ Standard Splash Screen
Custom Splash Screen

Unit Configuration
Enable diagnostic web server
Diagnostic Server Authentication (optional)
User name: | admin

Trsmragt ssessnnsee

Enable local web server
Local Web Server Authentication (optional)
User name:  admin

e sssssssses

Enable Update Notifications

@ Standalone
USE Content Update Password (optional)

| Networked with Local File Networking
 Networked with the BrightSign Network
) Networked with Simple File Networking

Beacons (XT/4K/2K. XDx33. HDx23, L5423 only)

Logging
Enable playback logging
Enable event logging
Enable state logging
Enable diagnestic logging
Enable variable logging

Upload logs

On startup
At specific time each day

Upload time: | 00 |00

Relative URL for log handler: {e.q., loghandler.php}

Remote Snapshot (4K>42, XDx32, XDx30, HDx22 only)
Enable remote snapshot
Remote snapshot every 15  minutes.
Saveupto 5  images (1 - 100) on lacal storage.
IPEG quality level 50 (0 - 100).
|| Display snapshots in portrait mode

Relative URL for remate snapshot handler: (e.g., remoteSnapshotHandler.php)

RF Channel Scan Data (optional)

Add Beacon (4 Browse ‘

Name Type

Screen Color

Select a color to display when BrightSign is idle

I (-

| Create Setup Files | | Cancel |

Network Properties

® Enable Wireless: Check this box to connect the player to the local network using a wireless connection. In order to use a wireless
connection, you must purchase a Wireless Module for your BrightSign player. If the player is connecting to a secured network, enter the

following:

® SSID: Enter the SSID of the wireless network.

® Security key: Enter the password for the wireless network

® Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless connection. The BrightSign player
will always attempt to download and upload using the first option, and will only use the second option if the first is unavailable.

® Time zone: Select the time zone where the player is located.

® Time server:(Optional) Specify the server (using a supported protocol) that the player should use to synchronize its clock. Players use
the BrightSign Network time server by default.

Advanced Network Setup

Click the Advanced Network Setup button to customize advanced settings for your networked player.

Unit Configuration

Use the Unit Configuration tab to specify the following:

® Specify hostname: Check this box to specify a custom hostname for the player on the network. By default, the player serial number is
used to generate a unique hostname (i.e. "brightsign-<serial_number>").

® Use Proxy: Check this box if you want the player to use a proxy server.

® Address: Enter the address of the proxy. If you need to provide a user name and password for the proxy, use this format: <user
name>:<password>@-<proxy server address> (e.g. “admin:root@myproxy.com”).

® Port: Enter the port number of the proxy. If you do not specify a port number, the player will default to using port 1080.

®* Proxy Bypass: Use the Add Host button to add host names to the proxy bypass list. Host names that are checked will be
accessed directly, rather than using the specified proxy server. Entering a host name such as "example.com" will exempt
"example.com”, "example.com:80", and "www.example.com" from the proxy setting. This feature includes bypass options for the
BrightSign Network (content downloads, log uploads) and BrightSign Network Feeds (Dynamic Playlists, Live Media Feeds,
Live Text Feeds) by default.

Wred/ Wrel ess
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Use the Wired and Wireless tabs to specify the following:

® Data Types Enabled: Use these checkboxes to determine the data types that can be transferred using the connection. You can
enable/disable downloads (Content, Text Feeds, Media Feeds), as well as uploads (Health, Log Updates).

® Connection Settings: Indicate whether the IP address is auto-generated (via DHCP) or static. If you're using a static IP address, enter
the parameters in the fields.

Di agnostics
Use the Diagnostics tab to specify the following:

® Enable network diagnostics: Check this box to have the player display the network diagnostics screen during setup.
® Test Ethernet: The player will indicate whether or not it was able to attain an IP address over Ethernet.
® Test Wireless: The player will indicate whether or not it was able to attain an IP address over wireless.
® Test Internet Connection: The player will indicate whether or not it was able to communicate with a remote server.

Firmware

Click the Specify Firmware Update button to include a firmware update with the setup files. The firmware update will be performed after you
insert the storage device containing the setup files into the player and power it up. Locate the section corresponding to your BrightSign model and
select one of the following:

® Production Release: The current official release of BrightSign firmware

® Beta Release: The current beta release of BrightSign firmware

® Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The
minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.

® Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will download
the update file from BrightSign servers when the setup files are created.

Splash Screen

® Standard Splash Screen: The player will display the BrightSign logo when booting up.
® Custom Splash Screen: The player will display a custom logo when booting up. Click Browse to locate and select the image you wish
to use. See this FAQ for image size and format restrictions.

Unit Configuration

Select the Standalone option. Then configure the following:

® Enable diagnostic web server:(Optional) Check this box to enable the Diagnostic Web Server. You can include a username and
password in the text fields below for added security.

® Enable local web server:(Optional) Check this box to enable the Local Web Server. You can include a username and password in the
text fields below for added security.

® Enable Update Notifications:(Optional) Check this box to have the player automatically refresh the User VVariables webpage wh
enever variable values change on the player.

® USB Content Update Password: Enter a password in the field to enable password protection for USB content updates. This feature

helps to ensure that a player will not be assigned incorrect schedules or data when updated via USB.

Beacons

This section allows you to configure persistent BLE beaconing. Beacons can also be paired with presentations.

® Name: Enter a name for the beacon.
® Type: Use the dropdown list to select the beaconing mode/format:
® iBeacon: A simple beaconing format
® UUID: A string representation of a UUID, which can be in 16-bit, 32-bit, or 128-bit format. A 16-bit UUID must be exactly
four hex digits with no punctuation; a 32-bit UUID must be exactly eight hex digits with no punctuation; and a 128-bit
UUID must be punctuated exactly as follows: "cd7b6f81-f738-4cad-aebf-d2a2ea36d996".
® Major: An integer specifying the 2-byte Major value (0 to 65535)
® Minor: An integer specifying the 2-byte Minor value (0 to 65535)
® TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.
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® Eddystone URL: The Eddystone-URL format
® URL: The URL to encapsulate in the advertisement packet.
® TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.
® Eddystone UID: The Eddystone-UID format
* Namespace: A 6-byte value expressed as 12 hexadecimal digits
® |nstance: A 10-byte value expressed as 20 hexadecimal digits
® TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

Note
The TxPower value does not modify the power level of the Bluetooth transmitter (this requires physical attenuation). Rather, the TxPow

er value is transmitted to Bluetooth clients in the BLE advertisement. Clients can then compare this value to the current RSSI of the
signal to determine their approximate distance from the beacon.

Logging
Use the check boxes to enable/disable logs and specify log upload settings. You can view logs in the currentLog folder on the player storage.

®* Enable playback logging: Records playback start and end times, zone names, media types, and file names.

® Enable event logging: Records timestamps, state names, zone names, event types, and event data.

® Enable state logging: Records current and last state names, timestamps, and media types.

® Enable diagnostic logging: Records timestamps, firmware and script versions, and the current presentation.

® Enable Variable logging: Records the current and default values of all User Variables in the presentation. This log is only generated
when logs are uploaded to a custom log handler URL.

Tip
See this FAQ to learn how to read player logs.

Remote Snapshot

Check the Enable remote snapshot box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of the
presentation display.

Note
The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

® Remote snapshot every [ ] minutes: Specify how often the player should take a snapshot of the presentation display.

® Save upto[]images (1-100) on local storage: Specify how many JPEG snapshot images can be stored on the local storage of the
player.

* JPEG quality level [] (0 - 100): Specify the quality level (and thus the file size) of each image file.

® Display snapshots in portrait mode: Check this box to have the player rotate the snapshots to portrait mode before saving and
uploading them.

RF Channel Scan Data (optional)
Use this field to publish RF channel scan settings to an XD1230 player. This option is useful if you need to publish identical channel scan settings
to multiple XD1230 players. See Publishing Channel Scan Results for more details.

Screen Color

Click Choose to specify what screen color the player should display after it has successfully completed the setup process. When the player
displays this color, it is ready to receive content.
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Creating and Installing the Setup Files

Now that you've configured the setup files, you need to publish them to your player:

N

(o2 62 B - V]

. Click Create Setup Files.

Browse to and select an SD card (recommended) or USB flash drive. Ensure the setup files are written to the root folder of the storage
device.

. Click OK.

. Turn off the BrightSign player by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
. Insert the SD card or USB flash drive into the player.

. Turn on the BrightSign player by reconnecting the power.

Note

We recommend formatting your SD/microSD card using FAT32 or exFAT. The exFAT format allows you to store files larger than 4GB,
but it is only supported on Series 3 players (XTx43, XDx33, HDx23, LS423) using firmware 6.2.94 or later. The NTFS format also allows
for files larger than 4GB, but the player will not be able to receive network updates or generate logs.

Important
The storage device must remain in the player at all times while playing presentations.

Creating Presentations

w BrightAuthor Version 4.7

® \ersion 4.6
® Version 4.4
® Previous Versions

This section describes how to create presentations. There are three types of presentation you can create in BrightAuthor:

Full-screen presentations: A looping playlist of media—images, videos, HTML pages, etc.—that occupies the entire presentation display.
Multi-zone presentations: Content can occupy different zones on the screen, allowing you to display multiple images, videos, HTML
pages, and text widgets in a customizable layout.

Interactive presentations: Playback, whether full-screen or multi-zone, is responsive to interactive events such as button presses, GPIO
input, or UDP commands.

Besides image, video, audio, and HTML files, presentations can also feature a number of BrightAuthor states, such as Live Text, Media RSS
feeds, and HDMI input.

Full-Screen Presentations

~ BrightAuthor Version 4.7

® Version 4.6
® \ersion 4.4
® Previous Versions
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Tip
This tutorial video outlines the basic steps for creating a full-screen presentation.

In a full-screen presentation, your images and videos occupy the entire screen.

Creating a New Project



http://docs.brightsign.biz/display/BA46/4.6-BrightAuthor+User+Guide
http://docs.brightsign.biz/display/BA44/4.4-BrightAuthor
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting
http://docs.brightsign.biz/display/BA46/4.6-BrightAuthor+User+Guide
http://docs.brightsign.biz/display/BA44/4.4-BrightAuthor
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting
http://brightsignbiz.s3.amazonaws.com/videos/02_full_screen.mp4

To create a new presentation project, navigate to File > New Presentation. If you don’t see New Presentation under File, make sure you have
the Edit, Publish, or Manage tab selected.

Specify the following in the New Project window:

@ New project ﬂ @ New project ﬂ
Create a new BrightSign project Create a new BrightSign project
Main | Advanced Main | Advanced
Save As:  Project 1 Force Resolution:
‘Where:  CA\BrightSign Content Browse Full resolution graphics: [

Enable YCbCr 10-bit output: [

BrightSign Model: [XTL143 -]

Video zone configuration: @) Standard

Connector type: [HDMI - ] ) Mosaic

Menitor overscan: @ Mo overscan - use full screen

Screen resolution: [384-012150x30p h ] () Overscan - action safe area
() Overscan - title safe area

—

Maonitor ori i [Landscape - ]

Mai n
® Save as: Enter a name for the presentation project.
* Where: Click Browse to select the folder where you want to save the presentation project.
® BrightSign model: Select the target player model for the presentation. This will determine the options available when creating the
presentation in the Edit tab.
® Connector type: Select the video connector type that connects the player to the display: HDMI, VGA, or Component.

® Screen resolution: Choose a resolution that matches the native resolution of your monitor. You can view all available screen resolutions
in this FAQ.

Note
You can output a composite signal to a converter by selecting the "HDMI" or "Component" Connector type and choosing one of the
available composite video modes. See this FAQ for more information on generating component and composite signals.

® Monitor Orientation: Select a monitor orientation for your presentation:
® Landscape: Content is not rotated.
® Portrait — bottom on left: Content is rotated counter-clockwise 90 degrees. Select this option if the bottom of the monitor is on
the left when it is portrait oriented.
® Portrait — bottom on right: Content is rotated clockwise 90 degrees. Select this option if the bottom of the monitor is on the right
when it is portrait oriented.

Portrait - bottom on left Landscape Portrait - bottom on right

Monitor Logo Monitor Logo Monitor Logo

Note
Choosing a portrait mode will rotate all images, videos, and HTML. However, for HDx20 and LSx22 models, content is not rotated on

the player. Instead, you will need to rotate video or images in the source application (e.g. Photoshop, Adobe After Effects) before
publishing them to the player.

Advanced
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Force Resolution: Check this box to have the player output the selected Screen resolution even if the display reports over HDMI/VGA
that it does not support this resolution. If this box is unchecked, the player will attempt to use the selected Screen resolution first, but will
then fall back to the highest resolution supported by the display if it is unsupported.
Full resolution graphics: Check this box to enable full-resolution graphics for the selected Screen resolution. When this box is
checked, the graphics plane (images, text, HTML animations, etc.) is rendered at the same size as the video output, rather than being
upscaled to the output resolution after rendering. This option is only available for certain video modes larger than 1920x1200; all smaller
video modes use full-resolution graphics automatically. This setting is subject to additional restrictions based on the resolution and player
model—-see here for full details.
Enable YCbCr 10-bit output: Check this box to output a 10-bit color video signal to the connected display. See the video encoding FAQ
for more details on supported 4K color spaces and bit depths.
Video zone configuration: Determine how video resources will be divvied up in the presentation:
® Standard: You can have one or two video zones (depending on whether your player model supports dual decode), and these
zones can play video files up to the maximum resolution (either HD or 4K) supported by your player model.
® Mosaic: You can have more than two video zones. The maximum number of video zones depends on the Maximum content
resolution setting in the Edit > Layout tab: The smaller the maximum resolution, the more video zones you can add.
Monitor overscan: Select an overscan setting to determine how the content fills the display screen.
®* No overscan — use full screen: Displays content to the edge of the video signal.
® Overscan — action safe: Restricts the display area to a size that is compatible with most displays.
® Overscan —title safe: Restricts the display area to a size that is much smaller than the generated video signal.

Overscan is necessary with some older television screens that cut off content at the edges of the screen.

Click Create when you are finished configuring the presentation. The Template window will open. Click the Full screen template, then click Cho

ose.

Adding Content to the Presentation Playlist

To add content to your presentation, first designate a folder on your computer as your Media Library. This will make it easy to drag and drop
image, video, and audio files into your playlist from a scrollable list of thumbnails.

Under Media Library, select the files tab.

Click to open the file browser.

Navigate to the folder where your content is stored.
Click OK.

Note
If your content folder contains large files, it may take a while for the thumbnail images to appear.
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Add media files to your presentation by dragging files from the Media Library to the playlist area. You can do the following when adding media
files:

® Select a series of adjacent media files — Hold the Shift key as you select the files in the Media Library.

® Select a group of non-adjacent files — Hold the Ctrl key as you select the files in the Media Library.

® Refresh the Media Library — Click . This will update the Media Library with any changes to the corresponding folder on your computer.
® Move up to the parent directory of the current folder — Click .

® Move to a sub-directory of the current folder — Click a file thumbnail in the Media Library.

Tip
You can also drag and drop media files directly into the playlist from a Windows Explorer window.

Editing the Presentation Playlist

Once you've added media files to the playlist, you can modify it by doing any of the following:

®* Remove an item from the playlist — Click an item in the playlist area and press the Delete or Backspace key.
® Change the order in which an item plays — Click and drag an item to a new position in the playlist.
® Rename the playlist — Click Edit in the upper-right corner of the playlist area.

® Change the playlist view — Click the list/tile icon in the top-right of the playlist area to change the playlist
view. Switching to a list view allows you to see the parameters of all media items and states in the

playlist.
® Replace media files in the playlist — Go to File > Replace media files. The Replace Media Files wind
ow allows you to replace files within media states without having to drag and drop individual files. This [ interactive EDIT

is useful if you need to update a large number of media files in your playlist or if you want to ensure the
playlist order is preserved.
®* Replacement Media Folder: Click Browse to select the folder that contains the files you want to add. This can be the same
folder as your Media Library, or another folder.

® Preserve state names: Check this box to preserve the names of the media states in the playlist. If this box is unchecked, the
current media states will automatically take on the names of the new media files.

® Presentation Media Files: For each file listed under Current Media Files, select a new file using the dropdown list beneath Rep
lacement Media File.

Editing Media Playback Options

To edit the playback settings of a media item, double-click the thumbnail in the playlist area (or right-click and select Edit), then choose the



settings you want to apply to the selected item:

®* Image files: Specify the following:
®* Time on Screen: The amount of time (in seconds) that the image displays on screen before transitioning to the next iter_n.

® Transition: The transition effect that occurs from the previous ED Etdit Image Parameters = s
media item to this image.

® Transition Duration: The duration (in seconds) of the
transition effect .

*® Video files: Specify the Volume of the video. I —— T .
® Audio files: Specify the Volume of the audio track.

Time on screen: 5

. X i i . . Transitson Duration (secondk): 1.0
To edit settings for multiple items, press the Ctrl key and select items in the

playlist. On the menu bar, select Edit > Selected Items, and then choose the
settings you want to apply to the selected items. Note that the selected items
must all be the same media or state type for this to work.

0 Cancel

Next Steps

Now that you've created your full screen presentation, save it by navigating to File > Save [project name] (make sure you have the Edit tab
selected). Then, do any of the following:

® Publish the presentation — Click the Publish tab and select your publishing method. See the Publishing Presentations section for more
instructions.

® Export the presentation — Navigate to File > Export [project name]. This saves the presentation project as a package that can be
opened by BrightAuthor instances on other computers.

® Save the presentation using a new name or location — Navigate to File > Save [project name] As.
® Create another presentation — Navigate to File > New Presentation.

Multi-Zone Presentations
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Tip
This tutorial video outlines the basic steps for creating multi-zone presentations.

In a multi-zone presentation, BrightAuthor divides the screen into rectangles called zones, allowing you to create a different playlist for each zone.
BrightAuthor provides a number of multi-zone templates. You can choose one of the system templates or create your own (see the Customizing
Zone Layouts page for more details). You can also edit the zone layout at any time after selecting a template.

In multi-zone presentations, the zone type restricts the media and state types that can be included in the zone. The color-coded key at the bottom
of the Template window shows the available zone types. The following list describes the available content types for each zone type:

®* Images: Displays images and HTML. You can include multiple Images zones in a presentation.

® Ticker: Displays RSS feeds or pre-defined text strings. You can include multiple Ticker zones in a presentation.
® Clock: Displays the time or date. You can include multiple Clock zones in a presentation.

® Video or Images: Displays images, video, and HTML (can also play audio files).

® Video Only: Displays video.

¢ Audio Only: Plays audio. You can include multiple Audio Only zones in a presentation.
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®* Enhanced Audio: Plays audio in a cross-faded playlist. You can include only one Enhanced Audio zone in a presentation.
® Background Image: Places an image or media feed in the background of your presentation. All other zones appear on top of this zone.

Video Zone Restrictions

BrightSign XT, 4K, and XD models can decode two videos simultaneously, while HD and LS models can only decode a single video. Also, the
Background Image zone uses a video decoder to display an image. This leads to the following zone restrictions:

® XTx43, 4Kx42, XDx33, XDx32, XDx30: You can include two Video or Images zones, two Video Only zones, one of each, or one of these
and a Background Image zone.
® HDx23, HDx22, LS423, LSx22, HDx20: You can include a single Video or Images zone, Video Only zone, or Background Image zone.

Creating a New Project

To create a new multi-zone presentation, navigate to File > New Presentation.

B New project =]

Create a new BrightSign project

Save As: My New Project

Where:  C:BrightSign Content [Browse]
BrightSign Model: [XD233 -
Connector type: |HDML -
Screen resolution: [384Dx216[)x60p ']
Video zone configuration: ° Standard
Mosaic
Monitor orientation: | Landscape -

Monitor overscan: @ No overscan - use full screen
*) Overscan - action safe area
Owerscan - title safe area

o)

MAI' N

® Save as: Enter a name for the presentation project.

®* Where: Click Browse to select the folder where you want to save the presentation project.

® BrightSign model: Select the target player model for the presentation. This will determine the options available when creating the
presentation in the Edit tab.

® Connector type: Select the video connector type that connects the player to the display: HDMI, VGA, or Component.

® Screen resolution: Choose a resolution that matches the native resolution of your monitor. You can view all available screen resolutions
in this FAQ.

Note
You can output a composite signal to a converter by selecting the "HDMI" or "Component" Connector type and choosing one of the

available composite video modes. See this FAQ for more information on generating component and composite signals.

® Monitor Orientation: Select a monitor orientation for your presentation:
® Landscape: Content is not rotated.
® Portrait — bottom on left: Content is rotated counter-clockwise 90 degrees. Select this option if the bottom of the monitor is on
the left when it is portrait oriented.
® Portrait — bottom on right: Content is rotated clockwise 90 degrees. Select this option if the bottom of the monitor is on the right
when it is portrait oriented.
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Portrait - bottom on left Landscape Portrait - bottom on right

Monitor Logo Monitor Logo Monitor Logo

Note

Choosing a portrait mode will rotate all images, videos, and HTML. However, for HDx20 and LSx22 models, content is not rotated on
the player. Instead, you will need to rotate video or images in the source application (e.g. Photoshop, Adobe After Effects) before
publishing them to the player.

ADVANCED

Force Resolution: Check this box to have the player output the selected Screen resolution even if the display reports over HDMI/VGA
that it does not support this resolution. If this box is unchecked, the player will attempt to use the selected Screen resolution first, but will
then fall back to the highest resolution supported by the display if it is unsupported.

Full resolution graphics: Check this box to enable full-resolution graphics for the selected Screen resolution. When this box is
checked, the graphics plane (images, text, HTML animations, etc.) is rendered at the same size as the video output, rather than being
upscaled to the output resolution after rendering. This option is only available for certain video modes larger than 1920x1200; all smaller
video modes use full-resolution graphics automatically. This setting is subject to additional restrictions based on the resolution and
player model-see here for full details.

Enable YCbCr 10-bit output: Check this box to output a 10-bit color video signal to the connected display. See the video encoding FAQ
for more details on supported 4K color spaces and bit depths.
Video zone configuration: Determine how video resources will be divvied up in the presentation:

® Standard: You can have one or two video zones (depending on whether your player model supports dual decode), and these
zones can play video files up to the maximum resolution (either HD or 4K) supported by your player model.

® Mosaic: You can have more than two video zones. The maximum number of video zones depends on the Maximum content
resolution setting in the Edit > Layout tab: The smaller the maximum resolution, the more video zones you can add.

Monitor overscan: Select an overscan setting to determine how the content fills the display screen.
®* No overscan — use full screen: Displays content to the edge of the video signal.
® Overscan — action safe: Restricts the display area to a size that is compatible with most displays.
® QOverscan —title safe: Restricts the display area to a size that is much smaller than the generated video signal.

Overscan is necessary with some older television screens that cut off content at the edges of the screen.

Click Create when you are finished configuring the presentation. The Template window will open.

Selecting a Template

Use the

View dropdown list to choose between "System Templates" and "User Defined Templates" (see the Customizing Zone Layouts section to

learn more about creating User Defined Templates). Select a multi-zone template you wish to use and click Choose—Remember that you can
edit the zone layout at any time after choosing a template.
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To add content to your zones, first designate a folder on your computer as your Media Library. This will make it easy to drag and drop image,
video, and audio files into a zone playlist from a scrollable list of thumbnails.

FileFdi

1. Under Media Library, select the files tab.

2. Click to open the file browser.

3. Navigate to the folder where your content is stored.
4. Click OK.

Note
Note: If your content folder contains large files, it may take a while for the thumbnail images to appear.

@ New Multi-Zone Presentation - XD232 - BrightAuthor

==

BrightAuthor

Use the dropdown menu under Zone to select a zone, then add media files to the zone by dragging files from the Media Library to the playlist
area. You can do the following when adding media files:

Select a series of adjacent media files — Hold the Shift key as you select the files in the Media Library.
Select a group of non-adjacent files — Hold the Ctrl key as you select the files in the Media Library.

Refresh the Media Library — Click . This will update the Media Library with any changes to the corresponding folder on your computer.
Move up to the parent directory of the current folder — Click .

Move to a sub-directory of the current folder — Click a file thumbnail in the Media Library.

Tip
You can also drag and drop media files directly into the playlist from a Windows Explorer window.

Editing the Zone Playlist

Once you've added media files to a zone, you can modify it by doing any of the following:

Remove an item from the playlist — Click an item in the playlist area and press the Delete or Backspace key.
Change the order in which an item plays — Click and drag an item to a new position in the playlist.
Rename the playlist — Click Edit in the upper-right corner of the playlist area.

Change the playlist view — Click the list/tile icon in the top-right of the playlist area to change the playlist
view. Switching to a list view allows you to see the parameters of all media items and states in the

playlist.
Replace media files in the playlist — Go to File > Replace media files. The Replace Media Files wind
ow allows you to replace files within media states without having to drag and drop individual files. This [ imteractive ECIT

is useful if you need to update a large number of media files in your playlist or if you want to ensure the
playlist order is preserved.

®* Replacement Media Folder: Click Browse to select the folder that contains the files you want to add. This can be the same
folder as your Media Library, or another folder.

® Preserve state names: Check this box to preserve the names of the media states in the playlist. If this box is unchecked, the
current media states will automatically take on the names of the new media files.

® Presentation Media Files: For each file listed under Current Media Files, select a new file using the dropdown list beneath Rep
lacement Media File.



Editing Media Playback Options

To edit the playback settings of a media item, double-click the thumbnail in the playlist area (or right-click and select Edit), then choose the
settings you want to apply to the selected item:

®* Image files: Specify the following:
®* Time on Screen: The amount of time (in seconds) that the image displays in a zone before transitioning to the next item.
® Transition: The transition effect that occurs from the previous media item to this image.
® Transition Duration: The duration (in seconds) of the transition effect.

® Video files: Specify the Volume of the video.

® Audio files: Specify the Volume of the audio track.

. m Edit Image Parameters &J

Time on screen: 6

Transstion: | Mo effect -

Transition Duration (secondsk: 1.0

0K || Caneat |

To edit settings for multiple items, press the Ctrl key and select items in the playlist. On the menu bar, select Edit > Selected Items, and then
choose the settings you want to apply to the selected items. Note that the selected items must all be the same media or state type for this to work.

Next Steps

Now that you've created your multi-zone presentation, save it by navigating to File > Save [project name] (make sure you have the Edit tab
selected). Then, do any of the following:

® Publish the presentation — Click the Publish tab and select your publishing method. See the Publishing Presentations section for more
instructions.

® Export the presentation — Navigate to File > Export [project name]. This saves the presentation project as a package that can be
opened by BrightAuthor instances on other computers.

® Save the presentation using a new name or location — Navigate to File > Save [project name] As.
® Create another presentation — Navigate to File > New Presentation.

Customizing Zone Layouts
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® Saving the Zone Layout as a Template

Tip
See this tutorial video for an overview of zone layouts.

If the system zone templates do not meet your needs, you can manually edit the zone layout of your presentation. You can then save it as a
user-defined template for use with future presentations. Once you have created a presentation project via File > New Presentation, click Layout
(below the Edit tab) and customize the zones by doing any of the following:

® Rename the zone — Enter a new name for the zone in the Name field.
® Add a zone — Click Add zone. Enter a Zone name, select the Zone type, and then click OK.
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Delete a zone — Click the zone and press the Delete key on your keyboard.
Change the position of a zone manually — Click and hold a zone. Then drag it to the desired position.
Change the position of a zone using coordinates — Enter the Position information. The X and Y values correspond to the horizontal and

vertical position (in pixels) of the top-left corner of the zone. Using coordinates to specify the position allows for exact alignment with other
zones.

Resize a zone manually — Click and hold one of the marks around the edge of a zone. Then drag it to create the desired zone size and
shape.

Resize a zone using pixel values — Specify the Size information. The W and H values correspond to the width and height of the zone (in
pixels).

Make zones equal in size — Press Ctrl and select the zones you want to resize. On the menu bar, click Format > Make same size and
select a resize option.

Align multiple zones — Press Ctrl and select the zones you want to align. On the menu bar, click Format > Align and select an alignment
option.

Center one or more zones — Select a single zone or press Ctrl and select the zones you want to center. On the menu bar, click Format >
Center in form and select Horizontally or Vertically.
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The preview image is always displayed as landscape. If you're creating a portrait-mode presentation, refer to the portrait image on the
left to see a more accurate representation of the screen layout.

i ng Zones

You can place multiple zones in the same screen area and use transparency and z-ordering options to creating layering effects. For example, you
can place a Ticker or Clock zone on top of a Video Only zone and then edit the transparency of the Ticker or Clock zone (in the Zone Properties)
to control how much of the underlying video shows through.

There can be three layers (or "planes") in a multi-zone presentation. Each of these planes can be ordered in relation to the others:

Graphics Plane: This plane includes all Ticker, Clock, and Images zones (as well as the Video or Images zone if it's currently displaying
an image or HTML page). Note that the layering of graphics zones with respect to each other can be unpredictable, and may change if
the player firmware is updated or some other presentation setting is changed.

Video Plane 1: This plane consists of a Video Only or Background Image zone (or a Video or Images zone if it's currently displaying
video). The Background Image zone uses the video decoder to display an image, so it counts as a video plane.

Video Plane 2: This plane consists of a second Video Only or Video or Images zone (if it's displaying video).

Tip



If you want to place an image behind a graphics element, use a Background Image zone to display the image.

Use the following options to edit the layering of the three planes:

® Video Position Z: (XT, XD, and 4K models only): Edit the z-ordering of one video plane in relation to another.
® Front: Places the zone in front of another Video Only zone or Video or Images zone.
® Back: Places the zone behind another Video Only zone or Video or Images zone.
® Graphics plane z position: Edit the z-ordering of the graphics plane in relation to the video plane(s).
® Front: Places the graphics plane (including all Ticker, Clock and Images zones) in front of the video plane(s).

® Between: Places the graphics plane between two video planes. If there is only one video plane, the graphics plane will appear
behind it.

® Back: Places the graphics plane behind the video plane(s).

Addi ng Mosai ¢ Vi deo Zones

If you set the Video zone configuration to Mosaic when creating your presentation, you will need to perform extra steps when adding Video
Only or Video or Images zones:

1. Delete any video zones that were created with the presentation template.
2. Click Add Zone and select a Video Only or Video or Images zone.

3. Select a Maximum Content Resolution. This will determine the maximum resolution of video files you can add to the zone, as well as
the maximum number of video zones you can add to your presentation. The maximum number of zones will also depend on the player
model.

4. Use the Add Zone button to create additional video zones as desired. For each additional zone, you can select smaller maximum
resolutions, but you cannot change the initial maximum resolution unless you remove all video zones from the presentation.

@ Mew Zone ﬁ

Zone name: Mosaic Zone 1

Zone Type
Video or Images

@ Video Only

! Images

! Audic Only

! Enhanced Audio

! Ticker

0 Clock

Background Image

Maximum Content Resclution
' 4K (3840 x 2160)
! HD (1920 x 1080)
@ SD (720 x 480)
1 CIF (352 x 288)
P QCIF (176 x 144)

OK 1| Cancel

Maximum Usage

The maximum allowed number of videos per video decoder are listed below; the limit may be lower depending on a number of factors, including
interlacing and frame rate.

® 4K decoder:
® 1 4K video
® 2 HD videos
® 4 SD videos
® 8 CIF videos
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® 10 QCIF videos
® HD decoder:

® 04K videos

® 1 HD video

® 3 SD videos

® 4 CIF videos

® 5 QCIF videos

BrightAuthor combines the capabilities of all video decoders on the player to create a maximum number of available videos. The available video
decoders for Mosaic Mode vary by model:

® XTx43, 4Kx42: 1 4K and 1 HD decoder

® XDx33: 1 4K decoder or 2 HD decoders

® XDx32: 2 HD decoders

® HDx23, HDx22, HO523, HS123: 1 HD decoder

Savi ng the Zone Layout as a Tenplate

Once you've created a zone layout, you can save it as a user-defined template. To save the layout as a template, click Save Template (in the
lower-left portion of the screen). Enter a name for the template, and then click OK.

To use the customer template when creating a new presentation, click the View dropdown list in the upper-right corner of the Template window
and elect User Defined Templates to view your templates.

Interactive Presentations
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Tip
This tutorial video outlines the basic steps for creating an interactive presentation.

You can use BrightAuthor to create interactive presentations. Interactive presentations respond to interactive events, such as input from buttons
or other GPIO devices, or from devices connected to a BrightSign communication port. The supported communication methods vary by BrightSign
model:

® USB devices (such as touch screens, mice, keyboards, barcode scanners, IR remote controls): XT1143, 4K1042, 4K1142,
XD1033, XD1032, XD1132, XD1030, XD1230, HD1023, HD1022, HD1020, LS423, LS322, LS422

®* Networked devices: All 4K, XD, and LS models, as well as the HD223, HD1023, HD222, HD1022, HD220, HD1020, and AU320

® Serial devices: XT1143, 4K1042, 4K1142, XD1033, XD1032, XD1132, XD1030, XD1230, HD1023, HD1022, LS423, HD1020, and
AU320. Note that some models do not fully support RS-232 signaling.

® GPIO devices: All models except the LS423
® Infrared (IR) devices: All XT, 4K, and XD models

Creating an Interactive Presentation

Follow these steps to create an interactive playlist in a presentation:

1. Open or create a presentation project. If you haven't created a presentation before, see the Full-Screen Presentations section for details.
2. Under Media Library, click the

r

button and select a folder that contains the files you want to include in your
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presentation.
3. Select a zone you want to make interactive.

4. Make the zone interactive: In the upper-right portion of the screen beside Playlis

t type, click Interactive. Playlist type: @ non-interactive D interactive EDIT
5. Drag the desired content into the playlist area. This can include media from the fi

les tab and states from the other tab.

Note
Multi-zone presentations can include both non-interactive and interactive zones.

Choosing a Home Screen

The Home Screen is the first media file in an interactive playlist. It is where the interactive presentation begins (within a particular zone). Home
Screens usually include one of the following:

® An attract video that loops until the user provides input
® A list of options from which the user can choose the next action (e.g. an Interactive Menu)

By default, the first item you drag into an interactive playlist will become the Home Screen. It is identified by the

L7
Home icon. You can change the Home Screen at any time by double-clicking the desired file in the playlist and checking the Set as initial state b
oX.
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Defining Interactive Events

Interactive events link files in the playlist and determine what must occur before one file transitions to another. In the user interface, files are
referred to as “states,” where the current file is the “current state,” and the file transitioned to is the “next state.” We refer to creating and linking
interactive events between states will be referred to as “defining events”.

The easiest way to define events is to use the Events Toolbar, which is located at the top of the playlist area.

1. In the Event Toolbar, click the interactive event icon that corresponds to the type of event you want to define. For example, to define
what happens when a user presses button 1 on a GPIO button board, click .

2. Click (and hold) the file name below the thumbnail image of the current state.
3. Drag the hand pointer to the thumbnail image of the media file you want to play next (i.e. the next state).



You can also define events using the events tab:

1. Select the events tab under Media Library.
2. Drag the event icon onto the thumbnail of a state. This will be the state that the event transitions away from.

3. An Event window will automatically open. Here, you can specify the state that the event will transition to. See the Editing Interactive
Events section for more details.

Interactive events can start with any item and correspond to any other item in the playlist. For example, you can set the first interaction to display
an image when the user presses button 1 from the Home screen. By defining a new event with the same event icon, you can set a second
interaction to display another media file when the user presses button 1 again.

Important
Make sure your defined events work in a loop. In the playlist shown below, a user can transition from the Home Screen to the other

images by pressing button 1 or button 2. After a set period of time (indicated by the timeout events), the presentation will return to the
Home Screen.

Upload to network
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Defining Multiple Events

You can define more than one event at a time. This is useful if you want multiple states to transition to a single state using the same event type.

1. Right-click and drag the cursor within the playlist area to select multiple states. Alternatively, you can pres and hold Ctrl to select multiple
states.

2. With the states selected, define the interactive event from one media file, and it will then be created for all selected files.

Customizing the Interactive Playlist

In the upper-right portion of the screen, you can use the Zoom control to adjust your view of the playlist area. When you switch between multiple
interactive zones, BrightAuthor will remember the zoom setting last used for each zone.

If you don't see the event you want in the playlist toolbar, click the arrow to the left of the Zoom control. Here, you can add or remove event icon
buttons from your toolbar.
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Editing Interactive Events

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

Tip
See this page for a list and description of interactive events.

You can further adjust how your media files transition from state to state by double-clicking Event icons (or right-clicking and then clicking Edit).
For example, if you create an event with the Timeout Event icon, the media file displayed in your presentation will transition to the next state after
a certain period of time. You can adjust this time period by double-clicking the Timeout Event icon between the two media files and changing the
duration in the Timeout Event window.

Double-clicking an event icon opens the Event window, which is the same window that automatically opens when you drag an event icon from the
events tab onto the playlist. The Event window will present options specific to the type of interactive event chosen, along with the following
options:

® Transition to new state: The presentation will transition to a new state when the interactive event occurs. Use the dropdown list to
specify which state in the playlist will be next.
® Return to prior state: The presentation will revert to the previous media file when the interactive event occurs.

® Remain on current state: The state will not change when the interactive event occurs. This option is useful when you need to perform
actions that are not immediately visible, such as sending a UDP command, altering the value of a user variable, or lowering the volume.
These actions are performed by attaching commands to an event; see the Commands page for more details.

@ Timeout Event l = |
Main | Advanced

Specify timeout (seconds) 10

Start state: kitteh.jpg
@) Transition to new state

Specify next state: Kitteh 2,jpg -
~) Return to prior state

) Remain on current state

f ok || cancel
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Editing Media Properties

~ BrightAuthor Version 4.7

® Version 4.6
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® Previous Versions

You can edit individual files in an interactive playlist by right-clicking the file icon and selecting Edit. The Media Properties window will open.

® State name: The current state name as it appears in the interactive playlist. You can edit the name in this field.

® Current file: The filename of the current file associated with the state. This field cannot be edited.

® Select different file: Use the dropdown menu to select a different media file to associate with the state. This is useful for preserving
events and commands that were defined for the original file. The change will not go into effect until the Update button is pressed (even if
you click OK). If you need to replace all instances of a particular media file within your presentation, navigate to File > Replace Media
Files.

® Transition:(Image states only) Use the dropdown list to select a special transition effect that will occur when the image appears on the
display.

® Transition duration:(Image states only) Specify how long the transition effect will take to complete. This duration should be less than the
amount of time the image is displayed on screen.

®* Loop media: (Video states only) Choose this option to loop the video indefinitely when no Media End event is attached to the state.

® Hold last video frame: (Video states only) Choose this option to display the last frame of the video after it ends when no Media End
event is attached to the state.

Click the Advanced tab to store the image in the cache, set display mode for video files (2D, 3D side-by-side, 3D top-over-bottom), or add
commands.

@D Media Properties = | B @D Media Properties ==
Main | Advanced | Notes Main | Advanced | Notes
State name:  kitteh,jpg State name: Jupiter_Rotation.mpd
Current file:  kittehjpg Current file: Jupiter_Rotation.mpd
Select different file: | kittehjpg | | Update Select different file: | Jupiter_Rotation.mpd v| |Update
Transition: |Nu effect =| Loop media if no media end 5

transition is specified

Hold last video frame if no media
end transition is specified

Transition duration: 1.0

A 7Y |
Set as initial state: s Set a5 initial state: | Yes

o[ concel | Cancel

Tip
You can delete a defined event (or file) at any time by clicking the icon/thumbnail and pressing Delete on your keyboard.

Copying, Importing, Exporting States

w BrightAuthor Version 4.7
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® Previous Versions

All states can be copied, exported, and imported. Copying or exporting a state (or set of states) will also copy all commands and notes attached to
that state. This process will only preserve events that transition among the set of copied/exported states.

® Copying: With a state selected, right-click the state and select Copy, navigate to Edit > Copy, or press Ctrl+C. You can also copy
multiple states by holding down Ctrl while selecting the desired states.

® Pasting: Right-click a playlist or Super State canvas and select Paste, navigate to Edit > Paste, or press Ctrl+V. Note that a pasted state
will appear at the same canvas position as the original state; if the original state has not moved, it may be difficult to tell that the paste
action occurred.

® Exporting: With a state selected, right-click the state and select Export or navigate to Edit > Export. You can also place multiple states
into a single export file by holding down Ctrl while selecting the desired states. The exported state(s) will be saved as a single file with a .
bse extension in the specified directory.

® Importing: Right-click a playlist or Super State canvas and select Import States, or navigate to Edit > Import States. You will be
prompted to select the .bse file containing the state(s) you wish to export.

Commands
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Commands allow you to add extended functionality to your presentations. Commands can help you control displays and devices (Display On,
GPIO On, etc.) or perform additional actions when interactive events are performed (Pause Video, Set Volume, etc.).

You can add commands to interactive events or to states. If you add a command to the interactive event, the command will be performed when
that event occurs. If you want to add a command to a state, you will need to choose between an Entry Command (executed upon entering the
state) or an Exit Command (executed upon leaving the state). Some commands (such as Switch Presentation) can only be added to interactive
events.

@ Media Properties

Advanced | Notes

State name: hu't'teh.jpg

Current file:  kitteh.jpg

different file: |Kittehjpg

Transition: [No effect -

Addi ng Conmands to an Event

Follow these steps to add a command to an interactive event:

. Double-click the event icon in the playlist area.

. Click the Advanced tab.

. Click Add Command.

. Use the dropdown list under Commands to choose the category of the command.
. Use further dropdown lists and fields to set additional Command Parameters.

a s~ 0N PP

Addi ng Conmands to a State or Media File

Follow these steps to add a command to a state or media file:

. Double-click the media file thumbnail in the playlist area.

. Click the Advanced tab.

. In the Entry Commands or Exit Commands section, click Add Command.

. Use the dropdown list to specify a command.

. Use further dropdown lists and fields to set additional parameters for the command.

g b~ WON B
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Command Types

This section outlines available command categories and types.

Set Panel Output

Configures the LED output of an attached USB device (BP200, BP900, or BLC400)

If you're connecting a single BP/BLC device to a player, use the "A" version of the device (e.g. "BP900A"). If you plan to connect
multiple BP/BLC devices to a player, see here to learn more about using the A, B, C enumerations.

BP900/BP200

® Button number: Select a single button LED to affect, or select All to affect all button LEDs on the board.
® Action: Select one of the following actions:

¢ Off: Disables an output that was previously set on the button LED(s). This action does not disable the default lighting effect that
occurs when a button is pressed.

® On: Displays a solid pattern.

® Fast Blink: Displays a quick flashing pattern.

®* Medium Blink: Displays a moderate flashing pattern.
® Slow Blink: Displays a slow flashing pattern.

BLC400

Note

You cannot use multiple BLC commands to simultaneously trigger multiple LED patterns (e.g. a breathe effect on channel A and a
marquee effect on channel B). BLC commands that belong to the same event/state will trigger in descending order at slightly offset
intervals.

® Intensity: Triggers each channel at the specified intensity. Specifying a Time of zero causes the channel(s) to reach that intensity
immediately, while a non-zero value causes them to ramp up over the specified interval.

Tip
To turn off a channel, set the Intensity to zero.

® Blink: Triggers each channel at a Fast, Medium, or Slow speed.

® Breathe: Causes a channel to ramp up from the specified Min to the specified Max intensity over the specified Time interval.
The channel(s) will then ramp down to the specified Min over the same Time interval.

® Strobe: Triggers each channel in short bursts at maximum intensity. The Time parameter specifies how frequently the channel(s) will
trigger; values greater than 1000ms will default to 1000ms.

® Marquee: Triggers each channel in succession. You will need to specify the marquee type:
® Loop: Cycles through the channels (A B C D) continuously.
® Back and forth: Cycles from Ato Dto A (A B C D C B A) continuously.
® Play once: Performs a singe cycle through the channels (A B C D).
® Random: Cycles through the channels in continuous random order (e.g. CADBADCBDBCA).

You will also need to specify the pattern timing for marquee effects:

® Hard on/off: Channels can only be off or at full brightness, without transitions. The On time specifies how long each channel
remains at full brightness, while the Off time specifies the interval between one channel turning off and the next turning on.

® Smooth delay: After completing its On time, a channel will decrease in brightness until it turns off completely. Then, once the Of
f time has transpired, the next channel will increase in brightness to full intensity.

® Smooth full overlap: The current channel decreases in brightness only when the next channel has reached full brightness.

® Smooth partial overlap: The current channel decreases in brightness while the next channel simultaneously increases in
brightness (i.e. the rate of increase and decrease are inversely proportional).

Note
For the "Smooth" options, the ramp up and ramp down intervals are fixed at approximately 20 percent of the On time.

Set Audio

Changes the audio settings of a zone. Note that triggering the Set Audio command while an audio/video file is playing will cause playback to
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freeze (though the player will still respond to Interactive Events like Timeout, UDP Input, etc). You can also use the Set Audio command while
displaying an image file, or you can attach the Set Audio command to an interactive event that transitions to or from an audio/video file.

® Zone: Specifies the zone to which the audio settings will apply.
® Audio Output: Enables or disables the Analog Stereo, HDMI, and SPDIF audio outputs.

® Pass through: Supplies the un-decoded audio signal through the HDMI/SPDIF connector. Use this option if the presentation
audio (for example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the HDMI/SPDIF connector.
® Audio Mixing: Specifies which part of the audio signal to send.

® Stereo: Sends both left and right audio signals.

® Left: Sends the left audio signal only.

® Right: Sends the right audio signal only.

Connector Volume

Changes the audio volume of a specific connector.

® Set: Specifies the volume level. Select the Audio (i.e. analog), HDMI, or SPDIF connector in the dropdown list and enter a volume value
between 0 and 100 in the field.

® Increment: Specifies how much the volume level increases with each interaction. Select the Audio (i.e. analog), HDMI, or SPDIF
connector in the dropdown list.

® Decrement: Specifies how much the volume level decreases with each interaction. Select the Audio (i.e. analog), HDMI, or SPDIF
connector in the dropdown list.

® Mute: Turns the connector audio output off. Use the checkboxes to select among the Audio (i.e. analog), HDMI, and SPDIF connectors.

® Unmute: Turns the connector audio output on. Use the checkboxes to select among the Audio (i.e. analog), HDMI, and SPDIF
connectors.

Zone Volume

Sets the volume for a zone. Note that the Connector Volume settings take precedence over the Zone Volume settings when both are active in a
presentation.

® Set: Specifies an absolute volume level for a zone. Use the dropdown menu to select the zone to which this command applies and enter
a volume value between 0 and 100.

® Increment: Specifies how much the volume level increases with each interaction. Use the dropdown menu to select the zone to which
this command applies and enter an increment amount.

® Decrement: Specifies how much the volume level decreases with each interaction. Use the dropdown menu to select the zone to which
this command applies and enter a decrement amount.

Send

Sends information using the following interfaces:

® Send Zone Message: Triggers a Zone Message event with the same command parameter as the Send Zone Message command.

® UDP: Sends a message to a networked device using the UDP protocol. Use the File > Presentation Properties > Interactive tab to
specify the destination address and port for UDP messages.

® Send IR Remote: Sends a command via the 3.5mm IR Out port (XT, 4K, and XD models only).
Send IR Remote (Pronto): Sends a command using Pronto Hex Code (PHC) via the 3.5mm IR Out port (XT, 4K, and XD models only).
Serial string (EOL): Sends the specified string to the specified serial port. This command adds a carrier return at the end of the string.

Serial string (no EOL): Sends the specified string to the specified serial port. This command does not add a carrier return at the end of
the string.

Serial byte: Sends the specified byte to the specified serial port. The byte must be entered in decimal format (0-255).
Serial bytes (comma separated): Sends the specified bytes to the specified serial port in comma-separated format.

Note
Most standard serial devices enumerate on port O (on the HO523, they will enumerate on port 1). If you are connecting a USB-serial
device, it will enumerate on port 2.

Send Plugin Message: Sends the specified string to a custom script plugin attached to the presentation. Use the dropdown menu to
select a desired script plugin. Please see the Parsers and Plugins tech note for more information on creating custom scripts that can
receive plugin messages.

Link

Connects presentation zones or synchronizes BrightSign players.
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® Synchronize: Specifies the Synchronization trigger.
® Zones: Specifies the Link Zones trigger.

Tip
This tutorial video describes how to use Link Zones commands to create a synchronized presentation.

GPIO
Changes the state of GPIO buttons that are configured for output.

® On: Turns on the specified GPIO button.

® Off: Turns off the specified GPIO button.
® Set State: Allows you to turn multiple GPIO buttons on or off. The buttons are specified as bits in an integer value; see the

documentation for roControlPort.SetWholeState() for an example.

Note
The "button" numbers described below are not the same as GPIO "pin" numbers: Some pins act as power supply or ground, so they are

not included in the button numbering scheme. See the hardware manual associated with your player model to view a mapping of
buttons to pins.

Video

Changes the video playback settings:

® Pause video: Pauses video playback.

® Resume video: Resumes video playback.

® Enable monitor power save mode: Turns the monitor's power saving mode on.
® Disable monitor power save mode: Turns the monitor's power saving mode off.

BrightControl
Sends commands to monitors and other digital signage displays:

® Display On: Turns the display on.

® Display Off: Turns the display off.
® Send Ascii String: Sends a CEC command. The provided string will be converted to hexadecimal format before being sent to the

display.

Important
BrightControl CEC command strings cannot contain spaces.

® Set Philips Volume: Sets the Philips TV volume.

Beacons

Controls beacons that are part of the presentation. These beacons can be added in the Presentation Properties window.

® Start Beacon: Enables the selected beacon.
® Stop Beacon: Disables the selected beacon

Other
Sends various commands that are not contained within the above categories.

® Pause: Pauses presentation playback for a specified number of milliseconds.
® Reboot: Reboots the BrightSign player.

® Set Variable: Sets a new value for the specified User Variable.

® Increment Variable: Increases the value of the specified User Variable by 1.

® Decrement Variable: Decreases the value of the specified User Variable by 1.

Note
The Increment Variable and Decrement Variable commands have the following special rules:

® |f the command is used on a number with a decimal value, the number will be converted to an integer by removing the decimal
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(i.e. the number is always rounded down).
® |f the command is used on a string, the value will be converted to a zero. Then the increment/decrement action will be
performed on the zero. Negative numbers are also possible.

® Reset Variable: Resets the specified User Variable to its current default value.
® Reset Variables: Resets all User VVariables to their current default values and all Media Counters to zero.

® Switch to Presentation: Switches to a different presentation. Before using this command, you must add additional presentation(s) to the
Switch Presentations tab in the Presentation Properties window. The following settings of must be identical for both presentations:
BrightSign Model, Connector Type, Screen Resolution, Monitor Orientation, and Monitor Overscan.

® Specify Presentation: Choose the presentation to switch to from the dropdown list.

® Specify via user variable: Choose the User Variable that will determine which presentation to switch to. The value of the User
Variable must be identical to the name given to the target presentation in the Switch Presentations tab.

Update Data Feed: Updates the content of the specified Data Feed.

® Resize Zone: Repositions and/or resizes the specified zone. Select the zone you wish to modify. Then enter an X and Y coordinate
(corresponding to the top-left corner of the zone), as well as W and H (width and height) values for the zone.

Hide Zone: Hides the specified zone from view.
® Show Zone: Shows the specified zone if it is hidden.

Note
The Hide Zone and Show Zone commands do not affect Audio Only, Enhanced Audio, or Background Image zones.

Conditional Targets
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Conditional targets allow you to change the settings of an event transition depending on the value of a User Variable. You can set multiple
conditional targets for a single event, and you can specify new commands to occur when the conditional target is met. With this feature, you can
change the behavior of a presentation based on a wide array of interactive and networked conditions.

Note
Conditional Targets are only available if you have created one or more User Variables in the File > Presentation Properties >
Variables window.

Follow these steps to add a conditional target to an event:

. Select the Advanced tab while creating or editing an event.

. Click the Set Conditional Targets button.

. Click Add Conditional Target in the Conditional Targets window (you can also click a preexisting Conditional Target to edit it).
. In the first dropdown menu, select the User Variable that will trigger the Conditional Target.

. In the second dropdown menu, select the conditional operator that will compare the current value of the variable against the value set in
the field to the right. The transition behavior and Commands you specify in this window will only occur when the entire statement—the
variable, the operator, and the target value—is true. These are the conditional operators that are currently available:
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a. Between
b. Less than (<)
¢. Less than or equal (<=) @ Conditional Target L&J
d. Equals (=)
e. Greater than or equal (>=) Main | Advanced
>
f. Greater than (>) Variable [‘u"ariable 1 v| [Greaher thanorequal ~| 42
6. Determine what will happen if the
Conditional Target is met: © Transition to new state
a. Transition to new state: The Specify next state: |kitteh,jpg -

presentation will transition to
a new state. Use the
dropdown list to specify a ! Remain on current state
new state.
b. Return to prior state: The OK ” Cancel
presentation will return to the
previous state. .

| Return to prior state
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c. Remain on current state:
The state will not change.

7. Select the Advanced tab to add Commands to the Conditional Target. Commands will trigger when the target is met. See the Command
s page for more information.
8. Click OK to save the conditional target.

Note

In the target value field, you can enter either a fixed integer or the name of another user variable (e.g. “when Variable A is equal to 42"
or “when Variable A is equal to Variable B"). For user variables, you must enter the name of a target variable between two sets of dollar
signs (e.g. “$$my_variable$$").

Dynamic User Variables
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There are several ways to change the values of User Variables in an interactive presentation. See the Variables page for more information about
creating User Variables and setting default values.

Web Browser

You can view and update User Variables using a web browser. To do this, your computer must be connected to the same local network as the
BrightSign player, and you must enable the Local Web Server on the player:

. Navigate to Tools > Setup BrightSign Unit.

. Check the Enable local web server box.

. Enter a user name and password for the web server if desired.

. Set the rest of the options in the BrightSign Unit Setup window and complete the unit configuration process (see the Setting up
BrightSign Players for more information).

. Wait for the player to complete the entire boot process.

6. Use the address bar of a web browser to navigate to device IP port 8008. For example, if the IP address of your BrightSign player is
192.168.1.2, then you would enter 192.168.1.2:8008. You will be provided with a web page that lists all User Variables and allows you to

modify them.
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Tip
If you do not know the IP address of your player, you can obtain it by powering up the player without an SD card inserted: The IP
address, along with other information about the unit, will be displayed on screen once the unit boots.

UDP, Serial Input, and Plugin Message Events
You can change the value of User Variables using the input from a UDP Input, Serial Input, or Plugin Message event:

1. Create a new UDP Input, Serial Input, or Plugin Message (or edit an existing one).
2. If using a UDP Input event, type <any> into the Specify UDP input field. The field can contain either the wildcard designator by itself or
additional text with the wildcard designator (e.g. "message_<any>").
3. If you are using a Serial Input or Plugin Message event, enter the <*> wildcard designator into the Specify serial input or Plugin messa
ge field. The field can contain either the wildcard designator by itself or additional text with the wildcard designator (e.g. "message_<*>").
4. Check the box labeled Assign input to variable.
a. Select Specify fixed variable if you want to choose a fixed User Variable in the BrightAuthor presentation. Use the dropdown list
to choose which User Variable the UDP input will modify. The UDP/serial string must be input in the form of <variable value>.
b. Select Input specifies variable if you want the UDP/serial input string to dynamically specify which User Variable is being
modified. The UDP/serial string must be input in the form of <variable name> : <variable value>.
5. Check the box labeled Assign wildcard to variable to specify the value of a User Variable using the <any> or <*> wildcard designator.
Select the User Variable to modify using the dropdown menu to the right.

6. Press OK to save the settings.
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Note

If you select Input specifies variable, you can modify more than one User Variable with a single event. Use the following UDP/Serial
string: "<variable name> : <variable value> !! <variable name> : <variable value>"

Note
Wildcards are only supported when the serial port is using the ASCII protocol, not when using the Binary protocol.

It is possible to check both Assign input to variable and Input specifies variable boxes for more complex functionality. For example,
you use Specify fixed variable to assign the entire UDP string to one variable, while at the same time using Assign wildcard to
variable to assign a subset of that string to another variable.

Editing Zones

~ BrightAuthor Version 4.7
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This section describes how to edit zone properties. Follow these steps to open the Zone Properties menu for a zone:

. Open a presentation project by clicking File > Open Presentation.

. Click the Edit tab and select Playlist.

Under Zone in the upper-left portion of the screen, select the zone you wish to edit.

. Click Zone Properties. Different options will appear depending on the type of zone that is selected (see the sub-pages for details).
. Repeat steps 2 — 4 for each zone you want to edit in your presentation.
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Use the Zone Properties window of a Video or Images Zone to edit the following:

View mode: Determines how videos will be scaled to fit in the zone. This option has no effect if the video and the zone are the same
size.

® Scale to Fill: Scales the video to fill the zone without maintaining the aspect ratio. The video will appear stretched or squashed if
the aspect ratios of the video and zone do not match.

® Letterboxed and Centered: Centers the video and adds black borders on the top and bottom. The aspect ratio is maintained.

® Fill Screen and Centered: Centers the video and fills the zone. The aspect ratio is maintained, so the video may be cropped if
required.

Note
The Scale to Fill and Fill Screen and Centered options will not remove letterboxing if it's part of the video file.
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Scale to fit Letterboxed and centered Fill screen and centered

Audio Output: Configure audio outputs for the zone.

Note
The Analog Stereo and and SPDIF outputs are only available on certain player models.

® Analog Stereo: Check this box to enable audio output via the 3.5mm audio connector (or USB Type C connector on the LS423).
® HDMI: Check this box to enable audio output via the HDMI connector.

® Pass through: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for
example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the HDMI connector.
® SPDIF: Check this box to enable audio output via SPDIF.

® Pass through: Supplies the un-decoded audio signal through the SPDIF connector. Use this option if the zone audio
(for example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the SPDIF connector.
Audio Mixing: Choose the mixing of the audio output:
® Stereo: Outputs both left and right audio signals.
® Left: Outputs the left audio signal only.
® Right: Outputs the right audio signal only.
Image mode: Use the dropdown list to specify a setting for images.
® Center Image: Centers the image without scaling. This may result in cropping if the image is too large.
® Scale to Fit: Scales the image to fit the zone. The image is displayed as large as possible while keeping the correct aspect ratio.
® Scale to Fill and Crop: Scales the image to completely fill the zone while maintaining the aspect ratio.
® Scale to Fill: Scales the image to fill the zone without maintaining the aspect ratio.
Initial volume (Audio): Sets the initial volume for audio files (0-100).
Initial volume (Video): Sets the initial volume for video files (0-100).
Minimum Volume: Sets the minimum volume for the zone (0-100).
Maximum Volume: Sets the maximum volume for the zone (0-100).

Note
The Maximum Volume setting will be overridden by other volume settings in a presentation, including the Initial Volume setting for the
zone and volume commands attached to events or states.
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Video Only Zones

w BrightAuthor Version 4.7

® \ersion 4.6
® Version 4.4
® Previous Versions

Use the Zone Properties window to edit settings for a Video Only zone.

® View Mode: Determines how videos will be scaled to fit in the zone. This option has no effect if the video and the zone are the same size.

® Scale to Fill: Scales the video to fill the zone without maintaining the aspect ratio. The video will appear stretched or squashed if
the aspect ratios of the video and zone do not match.

® Letterboxed and Centered: Centers the video and adds black borders on the top and bottom. The aspect ratio is maintained.

® Fill Screen and Centered: Centers the video and fills the zone. The aspect ratio is maintained, so the video may be cropped if
required.

Note
The Scale to Fill and Fill Screen and Centered options will not remove letterboxing if it's part of the video file.
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® Audio Output: Configure audio outputs for the zone.

Note
The Analog Stereo and and SPDIF outputs are only available on certain player models.

® Analog Stereo: Check this box to enable audio output via the 3.5mm audio connector (or USB Type C connector on the LS423).
® HDMI: Check this box to enable audio output via the HDMI connector.

® Pass through: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for
example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the HDMI connector.
® SPDIF: Check this box to enable audio output via SPDIF.

® Pass through: Supplies the un-decoded audio signal through the SPDIF connector. Use this option if the zone audio
(for example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the SPDIF connector.

¢ Audio Mixing: Choose the mixing of the audio output:

® Stereo: Outputs both left and right audio signals.

® Left: Outputs the left audio signal only.

® Right: Outputs the right audio signal only.
® |nitial volume (Audio): Sets the initial volume for audio files (0-100).
® Initial volume (Video): Sets the initial volume for video files (0-100).
® Minimum Volume: Sets the minimum volume for the zone (0-100).
® Maximum Volume: Sets the maximum volume for the zone (0-100).

Note
The Maximum Volume setting will be overridden by other volume settings in a presentation, including the Initial Volume setting for the
zone and volume commands attached to events or states.

Images Zones

w BrightAuthor Version 4.7
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® Version 4.6
® Version 4.4
® Previous Versions

Use the Image Mode dropdown list to determine how images will be displayed in the zone:

® Center Image: Centers the image without scaling. This may result in cropping if the image is too large.

® Scale to Fit: Scales the image to fit the zone. The image is displayed as large as possible while keeping the correct aspect ratio.
® Scale to Fill and crop: Scales the image to completely fill the zone while maintaining the aspect ratio.

® Scale to Fill: Scales the image to fill the zone without maintaining the aspect ratio.

Audio Only Zones

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

Use the Zone Properties window of an Audio Only zone to edit the following:

® Audio Output: Configure audio outputs for the zone.

Note
The Analog Stereo and and SPDIF outputs are only available on certain player models.

® Analog Stereo: Check this box to enable audio output via the 3.5mm audio connector (or USB Type C connector on the LS423).
* HDMI: Check this box to enable audio output via the HDMI connector.

® Pass through: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for
example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the HDMI connector.
® SPDIF: Check this box to enable audio output via SPDIF.

® Pass through: Supplies the un-decoded audio signal through the SPDIF connector. Use this option if the zone audio
(for example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the SPDIF connector.

® Audio Mixing: Choose the mixing of the audio output:

® Stereo: Outputs both left and right audio signals.

® Left: Outputs the left audio signal only.

® Right: Outputs the right audio signal only.

® |nitial Volume: Set the initial volume for audio files (0-100).
® Minimum Volume: Sets the minimum volume for audio files (0-100).
® Maximum Volume: Sets the maximum volume for audio files (0-100).

Note
The Maximum Volume setting will be overridden by other volume settings in a presentation, including the Initial Volume setting for the
zone and volume commands attached to events or states.
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Enhanced Audio Zones

w BrightAuthor Version 4.7
® \ersion 4.6
® Version 4.4
® Previous Versions

Enhanced Audio zones provide similar functionality Audio Only zones, but allow cross-fading between audio files in the playlist: Fading occurs
from silence at the beginning of the audio playlist and to silence at the end of the audio playlist, while cross-fading occurs between audio files.

Important

Cross-fading will not work between audio tracks if they have different sampling rates (for example, if the first file is sampled at 48kHz
and the second is sampled at 44kHz).

Use the Zone Properties window of an Enhanced Audio zone to edit the following:

® Audio Output: Configure audio outputs for the zone.

Note
The Analog Stereo and and SPDIF outputs are only available on certain player models.

® Analog Stereo: Check this box to enable audio output via the 3.5mm audio connector (or USB Type C connector on the LS423).
® HDMI: Check this box to enable audio output via the HDMI connector.

® Pass through: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for
example, AC3 Dolby Digital) is being decoded on an external device.
® Stereo: Supplies the decoded audio signal through the HDMI connector.
® SPDIF: Check this box to enable audio output via SPDIF.
® Pass through: Supplies the un-decoded audio signal through the SPDIF connector. Use this option if the zone audio
(for example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the decoded audio signal through the SPDIF connector.
Audio Mixing: Choose the mixing of the audio output:

® Stereo: Outputs both left and right audio signals.

® |eft: Outputs the left audio signal only.

® Right: Outputs the right audio signal only.
Initial Volume: Set the initial volume for audio files (0-100).
Minimum Volume: Sets the minimum volume for audio files (0-100).
Maximum Volume: Sets the maximum volume for audio files (0-100).

Note

The Maximum Volume setting will be overridden by other volume settings in a presentation, including the Initial Volume setting for the
zone and volume commands attached to events or states.
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® Fade(in seconds): Sets the duration of cross-fading between audio files, as well as the fade in and fade out durations at the beginning
and ending of a playlist.

[ @D Edit Zone ) |

Analog Stereo

Audio Output: [C] HoMI Pass through Stereo
("] spDIF Pass through Stereo
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Ticker Zones

= BrightAuthor Version 4.7
® Version 4.6
® Version 4.4
® Previous Versions

Use the Zone Properties window of a Ticker zone to edit the following:

® Number of lines: Set the number of text lines in the Ticker zone.

® Time to display each line: Set how long each line displays in the Ticker zone (in seconds).

Rotation: Use the dropdown list to select the rotation of text in the Ticker zone.

® Alignment: Use the dropdown list to set whether text is left aligned, right aligned, or centered in the Ticker zone.

Note
If you're using a right-to-left language (such as Hebrew or Arabic) in your ticker zone, the right/left alignment settings will be inverted.
For example, setting a ticker zone with an Arabic RSS feed to “Right aligned” will actually align the text to the left side of the zone.

® Text appearance: Specify how the text will appear on screen:
®* Animated: Text appears on screen from left to right (similar to a Teletype-style ticker).
® Static Text: Lines of text appear without any animation.

® Scrolling: Text scrolls across the screen (similar to a news or stock ticker). If this option is selected, the Number of Lines para
meter will be limited to 1 and the Time to Display Each Line parameter will have no effect. Note that this option is not available
for LSx22, HDx20, or HDx10 models (to enable scrolling with the LS423, BrightAuthor version 4.7.0.8 or later is required).

Note

The text can scroll either right-to-left or left-to-right with firmware versions 6.1.37 and later: This scrolling direction is
determined by the language of the first text item used in the Ticker zone (e.g. Spanish text will set the ticker to
right-to-left, while Arabic text will set the ticker to left-to-right).

® Scroll speed:(Scrolling text only) Use the slider to set the scroll speed to 100%, 200%, 300%, or 400% of normal.

® Foreground text color: Click Choose to select a color for the text in the Ticker zone.

® Background text color: Click Choose to select a color for the text background in the Ticker zone.

® Transparency: Use the slider to set the transparency of the text-background color: 0% is fully opaque, while 100% is fully transparent.

® Font: Click Browse to select a font for text in the Ticker zone. You can use any TrueType font. Click Reset to System Font to reset the
font.

Advanced
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Click the Advanced arrow to reveal the following options:

® Background bitmap: Click Browse to navigate to and select a file for a background image.
® Stretch to Fit: Select Yes if you want to stretch the image to fill the zone. Otherwise, select No.
® Safe text region: Define the dimensions of the text region in the zone. If this region is not defined, the text will be displayed to the edge
of the zone.
® X: The horizontal coordinate (in pixels) of the top-left corner of the safe text region.
® Y: The vertical coordinate (in pixels) of the top-left corner of the safe text region.
® Width: The width of the safe text region (in pixels).
® Height: The height of the safe text region (in pixels).

Clock Zones

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

Use the Zone Proprties window of a Ticker zone to edit the following:

® Rotation: Use the dropdown list to select the angle of text rotation in the Clock zone.

® Foreground text color: Click Choose to select a color for the text in the Clock zone.

® Background text color: Click Choose to select a color for the text background in the Clock zone.

® Transparency: Use the slider to set the transparency of the text-background color: 0% is fully opaque, while 100% is fully transparent.

® Font: Click Browse to select a font for text in the Clock zone. You can use any TrueType font. Click Reset to System Font to reset the
font.

Advanced

Click the Advanced arrow to reveal the following options:

® Background bitmap: Click Browse to navigate to and select a file for a background image.
® Stretch to Fit: Select Yes if you want to stretch the image to fill the zone. Otherwise, select No.
® Safe text region: Define the dimensions of the text region in the zone. If this region is not defined, the time/date text will be displayed to
the edge of the zone.
® X: The horizontal coordinate (in pixels) of the top-left corner of the safe text region.
® Y: The vertical coordinate (in pixels) of the top-left corner of the safe text region.
® Width: The width of the safe text region (in pixels).
® Height: The height of the safe text region (in pixels).
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Background Image Zones

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

You cannot edit the Zone Properties for a Background Image zone. If you only want a background color (instead of an image), do not add a
Background Image zone. Instead, change the background screen color in the File > Presentation Properties > Main tab.

Creating Playlists and Feeds

=~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4

® Previous Versions

You can use the Create tab to generate media playlists and text feeds that are hosted on the BSN servers. You can edit these playlists/feeds in
BrightAuthor or the BrightSign Network WebUI, and the changes will be automatically distributed to all players that use them.

Note

A BrightSign Network subscription is required to create Dynamic Playlists and Live Data Feeds.

Dynamic Playlists

~ BrightAuthor Version 4.7
® Version 4.6
® \ersion 4.4
® Previous Versions
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ON THIS PAGE

® Creating a Dynamic Playlist
® Updating a Dynamic Playlist
® Adding a Dynamic Playlist to your Presentation

Dynamic Playlists allow you to easily update media playlists in multiple presentations. For example, if you need to add a set of daily
announcements to multiple presentations, and you don’t want to update each presentation separately, you can add a single Dynamic Playlist to all
of your presentations. When you update the Dynamic Playlist, every presentation that includes the Dynamic Playlist receives the new content. In
this way, a single update can reach multiple presentations.

Note
Dynamic Playlists support a maximum of 500 content files. If you need dynamic playback of more than 500 files, create two or more

Dynamic Playlists to hold the content.

Creating a Dynamic Playlist

Tip
You can create Dynamic Playlists in the BSN WebUI as well.

Follow these steps to create and upload a Dynamic Playlist:

. Click the Create tab and select Dynamic Playlist.

. On the menu bar, click File > New Dynamic Playlist.

. Choose the Image or Video or Audio Only option for the Dynamic Playlist.

. Add files to your Media Library by clicking the Browse button and selecting a folder that contains the files you want to include in your
Dynamic Playlist.

. Drag the desired media files to the playlist area.

. Click the Upload to Network button in the upper-right portion of the screen.

7. You will be prompted to save the playlist. Click Yes. The Save As window will open. Type a name for your playlist and click Save. The S

ave Complete window will open. Click OK. The playlist will now be uploaded onto the BrightSign Network.
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Note
Dynamic Playlists containing audio can be added to Audio Only, Enhanced Audio, Video or Image, and Video Only zones, while
Dynamic Playlists containing image/video content can be added to Images, Video or Images, or Video Only zones.

Updating a Dynamic Playlist

You can change the content of the Dynamic playlist at any point by opening the playlist (File > Open Dynamic Playlist) from the Create tab.
Once you've edited the playlist, click Upload to Network to update it. All players using the Dynamic Playlist will be updated in real time.

Adding a Dynamic Playlist to your Presentation

Follow these steps to add a Dynamic Playlist to a presentation:

. Navigate to the Edit tab.

. Click the other tab under Media Library

Drag a Media RSS item into the playlist area.

. When prompted to select a Data Feed, click Add Data Feed.

Enter a Feed name. This does not need to be the same name given to the Dynamic Playlist.

. Under Feed specification, select Dynamic Playlist and choose the playlist from the dropdown menu.

. Under Data feed content usage, select MRSS Feed.

. Use the Update Interval dropdown menu to determine how often the player should check in with the BrightSign Network servers to
update the Dynamic Playlist.

9. Click OK.
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Live Data Feeds


http://docs.brightsign.biz/display/DOC/Create+Tab#CreateTab-creating_dynamic_playlists

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

ON THIS PAGE

® Creating a Live Data Feed
® Adding a Live Data Feed to Your Presentation

Similar to an RSS feed, a Live Data Feed consists of an indexed list of Titles and Values: Each Title has an associated Value. Live Data Feeds
can have numerous applications in a presentation. They can be used as updatable text feeds in Ticker zones or as individual text widgets in a Liv
e Text state. They can even be used to remotely update the values of User Variables.

Creating a Live Data Feed

Tip
You can create Live Data Feeds in the BSN WebUI as well.

Follow these steps to create and upload a Live Data Feed.

. Click the Create tab and select Live Data Feed.

. On the menu bar, navigate to File > New Data Feed.

. Click the Add Item button to create a new feed entry.

. Enter a Title for the feed entry. The title, as well as the index number, allows you to pick a specific entry to display when using RSS feeds
in Live Text.

. Enter a Value for the feed entry. This is the portion of the feed that will be displayed on screen.

. Use the up and down arrows to reorder the list of entries. You can also use the X button to delete an entry.

7. When you are finished adding entries, click the Upload to network button in the upper-right portion of the screen (you must be

connected to the BrightSign Network). You will be prompted to save the feed as an XML file before uploading it to the network. The name

you give to this XML file will be the name associated with this feed on the BrightSign Network.
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You can save a copy of the feed any time by navigating to File > Save New Feed or File > Save New Feed As. You can later retrieve the feed by
navigating to File > Open Live Data Feed.

Adding a Live Data Feed to Your Presentation

Follow these steps to add a Live Data Feed to you presentation:

. While in the Edit tab, navigate to File > Presentation Properties > Data Feeds.

. Click Add Data Feed.

Enter a Feed name. This does not need to be the same name given to the Live Data Feed.

. Under Feed Specification, select Live Data Feed and choose the feed from the dropdown menu.

. Under Data feed content usage, select Text.

. Use the Update Interval dropdown menu to determine how often the player should check in with the BrightSign Network servers to
update the Live Data Feed.

7. Click OK.
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You can now add the text of the Live Data Feed to your presentation via Live Text and RSS Feed states.
Tagged Playlists

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

Tagged Playlists allow you to create BrightSign Network playlists based on customizable media tags. You can use this feature to define a flexible
set of rules to dynamically build a playlist based on a wide range of intuitive conditions.

Example

You are managing networked BrightSign players at a dozen different retail locations. Each player requires some unique media to match
its retail location, and some locations, depending on the region, have more media files in common than others. Instead of creating a
dozen different presentations (and managing each presentation separately), you can create a single Tagged Playlist with location,
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region, and event tags (or any other tags you need; they're completely customizable) to ensure the right media gets played in the right
place at the right time.

(@) Test Tagging Playiist 2 - BrightAuthor =N X
File Edit Tools Help
Create Publish Manage B I‘IghtAUthOf Signed in to account: peterdemo
Dynamic Playlist Live Data Feed BrightWal™ | » Tagged Playlist
Media Rules
Match @ all () any media tagged as follows:
+ | Add Media Rule
Tag Name Condition Value
x [use  ~] contains any +| EndCap
% |Branded | is -
Content Order Tag: | Branded ~ | [Ascending -
Update Preview,
g A E i é |
L - : - .
Attractmpg XD1230_FrontIg.png | spain_1280x720.mpd
Note

You may want to tag media files before creating a Tagged Playlist. This will allow you to view which media files are included in the
Tagged Playlist while you define the tagging rules.

1. Click the Create tab.
2. Select Tagged Playlist in the secondary task bar.
3. Under Media Rules, select whether you want the playlist to match all tags or any tag:

a. All: For a media file to be included in this Tagged Playlist, it must match all conditions you define in the Media Rules section.
The more conditions you add, the more exclusive the playlist will tend to be.

b. Any: For a media file to be included in this Tagged Playlist, it only needs to match one of the conditions you define in the Media
Rules section. The more conditions you add, the more inclusive the playlist will tend to be.
4. Click Add Media Rule to add a tagging condition:

a. Tag Name: Select a tag from the dropdown menu. The list includes all media tags you've defined in your BSN library, as well as
a set of default media attribute tags (FileName, FileSize, UploadDate, etc.) that apply to all media files.

b. Condition: Select a rule to match media with the specified tag:
i. is: Tagged media that equals the specified Value will be matched.
ii. is not: Tagged media that does not equal the specified Value will be matched.

iii. contains all: Tagged media that contains all of the specified values for the tag will be matched. If a tag for a media file
contains additional values beyond the matched list of values, that media file will still be matched. Separate each tag
value using a comma without spaces (e.g. "NewDeals,DailyDeals,Promotions").

iv. contains any: Tagged media that contains any of the specified values for the tag will be matched. Separate each tag
value using a comma without spaces (e.g. "appetizers,drinks,specials").

v. contains: Tagged media that has one or more values containing the specified sequence of (case-insensitive) characters
will be matched: For example, specifying a Value of "deal" will match "deals", "Deals", and "New_Deals" values.

vi. does not contain: Tagged media that has no values containing the specified sequence of (case-insensitive) characters
will be matched: For example, specifying a Value of "day" will exclude "DayOfWeek", "Monday", and "Odays" values.

vii. begins with: Tagged media that has one or more values beginning with the specified sequence of (case-insensitive)
characters will be matched: For example, specifying a Value of "day" will match "DayOfWeek", but not "Monday".

viii. ends with: Tagged media that has one or more values ending with the specified sequence of (case-insensitive)
characters will be matched: For example, specifying a Value of "day" will match "Monday", but not "DayOfWeek".

ix. is less than:(file size only) Media with a file size (in bytes) smaller than the specified value will be matched.
X. is greater than:(file size only) Media with a file size (in bytes) larger than the specified value will be matched.

xi. is in the range:(file size, upload date, last modified date only) Media with a file size (in bytes), upload date, or last
modified date within the range of values will be matched.



xii. is not in the range:(file size, upload date, last modified date only) Media with a file size (in bytes), upload date, or last
modified date outside the range of values will be matched.

xiii. is after:(upload date, last modified date only) Media that was uploaded or last modified after the specified date will be
matched.

xiv. is before:(upload date, last modified date only) Media that was uploaded or last modified before the specified date will
be matched.

xv. in the last:(upload date, last modified date only) Media that was uploaded or last modified in the amount of time before
the specified date will be matched. Specify an amount of time (in days, months, or years), along with the target date.

xvi. notin the last:(upload date, last modified date only) Media that was not uploaded or last modified in the amount of time
before the specified date will be matched. Specify an amount of time (in days, months, or years), along with the target
date.

c. Value: Enter a value to match with the tag value using one of the above conditions.

5. Use the Content Order Tag dropdown list to determine how media files should be automatically ordered in the playlist. Use the first
dropdown menu to select a tag: The values of this tag will be used as the ordering criteria. Use the second dropdown menu to determine
if the order should be ascending (ASC) or descending (DESC) alphabetically/numerically.

6. Click the Update Preview button to see how changing the media rules modifies the contents of the Tagged Playlist.

7. Reorder the playlist if needed by dragging and dropping media files. If newly tagged media is included in the playlist later on, it will be
added to the end of the playlist using the Content Order Tag settings outlined above.

8. Select File > Save to save the playlist to your BSN account.
9. Enter a Tagged playlist name and click OK.

You can also use the File menu to rename the Tagged Playlist (Save [playlist name] As..), retrieve a Tagged Playlist from your BSN account for
editing (Open Tagged Playlist), or create a new Tagged Playlist (New Tagged Playlist).

Tip
Use the Presentation Properties > Data Feeds tab to add a Tagged Playlist to a BrightAuthor presentation.

Presentation States

=~ BrightAuthor Version 4.7
® Version 4.6
® Version 4.4
® Previous Versions

In its simplest form, a presentation can contain image, video, and/or audio files. However, BrightAuthor also features a number of presentation sta
tes that allow you to expand the functionality and versatility of your projects. For example, if you want to have dynamic, remotely updatable media
in your playlist, you can add a Media RSS Feed state to your playlist and point it at a hosted feed URL.

To add a state to your presentation, click the other tab under Media Library and drag the desired state into the playlist area.

Note
You can add any state to an interactive playlist, but some states cannot be used in non-interactive playlists because they require

interactive input.
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Non-Interactive States
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Non-interactive states can be used in both interactive and non-interactive playlists. The following are non-interactive states:

® Media RSS Feed
® | ocal Playlist

® RSS Feed and Static Text
® Twitter

® User Variable

® SignChannel

® HTML5

® Video Stream

® Mjpeg Stream

® Audio Stream

® Live Video

® RFIn (ATSC)

® Tuner Scan

Note
Though HTMLS5 states are not interactive, the HTML pages themselves feature full JavaScript interactivity: The JavaScript of a page
can interact with BrightSign hardware interfaces using BrightScript-JavaScript objects.

Media RSS Feed

w BrightAuthor Version 4.7
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® Previous Versions

You can use Media RSS Feed states to display the content in Dynamic Playlists or MRSS feeds. An MRSS feed can be hosted on a third-party
server or the BrightSign Network (using the Live Media feature). MRSS feeds can be used to play image, video, audio, and HTML content
(different content types can be mixed into a single feed).

Follow these steps to add an MRSS feed to your presentation:

1. Click the Other tab below Media Library.
2. Drag the Media RSS Feed icon to the playlist area.

3. Select a Data Feed from the dropdown list. If you have not added a Data Feed to the presentation yet, click Add Data Feed and follow
these steps:

a. Enter a Feed name.
b. Under Feed specification, do one of the following:
i. To add an MRSS feed that's hosted on a third-party server, select Url and enter the URL for the MRSS feed.
ii. Toadd a BSN Live Media feed, select Live Media Feed and choose the feed from the dropdown list.
iii. To add a BSN Dynamic Playlist, select Dynamic Playlist and choose the feed from the dropdown list.
c. Under Data feed content usage, select MRSS Feed.

d. Use the Update Interval dropdown menu to determine how often the player should check in with the server to update content in
the feed.

e. Click OK to add the MRSS feed to your presentation.
4. Click OK.

Important
If you are using the Media RSS Feed in an Audio Only or Enhanced Audio zone, ensure that the MRSS feed contains audio files only.

Local Playlist
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A Local Playlist allows you to customize which Dynamic Playlist is used in a presentation depending on the player. For example, if you are using
BrightSign players at a dozen different locations, and the locations require the same content except for variations in the content of the Dynamic

Playlists, you only need to create, edit, and update one presentation that uses a Local Playlist rather than a dozen that use different Dynamic
Playlists.

A [+] Playlist0 A1 [+] Playlist 0 A1 [*] Playlist0

Dynamic Playlist B Kitteh Zjpg kitteh.jpg Dynamic Playlist €

~ | [*] Playlist 0

My Dynamic Playlists

Tip
To use a Local Playlist, you first need to sign in to the BrightSign Network and add Dynamic Playlists to your presentation (via File >
Presentation Properties > Data Feeds).

To add a Local Playlist to your presentation, click the Other tab in the Media Library. Then drag and drop the Local Playlist icon where you would
normally add a Dynamic Playlist.
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® State name: Enter a unique name for the Local Playlist state.

* Default playlist: Specify a default Dynamic Playlist for players to use. If a player enters the Local Playlist state and does not have a
Dynamic Playlist assigned to it, it will use the default Dynamic Playlist instead.

® Filter by player name: Enter a search term and click the

icon. The list will be filtered to contain only players with names that match (or partially match) the search term.
® Filter by playlist name: Enter a search term and click the

icon. The list will be filtered to contain only players currently assigned Dynamic Playlists with names that match (or partially match) the
search term.

Note

The Filter by playlist name search function works on the currently saved configuration for the Local Playlist: If you've made
changes to Dynamic Playlist assignments since opening the Local Playlist state, you will need to click OK to save those
changes and reopen the Local Playlist state for the search function to operate on the current configuration.

® Playlist: Assign a Dynamic Playlist to each player connected to your BrightSign Network Account.

RSS Feed and Static Text
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Ticker zones can be used to display dynamic text (RSS feeds) or static text feeds. You can also use a Live Text state to display text over an
image or video.

RSS Feeds

RSS feeds are updated each time the BrightSign player connects to the specified RSS URL. An RSS Feed state can display either Live Text Data
or a third-party RSS feed. Follow these steps to add an RSS Feed to your presentation:

. Select a Ticker zone in your presentation.

. Click the RSS tab and drag the New RSS Feed icon onto the playlist.

. Select a Data Feed from the dropdown list.

. If you have not added the RSS feed to the presentation yet, click Add Data Feed. Do the following:
. Enter a Feed name.

. Under Feed Specification, select Url and enter the URL for the RSS feed.

. Under Data feed content usage, select Text.

. Click Validate to ensure the RSS URL is working correctly.

. Use the Update Interval dropdown menu to determine how often the player should check in with the BrightSign Network servers
to update the Live Data Feed.

f. Click OK to add the Data Feed to your presentation.
5. Click OK.
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Text Feeds

Text Feeds are static text files located on the local storage of the player. Follow these steps to add a Text Feed to your presentation:

1. Create a .txt file (using Notepad or a similar program) that contains the text you wish to display.
a. Insert a line break between each text item in the .txt file.
b. Save the text file and place it in your Media Library folder.

2. Select a Ticker zone in your presentation.

3. Click the Text tab in the Media Library.

4. Drag the text file into the playlist.

Twitter

w BrightAuthor Version 4.7

® \ersion 4.6


http://docs.brightsign.biz/display/BA46/4.6-BrightAuthor+User+Guide
http://docs.brightsign.biz/display/BA44/4.4-BrightAuthor
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting
http://docs.brightsign.biz/display/BA46/4.6-BrightAuthor+User+Guide

® Version 4.4
® Previous Versions

Tip
This tutorial video shows the basics of adding a Twitter state to a Ticker zone.

You can use your Twitter account to create a data feed from a remote source. Twitter feeds can only be used in a Ticker zone. To add your
Twitter feed to a presentation, select a Ticker zone, click the RSS tab, and drag the Twitter icon onto the playlist.

® Twitter User Name: Enter your Twitter user name and click Authenticate. When prompted to authorize BrightSign to use your Twitter
account, enter your Twitter account login information and click Authorize app.
Update Interval: Use the dropdown list to specify how often the player should check your Twitter feed for updates.

Only show the most recent number of tweets: Check this box if you want to limit the tweets displayed in the Ticker zone to only the
most recent. Specify in the field how many recent tweets can be displayed.

User Variable
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The User Variable state allows you to display the value of a User Variable in a Ticker zone.

When you add a User Variable state to the playlist, you will be prompted to select the name of the variable to display. To add User Variables to
your presentation, navigate to File > Presentation Properties > Variables.

@ User Variable @

Select user vanable: |Varl ']

oKk || cancel |

SignChannel
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To add a SignChannel state, select a Video Only zone or a Video or Images zone. Under the Other tab, drag the SignChannel icon to the playlist
area.

Note
You can only use one zone per presentation to display SignChannel content.

HTMLS
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You can use the BrightSign XT, 4K, XD, HDx23, and HDx22 models to display HTML web pages, including video, image, text, and JavaScript
elements. For a full explanation of how to create and publish HTML content for BrightSign players, please see the HTML5 Development section.

Important

BrightSign models are not designed to be used as general-purpose web browsers. Many web pages have elements that will not display
correctly on a BrightSign player. Make sure to thoroughly test a web page before using it as digital signage.

Note
HTML video content will play even if it is embedded in an Images zone.
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® State name: Specify a name for the HTML state.

® HTMLS5 Site: Select an HTML site from the dropdown menu. To populate this list with sites, navigate to File > Presentation Properties >
HTML Sites.

® Enable external data: Check this box if your HTML page uses assets from multiple locations.

® Enable mouse and touch events: Check this box if you want to enable interaction with the HTML5 page (clicking on links, interacting
with JavaScript elements, etc.).

® Display cursor: Check this box to display a cursor whenever a USB mouse is connected to the player.

® Enable native video plane playback: Check this box to enable H\WZ mode on all <vi deo> elements contained within the page. This
increases the frame rate and quality of HTML video playback, but can also cause problems with CSS page transforms and other page
elements. By default, it will place video on top of all graphics in the presentation and set the view mode of all <vi deo> elements to Scale
to Fill.

® Specify user stylesheet: Assign a user stylesheet to the HTML page. Use the Browse button to select the .css file you wish to utilize as
the user stylesheet. Every HTMLS5 state can have a different user stylesheet, even if the states are being used to display the same
HTMLS5 page.

® Custom fonts: Click Add Font to add custom font files to the HTML page. Supported file types include TrueType Font (.ttf) and Web
Open Font (.woff, .woff2). When the presentation is published, the font file(s) will act as though they are located in the same file directory
as the index.html file (i.e. they can be accessed with the standard font-family attribute in HTML/CSS). If no custom fonts are specified,
text in an HTML page is displayed using the default system font.

® Time on screen: Specify how long (in seconds) the HTML page should be displayed before transitioning to the next state in the playlist.
If this value is zero, the page will be displayed indefinitely.

,ﬁp HTMLS [

State name: New Site

HTMLS Site: New Site |

Enable external data
Enable mouse and touch events
["] Display curser
Enable native video plane playback
Specify user stylesheet
User stylesheet  C:\BrightSign Content\Other\HTMLS5 Content\Sushi Menu Board\sushi\styling\sushi.css @|

Custom fonts

4+ Add Font

Font Path

Time on screen (in seconds, 0 means unlimited): Q

Add HTML Site |

i oK | [ Cancel

Video Stream
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This state allows you to play an IP stream. All networked players can play streaming video. See this FAQ to learn more about supported video
formats and codecs for IP streaming.

® State Name: Specify a unique name for the stream state.
® URL for video stream: Enter a valid URL for the stream. The URL can also include a number of optional parameters:

® Specify a User Variable to replace all or part of the URL. To include the value of the variable in the URL, enter the variable name
between two sets of dollar signs (e.g. "http://www.example.com/streams/$$my_URLvar$s$").

® Append the "latency" and "jitter" parameters to modify the default latency (see this FAQ for more details).
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* Append the "buffersize”, "vcdbsize", and "acdbsize" parameters to modify the default streaming buffer size (see this FAQ for
more details).

* Append the "?lowlatency" parameter to reduce the default latency (see this FAQ for more details).

® Time on screen: Specify the duration (in seconds) that the stream will be played. This option is only available in non-interactive
presentations. To customize the duration of a stream in an interactive presentation, use a Timeout or Media End event.

Mjpeg Stream
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All networked players can play streaming Mjpeg video. See this FAQ to learn more about supported video streaming formats and codecs.

Note

Unlike other video types, there is no limit on the amount of Mjpeg streams you can display on screen. However, adding more than a
certain number of windows (depending on the player model and stream quality) will begin to reduce the framerate of the videos.

® State Name: Specify a unique name for the stream state.
URL for video stream: Enter a valid URL for the stream. The URL can also include a number of optional parameters:

® Specify a User Variable to replace all or part of the URL. To include the Value of the variable in the URL, enter the variable
Name between two sets of dollar signs (e.g. "http://www.example.com/streams/$$my_URLvar$$").

® Append the "?latency=[value_in_ms]" parameter to modify the default latency (see this FAQ for more details).

® Append the "?buffersize=[size_in_bytes]" parameter to modify the default streaming buffer size (see this FAQ for more details).
Rotation: Specify the clockwise rotation of the streaming video.
Time on screen: Specify the duration (in seconds) that the stream will be played. This option is only available in non-interactive
presentations. To customize the duration of a stream in an interactive presentation, use a Timeout or Media End event.

Audio Stream
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All networked players can stream audio from a remote source. For more information on supported formats, codecs, and bitrates, please see the A
udio Streaming Support FAQ.

® State Name: Specify a unique name for the stream state.

® URL for video stream: Enter a valid URL for the stream. The URL can also include a number of optional parameters:

® Specify a User Variable to replace all or part of the URL. To include the Value of the variable in the URL, enter the variable
Name between two sets of dollar signs (e.g. "http://www.example.com/streams/$$my_URLvar$s$").

® Append the "?latency=[value_in_ms]" parameter to modify the default latency (see this FAQ for more details).
® Append the "?buffersize=[size_in_bytes]" parameter to modify the default streaming buffer size (see this FAQ for more details).
® Time to play: Specify the duration (in seconds) that the stream will be played. This option is only available in non-interactive
presentations. To customize the duration of a stream in an interactive presentation, use a Timeout or Media End event.

Live Video
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The XT1143, 4K1142, XD1132, and XD1230 models support live-video playback from another source via the HDMI Input port. To add a Live
Video state, select a Video or Images or Video Only zone, click the Other tab, and drag the Live Video icon to the playlist area.

® Volume: Specify the volume of the video input (between 0 and 100).

® Time on screen: Specify the amount of time the video input is displayed on screen.

® Qverscan: Check this box to display the video input beyond the edges of the zone. Use this option if the source video signal is using an
overscan setting.

Note
We do not recommend displaying a Live Video state at the same time as an RF In state (in two different video zones, for example).
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RF In (ATSC)
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Note

The RF In state was changed significantly in BrightAuthor version 3.7.0.12. If you have an RF In project from an earlier version of
BrightAuthor, you will need to recreate the presentation with a new version of BrightAuthor.

This state displays live video that is passed to the BrightSign player through the RF Input. This feature is available only on the XD1230. Before
you can display video from the RF Input, you must first perform a channel scan on the player while it is connected to the cable source: You can do
this prior to publishing the presentation (via the RF Channel Scan interface) or during the presentation (via the Tuner Scan state).

If you've already performed a channel scan on the player, you can use the “ScannedChannels.xml” file generated by the scan on the SD card to
enable the Channel name and Select different virtual channel options:

1. Click the Browse button next to Specify RF channel scan file.
2. Locate the SD card or USB flash drive you used to perform a channel scan on the player.
3. Open the “ScannedChannels.xml” file located in the root directory.

@D Media Properties (o
Main | Advanced | Notes
— State name:  RFIn
aTsc)
Select channel
AM
@ First scanned channel
® Channel name PNA -
Virtual channel
Currentvirtual channel 10
Select different virtual channel | 1.0
User variable
Specify RF channel scan file Browse|
CABrightSign ContentiScanResultsxml
On entry to this state
© Remain on last tuned channel
Retune as specified above
Event that triggers channel up [None -
Event that triggers channel down | None -]
[E] Overscan
Set as initial state: [ Yes

Specify the following:

® Select channel: Determine which channel will be played upon entering the RF In state:

® First scanned channel: Displays the first channel detected during the channel scan (i.e. the smallest detectable channel
number).

® Channel name: Displays the channel with the specified name. To use this option, you must first specify a
“ScannedChannels.xml” file in the Specify RF channel scan file field.

® Virtual channel: Displays the channel based on its virtual number:
® Current virtual channel: Manually enter the virtual number of the channel. You should only use this number if you are
familiar with the channel map of the cable source.
® Select different virtual channel: Select the virtual number of the channel based on the results of the channel scan. To
use this option, you must first specify a “ScannedChannels.xml” file in the Specify RF channel scan file field.
User variable: Displays the channel based on the value of a User Variable. The system software can recognize both channel
name and virtual channel number as the value of a User Variable. Before you can enable this option, you must first designate
one or more User Variables.
® On entry to this state: Determine what should happen when playback enters the RF In state:
® Remain on last tuned channel: The player remains on the same channel that was displayed the last time the presentation was
in the RF In state. The state will use your Select channel settings if it is the first time the presentation is entering the RF In state.

® Retune as specified above: Choose this option if you would like the player to retune using your Select channel settings every
time the presentation enters the RF In state.

® Event that triggers channel up: Specify an event trigger that will flip up through channels.
® Event that triggers channel down: Specify an event trigger that will flip down through channels.
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® Qverscan: Check this box to display the video input beyond the edges of the zone. Use this option if the source video signal is using an
overscan setting.

Tip
A Media End event will trigger on an RF In state only if the video bit rate of the tuner input drops to OMbs.

Note
We do not recommend displaying an RF In state at the same time as a Live Video state (in two different video zones, for example).

Tuner Scan
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You can use the Tuner Scan state to perform a channel scan of the cable source while an interactive presentation is running. Use a Media End ev
ent to exit this state once the channel scan concludes. If you use another interactive event (e.g. Serial Input, UDP Input) to exit the Tuner Scan
state before it concludes, the scan will be canceled and the results will not be written to the player.

® Channel Map: Select QAM, ATSC, or ATSC and QAM (consult your service provider for details).

® Modulation Type: Select QAM 64, QAM 256, or QAM 64 and QAM 256 (consult your service provider for details).

® First RF Channel (optional): You can choose to limit the range of the channel scan by selecting the first channel to scan.
® Last RF Channel (optional): You can choose to limit the range of the channel scan by selecting the last channel to scan.

Note
Each channel takes approximately one second to scan. Specifying upper and lower limits will reduce the amount of time it takes to

perform the scan. You should only use these two options if you are familiar with the channel map of the cable source.

|

@ Media Properties

Main | Advanced | MNotes

QAMm

State name:  Tuner Scan

Channel Map | ATSC and QAM v

Modulation Type | QAM 64 and QAM 256 ~ |

First RF Channel (optional) 30

Last RF Channel [optional) 122

Set as initial state: [ Yes

f QK i [ Cancel

Interactive States
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Interactive states can be used in interactive playlists only. The following are interactive states:
® Media List, Video List, Image List, Audio List
® Video Play File, Image Play File, Audio Play File

® Live Text
® |nteractive Menu
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Event Handler
Super State

Media List, Video List, Image List, Audio List
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The Media List, Video List, Image List, and Audio List states are convenient tools for defining interactive events with many files. They allow you to
compile your files into one group that appears as a single thumbnail in your playlist area. By default, each time the playlist transitions to a list
state, the next file in the list will play and exit the list after a timeout (images) or when the file finishes playing (video and audio). Alternatively, you

can set

the list to shuffle files or cycle through every file in the list before exiting and transitioning to the next state.

Tip
Use the Transitions tab to add commands for entering or exiting each media item in the state. To add commands for entering or exiting
the state itself, use the Advanced tab

Tip
You can edit properties of these states under File > Presentation Properties > Media List.

B All Media List = | 5 i)
Main | Advanced | Transitions | Notes
Media list name:  Media List 1 @) Populate from media library
o Media Library
i : [
g — Set as initial state: [¥] Yes CagrightSign Content [Z‘
’ Advance to next item on Media End event: [ Yes
Media Files
Advance to next item on Image Timeout: (] Yes +) agdFie () Add Al Content From Media Library Delete Al |
Image Timeout (seconds):
Support 4K images (use video plane to display images) [ Yes Popuiate from data feed
Play from beginning on entry to state: || Yes Data feed:
Startindex 1
Shuffle playback: [[] Yes
Event to transition to next item: | None -
Event to transition to previous item: |Nane -
Transition: | No effect =)
Transition duration: 1.0
Send Zone Message (using file name as parameter) prior to showing each item: [ Yes
==

First, make sure your playlist is set to Interactive. Then, drag a Media List, Video List, Image List, or Audio List icon onto the playlist area. You
can then set the following parameters for your list:

Media list name: Create a unique name for the list.

Set as initial state: Check this box to make the list your Home Screen.

Advance to next item on Media End event: (Media Lists, Video Lists, Audio Lists) Check this box to have the list cycle to the next file
after an audio/video file ends. If you leave this box unchecked, the list will play one audio/video file each time it is transitioned to,
remaining on that file until the playlist transitions away from the list.

Advance to next item on Image Timeout: (Media Lists, Image Lists) Check this box to have the list cycle to the next file after an image
times out. If you leave this box unchecked, the list will display one image each time it is transitioned to and then transition away when the
Image Timeout interval is reached.

Note

An Audio List in an Enhanced Audio zone cycles through all files in the list by default, so the Advance to next item on media end eve
nt option is not available for Enhanced Audio zones. In an Enhanced Audio zone, a Media End event attached to an Audio List will only
trigger once all files in the list have been played.
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* Image Timeout (seconds): (Media Lists, Image Lists) Specify the length of time each image remains on screen. You can also use
decimal values to specify the image timeout in milliseconds (for example, 1.500 = 1500msec).

® Support 4K images (use video plane to display images): (Image Lists) Check this box to enable 4K image playback in the Image List.
This will consume the 4K video decoder on the player, so you won't be able to display both a 4K video and a 4K image at the same time.

® Play from beginning on entry to state: Check this box to have the list start from the beginning each time it is transitioned to. This box is
only enabled if you have checked the above Advance to next item on Media End event box (unless you are using an Enhanced Audio
zone) or Advance to next item on Image Timeout box. If you leave the Play from beginning on entry to state box unchecked,
subsequent transitions to the list will play the next file in the list.

® Start Index: Specify which item in the list should count as the beginning of the list. When the list plays from the beginning (see the Play
from beginning on entry to state option above), it will play from the item index specified here. When non-shuffled playback reaches the
end of the list, it will loop back to the top of the list (i.e. start index 1), rather than the specified Start Index.

® Shuffle playback: Check this box to randomize the order of media items in the list each time it is transitioned to.

® Event to transition to next item: Select an interactive event that allows the user to transition to the next file in the list. After selecting the
event type, you must specify a trigger.

® Event to transition to previous item: Select an interactive event that allows the user to transition to the previous file in the list. After
selecting the event type, you must specify a trigger.

Note
Like the Synchronize event, commands for the Synchronize trigger must be sent from another player on the local network.

Note
If you leave event transitions on "None", audio/video files will transition at media end and images will transition at timeout.

® Transition: (Media Lists, Image Lists) Specify the transition effect that will occur when the image timeout triggers.

® Transition duration:(Media Lists, Image Lists) Specify how long the image-transition effect will take to complete. This duration should be
less than the amount of time the image is displayed on screen.

® Send Zone Message (using file name as parameter) prior to showing each item: Check this box to send a Zone Message command
every time there is a file transition in the list. The Zone Message string will consist of the filename (without the file extension) of the media
item that is being transitioned to.

® Populate from media library: Select this option to populate the list using content stored on your computer.
® Media Library: Click Browse to select the folder that contains all the files you want to include in the list.

® Media Files: Add individual files to the list by clicking the Add File button and using the dropdown list. Only files contained in
the folder you selected above will be available in the dropdown list. Alternatively, you can click Add All Content From Media
Library to add all compatible media files from the directory specified in the Media Library field. Once you've added the desired
files to the list, you can customize playback order using the up and down arrows. You can also remove individual files using the
X buttons, or remove all files using the Delete All button.

* Populate from data feed: Select this option to populate the list using media files specified in an RSS feed (this feature does not support
MRSS feeds). You will first need to add the RSS feed to your presentation by navigating to File > Presentation Properties > Data Feeds.
When adding the Data Feed, you must set the Data feed content usage to Content for Image List, Audio List, Video List, or PlayFile
. Upon playing the presentation, the player will retrieve the media from the download URLs specified in the Value field of each item in the
Data Feed (i.e. the RSS <descri pti on> field).

¥v<rss version="2.0">
¥<channel>
<title>Content DL Feed 2</title>
<description>Content DL Feed 2</description>
v<item>
<title>Image l</title>
v<description>
http://brightsign.biz/filés/cache/d9d30310981df0922753268e6£62489¢e_f415.3pg Media download URL
</description>
</item>
v<item>
<title>Image 2</title>
v<description>
http://brightsign.biz/fileés/cache/acdl1772ef536e4e920e259c20347251 f421.jpg Media download URL
</description>
</item>
</channel>
</rss>

Video Play File, Image Play File, Audio Play File
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Play Files allow you to combine media files into a single state in the playlist area. You can then use the interactive event that transitions to the

Play File to conditionally determine which file in the playlist should be played.

Play Files can only be transitioned to using input from BP900/BP200, UDP, Serial, Keyboard, or USB devices. The input data from the controller
will determine which media item in the Play File will be played: For example, you can use a Keyboard Input event to playback “Video 1” if the “A”
key is pressed, “Video 2" if the “B” key is pressed, "Video 3" if the "C" key is pressed, etc. Any type of event can transition out of a Play File state

and into a new state.

Note

For BP200/BP900 events, you must specify each Key using both the panel enumeration and button number: For example, if you have a
single BP200/BP900 panel connected to the player and want button 3 to trigger an image, you would specify the Key as "0-3"; on the
other hand, if you have a second BP200/BP900 panel connected to the player and want button 3 on the second panel to trigger the

image, you would specify the Key as "1-3".

@ Play Fie o E e o[
Main | Advanced | Not
|l'—.|
© Speciy local les © Specifylocal fles
Display defauit media i nput doesn't match any keys Display defauit media i nput doesnt match any keys
= Default media ile path  CaBrightSign Content\Kitehs fightingipg =
e to specily key
Files Files
) s ) s
Key Label Show in BrightSign App__ File Path Key Label Show in BrightSign App _File Path
x UDPL Kitteh = CABrightSign Contentikittehjpg x 03 [a] CABrightSign Content\kittehjpg
x @ o2 Kiteh 2 @ CABrightSign Content\Kitteh 2]pg x 13 &} CABrightSign Content\Kiteh 2jpg
Import Table| | Export Table | Import Table | [ Export Table |
Speciy data feed Speciy data feed
Data feed: Data feed:
o (o | |

Make sure you use zones that match the Play File type you want to use. After setting your zone to Interactive and dragging a Play File icon to the
playlist area, the Play File window will automatically open. Here you can set the parameters for your Play File list.

® State name: Create a unique name for the Play File state.
® Transition (Image Play Files only): Use the dropdown list to create a special effect when the playlist transitions to an item in the Play File

state.

® Specify Local Files: Select this option if you would like to create the Play File using files from your computer. If you choose this option,
the Play File table will remain static when it is published to the player; the only way to change it is to republish the presentation. The Spec
ify data feed option (described below) allows for dynamic Play File tables.

® Display default media if input does not match any keys: Check this box to display the specified media file when the input
data does not match any existing keys in the Play File state. If this box is not checked, nothing will happen when the input data

does not match an existing key.

® Use variable to specify key: Check this box to have a User Variable specify the media-file key. The input data from the
controller will be ignored, though input of some kind must be received to trigger the interactive event. For example, if a Keyboard
event is attached to a Play File state and this option is enabled, any key press will initialize a transition to the Play File state; the
value of the specified User Variable will then be checked against the keys in the Play File to determine which file, if any, should

be played.

Note

If you attach a command that modifies the User Variable value (e.g. Set Variable, Increment Variable) to an event that transitions to the
Play File state, the media-file keys will still be compared against the old variable value. However, if the Display default media option is
enabled, the new User Variable value will be used instead.

® Add File: Click this button to add media items to the Play File.
® Files: This list displays files added to your Play File. Each file has a Key and File Path.
® Key: The value that will trigger playback if it is matched by the input from the interactive event. Because you define the
triggers with the keys in the Play File, you do not need to specify the triggers again when creating a transition to the Play
File. For example, if you define a USB Input event that links an item to the Play File, the option to Specify USB Input wil
| be disabled and replaced with "<any>". When a user performs an event via USB that matches a key, the corresponding

file will play.

® Label: The label of the interactive button as it will appear in the BrightSign App.

® Show in BrightSign App: Check this box if you want to display the media item as a button in BrightSign App instances
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that connect to the player. The button will only appear in the app if a UDP Input event transitions to the Play File state.
® File Path: The location of the media file on your computer. Click the Browse button to locate the file you wish to use.

® Display Mode (Video Play Files only): By default, files are set to 2D, but if you are using a 3D video, you can select 3D
side-by-side or 3D top-over-bottom when adding your files.

® Import Table: Click this button to import a previously created Play File table (.csv file). Navigate to your saved table and click Op
en to add the files to your Play File list. This table must have the "Key", "File Path", "File Name", and "Video Display Mode" (if
applicable) properly outlined. You can use a table that was exported from another Play File state with the Export Table function,
or you can create a Play File table using Notepad or Excel.

® Export Table: Click this button to create a .csv file that includes information about the current Play File table. This file can then
be imported to other Play File states that use the same media type.

® Specify data feed: Select this option if you would like to populate the Play File using media files specified in an RSS feed. You will first
need to add the RSS feed to your presentation by navigating to File > Presentation Properties > Data Feeds. You will also need to set the
Data feed content usage for use with Play Files. When playing the presentation, the player will retrieve the media from the download
URLSs specified in the <descri pt i on> field of each item in the RSS feed, and the Play File will use the value in the <ti t | e> field to
determine the key that triggers the media item to play.

¥v<rss version="2.0">
v<channel>
<title>Keyboard Play File Feed 3</title>
<description>Keyboard Play File Feed 3</description>
v<item>
<title>A</title> Play File key value
v<description>
http://brightsign.biz/files/cache/d9d30310981d£0922753268e6£62489e_£415.3pg Media download URL
</description>
</item>
v<item>
<title>W</title> Play File key value
v<description>
http://brightsign.biz/files/cache/acdl1772e£536e4e920e259c20347251_£421.3pg Media download URL
</description>
</item>
</channel>
</rss>
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A Live Text state consists of an image overlaid with various text fields and/or media. You can layer both static text and updatable RSS and MRSS
content on top of images and customize the position/size of items in relation to the background. You can even use Live Text to overlay content on
top of a video in another zone.

To add a Live Text state to your presentation, drag the Live Text icon from the Other tab to the playlist area and set the following parameters:

® State name: Enter a unique name for the Live Text state.
® Set as initial state: Check this box to make the Live Text state your Home Screen.
® Background Image: Click Browse to locate and select a background image for your Live Text.

Note

Image Mode settings that would normally crop displayed images (i.e. “Center Image” and “Scale to Fill and Crop”) are not applied to the
background image of a Live Text state. To get consistent performance between images and Live Text states, you will need to resize
images accordingly.
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® Update Live Text Data: Click this button to have all Live Text Data fields display their current value.

Changing the Size/Positioning of a Live Text Item

Click the
€]
Add Item button to add a new text/media item to the Live Text canvas. You can then edit the size and positioning of the item:

® Size: Adjust the size of a text field or item.
® W: The width of the text field or item
® H: The height of the text field or item
® Position: Adjust the position of a text field or item.
® X: The position of the text field or item on a horizontal axis
® Y: The position of the text field or item on a vertical axis.

@ Add Live Text [

Main | Advanced | Notes |

State name:  News Feed

Set as initial state: [[] Yes

Background Image:  Dumbbell nebulaj Background

Update Live Data| 8 Image
Itemns
Size: W 1920 H: 117
Position: X 0 ¥ 962
[ Offset next~ X: y:

Type: |Live Text Data ~| [Add Data Feed

Data Feed Name [Onion News Feed -

) Ttem title

(@ Ttem index 1

Layer: 1 E‘J T N
Live Text
(+) Add Item Feed £
Note

You can also click and drag the text fields in the preview area to adjust sizing and position.

® Offset next: Check this box to set an initial position for new items in relation to the most recently created item. Input the offset distance
for the next text item in the X and Y fields.

Sel ecting the Item Type

Use the Type dropdown menu to select the source of the content in the selected item:

® Fixed Text: Displays simple, static text. A text field will appear below Text Type, where you can type your customized text. As you type,
you can view the text in the preview image.

® System Variable: Displays the device serial number, firmware version, script version, or other System Variable value. Use the dropdown
list to determine which value you would like to display.

® Live Text Data: Displays content from a Data Feed in the text field. The displayed Data Feed item will remain fixed and will not cycle
through feed items like an RSS ticker (use the RSS Feed type for this functionality). However, you can still update the text in real time by
modifying the feed on the server and changing the description associated with the item title or index.

® Add Data Feed: Click this button to add a Data Feed to your presentation. You can use any feed type (RSS, Live Data Feed,

MRSS, Dynamic Playlist) as Live Text Data, but you must specify the Data feed content usage as Text when adding the Data
Feed.

® Data Feed Name: Select the desired Data Feed from the dropdown menu.
® Item title: Specify the feed item to display using the Title/Name of the item.



® |tem index: Specify the feed item to display using the index number of the item.

Note

When you use the Item index, subsequent RSS text fields will automatically contain the next item in the index (i.e. the previous index
number + 1).

Media Counter: Displays how many times a file in the presentation has played. Each Media Counter field must correspond to a specific
file. Use the dropdown list to pair the Media Counter field with a file in the presentation. To use this feature, Media Counters must first be

enabled: Navigate to File > Presentation Properties > Variables and check the box labeled Automatically create media counter
variables.

User Variable: Displays the current value of a User Variable. Use the dropdown list to specify a User Variable for the text field. To use
this feature, you must first create a User Variable.

® RSS Feed: Displays content from an RSS feed. To edit the amount of time each RSS item is displayed, click Set Text Parameters and
modify the Time to Display Each Line field.

® Update RSS URL List: Click this button to create a list of Data Feeds to use as RSS sources.

® Display RSS title: Check this box to display the title of the RSS item.

® Display RSS description: Check this box to display the description of the RSS item.
® Media RSS Feed : Displays content from a Media RSS (MRSS) feed.

® Update Media RSS URL List : Click this button to create a list of Data Feeds to use as MRSS sources.

* Display Media RSS title: Check this box to display the title of the MRSS item.

® Display Media RSS description: Check this box to display the description of the MRSS item.

® Display Media RSS media: Check this box to display the media item associated with the MRSS item.

® Custom fields: If your MRSS feed contains custom text fields, this section will allow you to show or hide the custom fields as
required.

® Image : Select this option to display an image over the background image. Select Browse to locate an image file to use in this item.
® Validate Live Text Data: Click this button to verify that the source URL for the selected Live Text Data item is valid.

Customi zing the Text Paraneters

Click the Set Text Parameters button to customize the parameters for a selected field.

® Alignment: Use the dropdown list to set whether the text is left aligned, right aligned, or centered.
® Foreground text color: Click Choose to select a color for the text.

® Background text color: Check this box to include a background color for text fields. Click Choose and set a default color for the
backgrounds.

®* Transparency: Drag the bar to set the transparency for the background text color.

Note

Transparency does not appear in the Live Text image preview or in Presentation Preview. You will need to publish the
presentation to a BrightSign player to view the level of transparency.

Font: Click Browse to locate and select a font for the text. You can use any TrueType font. Click Reset to System Font to reset the font
to the default.

Important

The LS422, HD120, HD220, and HD1020 models support a limited number of Live Text items with custom font. If you need to
display many items simultaneously, either display them with the system font or upgrade to another player model: The XT, 4K,
XD, HDx23, and HDx22 models support any practical number of text items with custom font.

® Font size: Select Automatic to fit the text to the height of the text field, or select Fixed point size to enter a value for the font size (1 -
500).

Note that the default parameters of a text item will differ depending on how it is created:

® The first text item will use the default text parameters set in the Edit Preferences window ( Edit > Preferences > Live Text).
® If you create a text item while another text item is selected, the new text item will inherit the parameters of the selected text item.

® If you create a text item without another text item selected, the new text item will inherit the parameters of the last created text
item.

Note
If you choose to include a Background Text Color, the Transparency setting will be enabled, allowing you to edit the transparency of
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the Background Text Color. If you choose not to include a Background Text Color, characters in the text fields will appear over the
elements beneath it.

Layering ltens

Use the Layer buttons to determine the layering of your Live Text elements. The background image is always displayed behind all elements.

L - | —-— -
Layer: gj ﬁ.__] E‘__] E—J
a. b. c¢. d

Sends the selected element behind all other elements.

Sends the selected element behind the element that is directly beneath it.
Sends the selected element in front of the element that is directly in front of it.
Sends the selected element to the front of all other elements.

o0 o

Live Text with Video

You can use a Live Text state to layer text and images over video. To do so, you must add the Live Text state to a Video or Images or Images
zone, and place it on top of a Video Only zone. To help you position text over the video, we recommend using a screenshot from the video you
want to use. Complete the following steps:

1. Under Layout, click Add Zone.

a. Click Add Zone to add a Video Only zone.

b. Click Add Zone again to add an Images or Video or Images zone.

c. Setthe Graphics plane z position of the Images zone to Front.

d. Resize the Images zone so that it completely covers the Video Only zone.
2. Click the Playlist tab and select your Video Only zone.

a. Drag the desired video file from the Media Library to the playlist area.

b. Make the zone Interactive.
3. Use the dropdown list to select the Images zone.

a. Make the zone Interactive.

b. Drag the Live Text icon from the Other tab to the playlist area.
4. Click the Live Text icon to open the Add Live Text window.

a. Click Browse beside Background Image.

b. Locate and select the screenshot image file taken from the video file used in the Video Only zone.
5. Click Add Text Item.

a. Adjust the Size and Position of your text field by clicking and dragging over the preview image or inputting exact numbers in the
corresponding fields.

b. Select your Text Type and input the desired text.
c. Click Set Text Parameters and edit text parameters as desired.
d. Click OK when finished.
6. Repeat step 5 for each text field you wish to add.
7. When all text fields are in place, click Clear next to Background Image.
8. Click OK.

Clearing the Background Image removes the image from the zone. The text fields will appear directly over the video. By temporarily including a
Background Image taken from the video, you can better position the text fields in relation to the video playing behind the Images zone.
Interactive Menu
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Interactive Menus are DVD-style menus that users can navigate with interactive events. By linking media to items to the Interactive Menu, you can
allow users to interactively transition to a new state of their choice. Because Interactive Menus can serve as a bridge to many media items and
outline all selections available to the user, they make great Home Screens.

To create an Interactive Menu, add a Video or Images zone to your presentation. Set the zone to Interactive and drag the Interactive Menu icon
from the Other tab to the playlist area.

Cener al

This tab allows you to select an image for your Interactive Menu and define how a user navigates it.

® State name: Create a unique name for your Interactive Menu state.
® Background Image: Click Browse to select an image to use as the menu display.

Important
The background image is not simply a background for menu items; it must contain all images and text you want displayed in

the menu.

® Set as initial state: Check this box to set the Interactive Menu as the Home Screen.

The Navigation section is where you define how a user navigates among items in the menu. Click the dropdown menu for each option (Up,
Down, Left, Right, Enter, Back, Next clip, Previous clip) and select the interactive input that will trigger this action (GPIO Event, Serial input, etc.).
A second dropdown menu or text field will appear. Specify the button or input you want to correspond to the action.

Let’s say you want to define how to move Up in the menu, and you want to use the "U" key on the connected keyboard. In the Up dropdown list,
select Keyboard Input. A text field will appear below where you can specify a button. Type “U” in the text field. Now, when a user presses “U” on
a keyboard, the cursor will move up along the menu items. If you don't wish to define an action, you can simply leave the dropdown list on the
default None.

The following actions can be defined in the Navigation section:

® Up, Down, Left, Right: These are the primary actions a user will perform to navigate from one menu item to the next.

® Enter: When a user enters the defined input on a menu item, a media file you have chosen in the Menu Items tab will play.

® Back: The user can enter the defined input to return to the menu at any point.

® Next clip: If a user is viewing a media file associated with a menu item, using the defined input will play the media file that corresponds to
the next menu item.

® Previous clip: If a user is viewing a media file associated with a menu item, using the defined input will play the media file that
corresponds to the previous menu item.
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General | Menu Items
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This tab allows you to create menu items and specify how a user navigates around the menu.

® Menu Iltem Number: Every menu item has a unique menu item number: The first item you create is 1, the second is 2, and so on. Here
you can navigate among the menu items you have created by clicking the Previous and Next buttons. All other options below
correspond to the menu item you have selected.

® Add Menu Item: Click to create a new menu item. The Add Menu ltem window will open.
® Active Image: This image serves as a cursor to visually inform the user what menu item is currently selected.
® Inactive Image: This image appears beside the menu item when the user has another menu item selected.

Tip

If you want nothing to appear beside a menu item when it is not selected, choose an Inactive image that matches the
color of the background. In firmware versions 6.2.147 and later, players also support transparency with active/inactive
images.

® Position: Adjust the position of your menu item by inputting specific numbers. Alternatively, you can click the active image in the preview
image and drag it to the desired position. The inactive image will appear in the same spot when the menu item is not selected.

® X: The position of the menu item on the horizontal axis.
® Y: The position of the menu item on the vertical axis.
® Offset next: Check this box to specify an initial position for new menu items in relation to the most recent menu item.
¢ X: The amount of offset on the horizontal axis.
® Y: The amount of offset on the vertical axis.
® Selected Image: Click Browse to change the active image.
® Unselected Image: Click Browse to change the inactive image.

® Store image in cache: Check this box to store the corresponding image in the player cache. This ensures that the image will load quickly
when switching between active/inactive states. Note that the player cache is limited—see this FAQ for more details.


http://support.brightsign.biz/entries/20474768-How-many-images-can-I-preload-using-the-Image-Cache-feature-

@ Add Interactive Menu {&J

General | Menu Items

Menu Item number

Demonstration

=+ Add MenuIzm CO ntent
Pasition X 79 Y. 170
Offsetnext X ¥: WEPercy Jackson & the Olympians: Hydra ESPN X-Games
Percy Jackson & the Olympians: Water
Selected Image:  green.png Up

Store image in cache
Unselected Image:  black.png

Store image in cache

lce Age: Dawn of the Dinosaurs

Barefoot Truth — All Good Reasons
Joan Osborne - Broken Hearted

Need For Speed: Shift

Bass - Waveguide technology
Sound - Invisible speakers

X Audio - ADAPTIQ® technology
o )] Connecting - Unify™ technology

Ingrid Michaelson — The Way | Am Simplified - Remote control and interface
Up Nene '| Melody Gardot - Baby I'm A Fool
. Spencer Day - Till You Come to Me
et @' Right @' Nick Howard - Empty Faces

Down |None ~ |

Enter

Items

Play clip Browse ‘ Image timeout (seconds) Store image in cache
Transition to new state
Retumn to prior state

Remain on current state

o) oo )

Navigation

The Navigation section is where you determine how a user moves from one menu item to the next. Although the actions were previously defined
in the General tab, this is where you specify how actions navigate among the specific menu items. The possible actions are Up, Down, Left, and
Right. Each action has a dropdown list that displays the menu item number for each created menu item. By default, None is selected for each.

Selecting a number in the dropdown list will allow the user to navigate from the current menu item to the specified menu item by performing the
corresponding action. Let's say you are editing menu item number 1. If you click the dropdown list for the Down action and select 2, the user can
now navigate from Menu item 1 to Menu item 2 by pressing the Down button. Remember, the buttons correspond to whatever you previously
defined in the Navigation section of the General tab.

Enter

The Enter section is where you determine what happens when a user presses the Enter button on a particular Menu item. Select one of the
following:

® Play clip: Plays the specified media item when the user presses the Enter button. Use the Browse button to select a media item. If you
select an image, the following options will be available:

®* Image timeout (seconds): Specify how long the image should be displayed before returning to the interactive menu.

® Store image in cache: Check this box to store the image in the player cache. This will ensure that the image loads quickly. Note
that the player cache is limited—see this FAQ for more details.

® Transition to new state: Transitions out of the Interactive Menu state and into a new state when the user presses the Enter button. Use
the dropdown list to select a state from the presentation playlist.

® Return to prior state: Returns to the previous state (i.e. the state that transitioned to the Interactive Playlist) when the user presses the
Enter button.

® Remain on current state: Does not change states when a user presses the Enter button. However, you can add commands to specify
changes that occur while remaining on the Interactive Menu. Click the Advanced tab to reveal the Commands menu.

Event Handler

~ BrightAuthor Version 4.7
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In some scenarios, you might want your presentation to sit at a blank screen. The Event Handler fills the role of an empty placeholder in your
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presentation. Here are a few cases where an Event Handler would be useful:

® You want a blank screen for a Home Screen so no content will play until the presentation is activated.
® You want to add a command that is performed before the first file in the presentation plays.
® You want the presentation to sit at a blank screen when finished, instead of looping.

@ Media Properties @
Main | Advanced | MNotes

State name: Event Handler

- R
m" Stop Playback: [ Yes

@y C)
- Set as initial state: Yes

=

Although Event Handlers contain no content, you can add commands and interactive events into and out of them. For example, if you set an
Event Handler state as the Home Screen and define a BP900 event linked from the Event Handler state to the first presentation item, the display
will sit at a blank screen until a user presses the BP900 button, and then the first item will begin playing. Alternatively, if you set an Event Handler
as the Home Screen and add a Synchronize command to it, you can synchronize your presentations and/or displays before the first files begin

playing.
To use an Event Handler, click the Other tab under Media Library and drag the icon into the playlist area.

® State Name: Enter a unique name for the Media Handler state.

® Stop Playback: Check this box if you would like audio/video playback to end once a media file transitions to the Event Handler state. If
this box is left unchecked, audio/video playback will continue after a transition to the Event Handler state.

® Set as initial state: Check this box to make the Event Handler the Home State of the presentation.

Define interactive events into and out of the Event Handler as you would with any other state. If you define a Media End event after a video and
link it to an Event Handler, the presentation will sit at a blank screen when the file finishes playing.

Super State
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If you need to create large, complex interactive playlists, you will likely run into two problems: You'll find yourself having to create a large number
of redundant events, and it will become difficult to keep track of numerous branching states and conditions. Super States are implemented to
alleviate these problems and make complex interactive presentations manageable.

@ Media End Event @

({ ____v/'-"\,
Media within

Super State

Super State

Attractmpg

-Jupiter_Rotation.mp4
"l -Kitteh 2jpg
-kitteh,jpg
-Kittehs fighting,jpg
Attract.mpg

Playlist

The primary mechanic of the Super State is that it functions as both a state and a self-contained interactive playlist. A Super State can be
transitioned into and out of using any event, but clicking on it will reveal a new interactive playlist canvas contained within the original. There are
several behaviors that are unique to this state:

® Each Super State contains a Home State: A transition to a Super State will point to the initial state within the Super State by default.
However, you can point the transition to any other state within the Super State by opening the event and selecting the desired state from
the Specify next state dropdown menu.
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® Super States can be nested inside other Super States: You can use the breadcrumb trail above the playlist area to keep track of where
you are within the hierarchy of Super States.

® Super States can have Entry and Exit Commands: Entry Commands are triggered when any state within the Super State is transitioned
to. If a Super State is contained within one or more other Super States, a transition to or from that Super State will trigger Entry/Exit
commands on all other Super States that will need to be moved through for the transition to reach its destination. Commands will be
executed in sequential order, depending on whether the transition is ascending or descending through a hierarchy of Super States.

® You can copy, paste, export, and import Super States: All events, states, commands, and other Super States contained within the Super
State will be copied over as well.

|E| Zone 1:Video or Images : Playlist - Branch A - Branch AB - Branch ABC

(%) [=] Playlist 0

OWELIILLIB©

Interactive Events
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Interactive events link states in the playlist and determine what must occur before one state transitions to another. See the Interactive
Presentations page to learn how to add events to your interactive playlist.

® User Defined Events
® Timeout

® Media End

® BP900/BP200

® Rectangular Touch
® USB Input

® Keyboard Input

® GPIO Event

® Serial Input

® Remote Input

* GPS
® Plugin Message
® UDP Input

® Synchronize

® Link Zones

® Zone Message

® Time/Clock

® Video Time Code
® Audio Time Code

User Defined Events
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ON THIS PAGE

® Creating and Editing User Defined Events
® Adding User Defined Events to your Playlist
® |mporting and Exporting User Defined Events

This feature allows you to save interactive events you use often so that you can access them more readily in the future. User Defined Events save
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both the event type and event parameters. For example, if you frequently use a 5 second Timeout event, you can create a User Defined Event
with this specification. In the future, instead of having to set each Timeout event to 5 seconds, you can use your previously created User Defined
Event.

Additionally, you can group multiple events into a User Defined Event. Any event within the User Defined Event will cause the desired transition.
This will save you time by eliminating the need for defining multiple events that perform the same transition.

@ Manage User Events @

+ Add User Event

X 4 Timeout Event

X & GPIO Events

Delete Al |

oK l [ Cancel

Creating and Editing User Defined Events

To create or edit a User Defined Event, select the user events tab under Media Library and click Manage. The Manage User Events window
will open. This window contains a list of all previously created User Defined Events. Do any of the following:

® Create a new User Defined Event: Click Add User Event. When prompted, type a unique name for your User Defined Event. Click Add
Event and use the dropdown list to select an interactive event. Repeat for each event you want included in the User Defined Event. Click
OK when you are finished.

® Edit a User Defined Event: In the Manage User Events window, click the name of the User Defined Event you wish to edit. Make the
desired changes in the User Event window.

® Organize User Defined Events: Click the arrows to arrange the order of the list by moving a User Defined Event up or down.

® Delete User Defined Events: Click the X beside a name in the list to delete a single User Defined Event, or click Delete All to erase the
entire list.

Adding User Defined Events to your Playlist

To add a User Defined Event to your interactive playlist, select the User Events tab under Media Library. Drag the desired event icon from the
list onto a state. In the Events window, specify the desired transition behavior. You can also add commands to a User Defined Event after it has
been assigned to a state.

Importing and Exporting User Defined Events

You can import and export your User Defined Events. Since User Defined Events are created on a per-presentation basis, the import/export
feature allows you to save your User Defined Events and transfer them to new presentations as needed.

To import or export, click File > Import User Events or File > Export User Events. If you are importing, browse to the location where the events
definition XML file is stored. If you are exporting, browse to a location where you want to export all User Defined Events currently defined for your
presentation.

Timeout
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Timeout
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The Timeout event displays a state for a predetermined period of time before an action occurs. In the Specify timeout (seconds) field, specify
the number of seconds the state should display before the action occurs.

@ Timeout Event l =NACH X
Main | Advanced

Specify timeout (seconds) 10

Start state: kitteh.jpg

@ Transition to new state

Specify next state: Kitteh 2,jpg -

~) Return to prior state

~) Remain on current state

ok ]| cancel

Media End
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“edia End

The Media End event specifies the action that occurs when a video file or audio file reaches the end of playback. Media End events can also be
applied to the following states: Video List, Audio List, Video Playfile, Audio Playlist, Media RSS, and Signchannel.

BP900/BP200
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SP200A Event

The BP900 and BP200 events specify the action that occurs when a specific BP900 or BP200 button is pressed. The BP900 and BP200 button

panels are LED-based touch devices that allow you to add interactivity to your BrightAuthor presentations. These button panels are compatible
with any BrightSign player that has a USB port.

Enumeration

There are a total of eight event icons: BP900A, BP900B, BP900C, BP900D, along with BP200A, BP200B, BP200C, and BP200D. The letters A,
B, C, and D correspond to USB ports. If the event you are defining is for a button pad connected to USB port A, use "A". If it is for a button pad
connected to the second port, use B. Let's say you are using an XD1132 and, therefore, have two available USB ports. If you want to connect two
button boards, a BP900 and a BP200, you would use the BP900A and BP200B icons to define events for each.

You can use a USB hub to connect up to four BP900/BP200 button panels to a BrightSign player. See this tech note to learn more about
BP900/BP200 enumeration on USB hubs.

Defining BP900 and BP200 Events
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Once you've added a BP900/BP200 event to your presentation, determine the parameters that will activate it:
® Specify Button Number: Select a button on the button pad that you want the user to press to transition to the next state.

Important

Selecting Any Button will enable only the button numbers used in other BP200 or BP900 events in the presentation (or numbers
enabled in the File > Presentation Properties > Buttons window): For example, if you have defined BP900 events for buttons 1 and 4,
then a BP900 event set to Any Button will trigger for buttons 1 and 4 only.

® Press (First Touch): Select this option to have the transition occur the moment the button is pressed.

® Press Continuous: Select this option to have the transition occur only after the button is continually pressed for a certain interval of time.
Specify the repeat interval (in milliseconds).

® Transition to new state: Select this option to have the presentation transition to a new state when the event occurs. Use the dropdown
list to specify a new state.

® Return to prior state: Select this option to have the presentation return to the previous state when the event occurs.

® Remain on current state: Select this option to have the state remain unchanged when the event occurs.

D BPYOOA Event [
Main | Advanced

Specify Button Number [l - |

® Press (First Touch)

~) Press Continuous (Repeat interval in milliseconds)
Start state: kitteh.jpg

@ Transition to new state
Specify next state: Whirlpool galaxy,jpg -
) Return to prior state

! Remain on current state

oK | [ Cancel

Rectangular Touch
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Rectangular Touch

The Rectangular Touch event specifies the action that occurs when the user presses a region on a touch screen that is connected to the
BrightSign player.

® Size: Use the size parameters to set an exact size for the touch region. Alternatively, you can click and drag the marks surrounding the
touch rectangle to change its size.

® W: Enter the width of the touch region.
® H: Enter the height of the touch region.

® Position: Use the position parameters to set an exact position for the touch region. Alternatively, you can click and drag the rectangle to
a different area.

* X: Enter the horizontal position (in pixels) of the top-left corner of the touch region.
Y: Enter the vertical position (in pixels) of the top-left corner of the touch region.

® Save as User Event: Check this box to save this Rectangular Touch event as a User Event. Enter the name of the new User Event in the
Name field.
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® Add Touch Region: Click to add another touch region to the event. All touch regions in a Rectangular Touch event will trigger the same

transition and commands. To define different touch transitions, add additional Rectangular Touch events to a state.
USB Input
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USE Input

The USB Input event sets the action that occurs when a BrightSign player receives the specified input from a connected USB device

In the Specify USB input field, enter the USB input string that will trigger the event.
Keyboard Input
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Keyboard Input

The Keyboard Input event sets the action that occurs when a BrightSign player receives the specified input from a connected keyboard

In the Specify keyboard input field, enter the keyboard input that will trigger the event.
GPIO Event
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GPIC Event

The GPIO Event specifies the action that occurs when a specific GPIO button is pressed or input is received. By default, the playlist toolbar
includes several GPIO buttons that you can use to define interactions.

® Specify button number: Specify the number of the GPIO button. These numbers also correspond to the 8 bi-directional pins on the
GPIO connector.

® Trigger Event on Button: Specify whether the event should trigger when the button is depressed (Down) or when it is released (Up). If
you've selected Down, choose one of the following behaviors:

® Press (First Touch): The event triggers the moment the button is depressed.

® Press Continuous: The event triggers the moment the button is depressed, then continues triggering at the specified intervals
as long as the button is depressed.

Note

The "button" numbers described above are not the same as GPIO "pin" numbers: Some pins act as power supply or ground, so they
are not included in the button numbering scheme. See the hardware manual associated with your player model to view a mapping of
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buttons to pins.

Serial Input
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oo
Serial Input

The Serial Input event specifies the action that occurs when the BrightSign player receives input from a device connected to a serial port.

® Specify port: Enter the port number of the input device. Most standard RS-232 serial devices enumerate on port 0. If you are connecting
a USB-serial device, it will enumerate on port 2. To configure the serial port, navigate to File > Presentation Properties > Interactive.

® Specify serial input: Enter the serial input string that will trigger the event. You can also use the <*> wildcard to match some or all of the
serial input (i.e. entering "<*>" in this field will match any input, while entering "mycommand_<*>" will match any input message that
begins with "mycommand_").

Modifying User Variables

You can use the Serial Input event to modify the values of User Variables. To enable these options, click the Advanced tab:

® Assign input to variable?: Check this box to assign the content of the serial input to a User Variable.

® Input specifies variable: The serial input string will dynamically specify which User Variable to modify. The serial input string
must be sent in the form of <variable name> : <variable value>.

® Specify fixed variable: The serial input string will modify a fixed User Variable. Use the dropdown list to choose which User
Variable the serial input will modify. The serial input string must be sent in the form of <variable value>.

Tip
You can use the Input specifies variable option to modify more than one User Variable with a single event. Use the following serial
input string: <variable name> : <variable value> !! <variable name> : <variable value>

Assign wildcard to variable?: Check this box to specify the value of a User Variable using the <*> wildcard. Select the User Variable to
modify using the dropdown menu to the right. The Specify serial input field must contain the <*> wildcard, either by itself or with
additional text (e.g. "message_<*>").

Note
Wildcards are only supported when the serial port is using the ASCII protocol, not when using the Binary protocol.

Tip

It is possible to check both Assign input to variable and Input specifies variable boxes for more complex functionality. For example,
you can use Specify fixed variable to assign the entire serial input string to one variable, while at the same time using Assign
wildcard to variable to assign a subset of that string to another variable.

Remote Input
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Remare Input

The Remote Input event sets the action that occurs when the BrightSign player receives the specified input from an IR remote control.

In the Specify remote input field, enter the remote control command value that will trigger the event. BrightAuthor supports the following NEC
remote control codes:

* WEST

* EAST

* NORTH
* SOUTH
* SEL

* EXIT

* PWR

* MENU

* SEARCH
* PLAY

* FF

* RW

* PAUSE
* ADD

* SHUFFLE
* REPEAT
* VOLUP
* VOLDWN
* BRIGHT

GPS
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GPs

The GPS event specifies the action that occurs when a BrightSign player, connected to a compatible USB GPS device, enters or exits a defined
geographical region.

® Event Direction: Determine how the event should trigger in relation to the defined region.
® Enter Region: The event triggers when the device moves from outside the defined region to inside of it.
® Exit Region: The event triggers when the device moves from inside the defined region to outside of it.
® Region: Define the size and shape of the circular region.
® Radius: Specify the radius of the circular region. Use the dropdown menu to specify the units in Miles or Kilometers.
® Latitude (degrees): Define the center of the circular region as a latitudinal coordinate.
® Longitude (degrees): Define the center of the circular region as a longitudinal coordinate.

Tip
You can create more than one entry or exit region by adding multiple GPS events to a single state.
Plugin Message
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Plugin Message

The Plugin Message event specifies the action that occurs when a message is received from a custom script plugin that is attached to the
presentation. See the Parsers and Plugins tech note for more information on creating custom scripts that send plugin messages.

® Plugin name: Use the dropdown menu to determine which plugin the event can receive messages from. You can also use the <*>
wildcard to match some or all of the plugin message string (i.e. entering "<*>" in this field will match all plugin messages, while entering
"mycommand_<any>" will match any plugin message that begins with "mycommand_").

® Plugin message: Enter the message string that will trigger the event.

Modifying User Variables

You can use the Plugin Message event to modify the values of User Variables. To enable these options, click the Advanced tab:

® Assign input to variable?: Check this box to assign the content of the plugin message to a User Variable.

® Input specifies variable: The plugin message string will dynamically specify which User Variable to modify. The plugin message
string must be sent in the form of <variable name> : <variable value>.

® Specify fixed variable: The plugin string will modify a fixed User Variable. Use the dropdown list to choose which User Variable
the plugin message will modify. The plugin message string must be sent in the form of <variable value>.

Tip
You can use the Input specifies variable option to modify more than one User Variable with a single event. Use the following
string: <variable name> : <variable value> !! <variable name> : <variable value>

® Assign wildcard to variable?: Check this box to specify the value of a User Variable using the <any> wildcard. Select the User Variable
to modify using the dropdown menu to the right. The Plugin Message field must contain the <any> wildcard, either by itself or with
additional text (e.g. "message_<any>").

Note

It is possible to check both Assign input to variable and Input specifies variable boxes for more complex functionality. For example,
you can use Specify fixed variable to assign the entire message string to one variable, while at the same time using Assign wildcard
to variable to assign a subset of that string to another variable.

UDP Input
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UCP Input

The UDP Input event specifies the action that occurs when the BrightSign player receives a UDP (User Datagram Protocol) message from
another device on the local network. Source devices can include, but are not limited to, tablets running the BrightSign App, other BrightSign
players, and PCs/Macs.

® Specify UDP Input: Enter the UDP message string that will trigger the event. You can also use the <any> wildcard to match some or all
of the UDP message string (i.e. entering "<any>" in this field will match all UDP messages, while entering "mycommand_<any>" will
match any UDP message that begins with "mycommand_").

® Label: Specify a label for the UDP command button in the BrightSign App. By default, the command label will be the same as the UDP
message string.
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® Show in BrightSign App: Check this box to have the command button corresponding to the UDP Input event appear in the BrightSign
App.

Modifying User Variables

You can use a UDP Input event to modify the values of User Variables. To enable these options, click the Advanced tab:

® Assign input to variable?: Check this box to assign the content of the UDP message to a User Variable.

® Input specifies variable: The UDP message string will dynamically specify which User Variable to modify. The UDP message
string must be sent in the form of <variable name> : <variable value>.

® Specify fixed variable: The UDP string will modify a fixed User Variable. Use the dropdown list to choose which User Variable
the UDP input will modify. The UDP string must be sent in the form of <variable value>.

Tip
You can use the Input specifies variable option to modify more than one User Variable with a single event. Use the following UDP
string: <variable name> : <variable value> !! <variable name> : <variable value>

Assign wildcard to variable?: Check this box to specify the value of a User Variable using the <any> wildcard. Select the User Variable
to modify using the dropdown menu to the right. The Specify UDP Input field must contain the <any> wildcard, either by itself or with
additional text (e.g. "message_<any>").

Note

It is possible to check both Assign input to variable and Input specifies variable boxes for more complex functionality. For example,
you can use Specify fixed variable to assign the entire UDP string to one variable, while at the same time using Assign wildcard to
variable to assign a subset of that string to another variable.

Synchronize
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Synchronize

The Synchronize event synchronizes playback with other BrightSign players on the same local network using UDP. This event is useful for

synchronizing playback according to user input. If you want frame-accurate video synchronization (e.g. for video walls), we recommend creating a
BrightWall presentation instead.

This event triggers when a Synchronize command with the same keyword as the Synchronize event is used on another player on the local
network. When the Synchronize Event window opens, enter the keyword that corresponds to the Synchronize command in the Specify
synchronization keyword field.

Note
A separate Synchronize event and command must be defined for each transition you want synchronized.

For Synchronize events to work, you must ensure UDP communication is configured correctly in File > Presentation Properties > Interactive.
Link Zones
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Zone Meszage

Use the Link Zones event, combined with the Link Zones command, when you require close, millisecond-level synchronization of content between
zones on the same player (as opposed to synchronizing across multiple players).

In the Specify link keyword field, enter the message that is sent by the corresponding Link Zones command.

Note
A separate Link Zones event and command must be defined for each zone transition you want synchronized.

Zone Message
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Zone Meszags

Use the Zone Message event, combined with the Send Zone Message command, to affect changes from one zone to another across multiple syn
chronized players with multi-zone presentations.

In the Specify zone message field, enter the message that is sent by the corresponding Send Zone Message command.

Note
A separate Zone Message event and command must be defined for each zone transition you want synchronized.

Time/Clock
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Time/Clock

The Time/Clock event specifies the action that occurs at a specific time and date or at regular intervals on a recurring schedule.

® Single date/time event: Select this option to specify a one-time-only event.
® Date: Specify the date by entering it into the field or selecting it from the calendar view.

® Time: Specify the time using the dropdown menu. If you want the event to occur at an exact minute, type the desired time
directly into the field.

® Specify with user variable: Select this option if you want to use the value of a User Variable to specify the date and time.
Choose a variable from the dropdown list. The value of the variable must be in this format: “yyyy-mm-ddThh:mm:ss”. For
example, if you would like the event to occur on December 20, 2016 at 3:45PM, then you would use the value
“2016-12-20T15:45:00".
* Daily timeout event: Select this option to specify a recurring event.
® Once per day: Select this option to have the event occur once per day. Specify the Time using the dropdown menu (or, if you
want the event to occur at an exact minute, type the desired time directly into the field).


http://docs.brightsign.biz/display/DOC/Commands#Commands-link
http://docs.brightsign.biz/display/BA46/4.6-BrightAuthor+User+Guide
http://docs.brightsign.biz/display/BA44/4.4-BrightAuthor
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting
http://docs.brightsign.biz/display/DOC/Commands#Commands-send
http://docs.brightsign.biz/display/BA46/4.6-BrightAuthor+User+Guide
http://docs.brightsign.biz/display/BA44/4.4-BrightAuthor
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting

® Periodic throughout the day: Select this option to have the event occur at intervals throughout the day.
® Interval between events (minutes): Determine the frequency of the event.

® Active between: Use the dropdown menus to specify the period during which the event can occur. The first event will
occur at the beginning of the active period.

® Set the days the timeout is active: Use the checkboxes to select which days the time/clock event is active.
Video Time Code
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Video Time Code

The Video Time Code event performs commands at specific times during video file playback. If you want to trigger a transition at a certain point in
the video, use the Timeout event instead.

Click the Add Time Code button to add a new time-code command. Enter the Timeout interval for the command (in milliseconds), and then
select the Command and Parameters from the corresponding lists.

Audio Time Code
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The Audio Time Code event performs commands at specific times during audio file playback. If you want to trigger a transition at a certain point
during audio playback, use the Timeout event instead.

Click the Add Time Code button to add a new time-code command. Enter the Timeout interval for the command (in milliseconds), and then
select the Command and Parameters from the corresponding lists.

BrightWall Presentations
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The Brightwall™ feature allows you to easily create, publish, and edit video-wall deployments. Video walls are created by synchronizing the
playback of a number of players, each connected to a different screen on the wall, over a local network connection. Simple looping video playlists

are the only presentation type supported by BrightWall. Images and interactive playlists are not supported: Use this FAQ to compare the
capabilities of different synchronization options.

The process of publishing BrightWall presentations differs from publishing standard presentations. See the Publishing a BrightWall Presentation p
age for more information.

Video Requirements

For best results, we recommend using the .mp4 or .mov container for video files that make up a BrightWall presentation. Transport Stream (.ts)

files are also supported, but they must begin with a presentation timestamp (PTS) offset of zero. Program Stream (MPEG-PS) files are not suppor
ted.
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Note

It is possible to create a seamlessly looping video wall if the video files are formatted appropriately. See the Seamless Looping FAQ for
more details.

Network Requirements

All players that are part of a BrightWall must be connected to the same network via Ethernet cable. BrightWall uses the PTPv2 network protocol,
which requires multicast support on the network.

Creating a BrightWall Presentation
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® Creating a Configuration File

® BrightWall Presentation Properties
® Main
® Audio

To create a new Brightwall presentation, navigate to Create > BrightWall™ (if the Create a new Video Wall window doesn't

open automatically, click File > New BrightWall ™). A Brightwall presentation requires a BrightWall Configuration file to set the platform,

dimensions, and layout of the video wall. Once you create a BrightWall Configuration file, you can use that file to quickly generate BrightWall
presentations with the same video-wall setup.

® Save As: Enter the name of the new BrightWall project.

®* Where: Choose where to save the BrightWall project file. Note that the project file is different from the presentation files that will actually
be published to the players.

Configuration file: If you have created a BrightWall Configuration file, you can use it to generate settings for the BrightWall project.

Create BrightWall Configuration: Click this button to create a new BrightWall Configuration file. Use this option if you haven't created a
BrightWall Configuration file yet, or if you would like to create an additional BrightWall Configuration file with new settings.

Creating a Configuration File

Clicking the Create BrightWall Configuration button will open the BrightWall Configuration window, which provides the following options.

® BrightSign Model: Choose the BrightSign player model that will display the video wall. All players that are part of the video wall must be
of the same model type.

® Connector type: Choose the connector (HDMI, VGA, Component) that each player will use to connect to its display. All players that are
part of a video wall must use the same connector.

® Screen resolution: Choose the resolution of each screen in the video wall. All video wall screens must have the same resolution. You
can view all available screen resolutions in this FAQ.

Note
Individual screens only support video files in landscape mode.

® Monitor orientation: Choose one of the following:
® Landscape: Content is not rotated.

® Portrait — bottom on left: Video is rotated counter-clockwise 90 degrees. Select this option if the bottom of each monitor is on
the left when it is portrait oriented.

® Portrait — bottom on right: Video is rotated clockwise 90 degrees. Select this option if the bottom of the each monitor is on the
right when it is portrait oriented.

Note

The portrait modes apply to Stretched BrightWall presentations only. If you select a portrait mode, you will be limited to
creating Stretched presentations with this BrightWall Configuration file.
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® Monitor overscan: Select an overscan setting to determine how each video fills the display screen.

®* No overscan — use full screen: Displays video to the edge of the video signal.

® Overscan — action safe: Restricts the image display to an area that is compatible with most displays.

® Overscan —title safe: Restricts the image display to an area that is much smaller than the image generated by the video signal.
®* Number of rows: Specify the vertical length of the video wall (in number of screens).
®* Number of columns: Specify the horizontal length of the video wall (in number of screens).

® Domain: Specify a domain number (between 0 and 127) for the video wall. This number must be unique for each video wall on the local
network. This will ensure that multiple video walls can run on the same local network without synchronization messages interfering with
each other.

® Bezel Width and Height: Account for the bezel size of the monitors that make up the video wall. This allows for better alignment of
videos in the video wall. These measurements only apply to Stretched BrightWall presentations. For Regular presentations, bezel width
and height will need to be accounted for in the content creation application.

® By percentage: Enter the bezel width and height as percentages. Use the following calculation to determine bezel percentages:

® Width: The width of the bezel between active screens (i.e. the total of both left and right bezels) divided by the width of
an active screen. The result is multiplied by 100. For example, a video wall made up of screens with a width of 42 inches
and a 1 inch bezel on each side would be calculated as follows: (2"/42")*100=5%

® Height: The height of the bezel between active screens (i.e. the total of both top and bottom bezels) divided by the
height of an active screen. The result is multiplied by 100. For example, a video wall made up of screens with a height of
23.625 inches and a 1 inch bezel on each side would be calculated as follows: (2"/23.625")*100=8%

Note
Bezel width and height percentages must be specified as integers (i.e. whole numbers that are positive).

® By measurement: Enter the bezel width, bezel height, screen width, and screen height in millimeters (mm). BrightAuthor will
make the calculations automatically.

® Save As: Click this button to save the BrightWall Configuration file. It will then be used as the Configuration File for the BrightWall
presentation.

Once you've created or selected a BrightWall Configuration file, click Create BrightWall Presentation. The BrightWall™ Presentation
Properties window will open.

BrightWall Presentation Properties

The BrightWall™ Presentation Properties window is divided into two tabs: Main and Audio.

Mai n
® Type: Choose whether the BrightWall presentation is Regular or Stretched:

® Regular: Each panel of the BrightWall presentation is made up of a different video file. To create a single video surface out of
multiple screens, video assets will need to be tailored for the video wall using the source application (e.g. Adobe After Effects):
You will need to split the videos into their respective screens and adjust for bezel width before adding the assets to BrightAuthor.
® Stretched: The video wall is made up of a single video. BrightAuthor automatically splits the video among the screens. This
option allows you to display video files, as well as Streaming Video, Live Video, and RF Input.
® View mode: Choose the view mode of the presentation. In Regular presentations, this option applies to videos on individual screens,
similar to the View Mode option found in the Zone Properties menu. In Stretched presentations, this option applies to the entire wall. The
following descriptions apply to Stretched presentations only:
® Scale to Fill: The video will be stretched over all screens in the video wall. If the aspect ratio of the video wall does not match
the ratio of the video content, the video will likely appear stretched or distorted.
® Letterboxed and Centered: The video will not be stretched. Instead, it will appear at the center of the video wall at its original
resolution, which may cover one or multiple screens. Areas of the video wall that are not filled by the video will display the
background color of the presentation.



® Fill Screen and Centered: The video will be stretched to the height or width of the video wall (whichever length is greater). If the
aspect ratio of the video wall does not match the ratio of the video content, the video will be cut off at the height or the width
(whichever length is lesser).

Note
The Scale to fit and Fill screen and centered options will not remove letterboxing if it's part of the video file.

® Display screen layout information when presentation starts: Check this box to have screens in the BrightWall display positioning
information for a few moments when the presentation starts scheduled playback. If this box is not checked, the presentation will begin
immediately without displaying positioning information.

Audi o

® Audio Output: Enables or disables the Analog, HDMI, and SPDIF audio outputs. In BrightWall presentations, only the master unit (i.e.
the player driving Screen 1) outputs audio, so these settings do not affect any of the slave units in the presentation.

® Pass through: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for
example, AC3 Dolby Digital) is being decoded on an external device.

® Stereo: Supplies the audio as a stereo signal.
® Audio Mixing: Enables the stereo, left-only, or right-only audio signal.

Editing a BrightwWall Presentation
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® Configuration
® Audio

To configure a BrightWall presentation, navigate to File > BrightWall™ Properties.

Main

® Type: Choose whether the BrightWall presentation is Regular or Stretched:

® Regular: Each panel of the BrightWall presentation is made up of a different video file. To create a single video surface out of
multiple screens, video assets will need to be tailored for the video wall using the source application (e.g. Adobe After Effects):
You will need to split the videos into their respective screens and adjust for bezel width before adding the assets to BrightAuthor.

® Stretched: The video wall is made up of a single video. BrightAuthor automatically splits the video among the screens. This
option allows you to display video files, as well as Streaming Video, Live Video, and RF Input.

* View mode: Choose the view mode of the presentation. In Regular presentations, this option applies to videos on individual screens,
similar to the View Mode option found in the Zone Properties menu. In Stretched presentations, this option applies to the entire wall. The
following descriptions apply to Stretched presentations only:

® Scale to Fill: The video will be stretched over all screens in the video wall. If the aspect ratio of the video wall does not match
the ratio of the video content, the video will likely appear stretched or distorted.

® Letterboxed and Centered: The video will not be stretched. Instead, it will appear at the center of the video wall at its original
resolution, which may cover one or multiple screens. Areas of the video wall that are not filled by the video will display the
background color of the presentation.

® Fill Screen and Centered: The video will be stretched to fit the height or width of the video wall (whichever length is lesser). If
the aspect ratio of the video wall does not match the ratio of the video content, the video will be cropped.

® Display screen layout information when presentation starts: Check this box to have screens in the BrightWall display positioning
information for a few moments when the presentation starts scheduled playback. If this box is not checked, the presentation will begin
immediately without displaying positioning information.

Configuration

® Configuration file: Use the Browse button to locate and select a preexisting BrightWall Configuration file to use with the BrightWall
project.
® Edit BrightWall Configuration: Edit the selected BrightWall Configuration file.
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® Create BrightWall Configuration: Create a new BrightWall Configuration file. See the Creating a BrightWall Presentation page for more

details.

Audio

® Audio Output: Enables or disables the Analog, HDMI, and SPDIF audio outputs. In BrightWall presentations, only the master unit (i.e.
the player driving Screen 1) outputs audio, so these settings do not affect any of the slave units in the presentation.

® Pass through: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for
example, AC3 Dolby Digital) is being decoded on an external device.
® Stereo: Supplies the audio as a stereo signal.
® Audio Mixing: Enables the stereo, left-only, or right-only audio signal.

Adding Video to a BrightWall Presentation
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The process of creating a video playlist for a BrightWall will differ depending on whether you created a Regular or Stretched presentation.

For a Regular Brightwall

Each screen in a video wall has a distinct playlist. You can switch among screens by selecting them in the Screen section.

To create a regular BrightWall, you will need to add a different video file (or Streaming/Live Video state) to each screen. The Media Library of a
Regular BrightWall has special properties that help streamline playlist creation:

® A video with a file name in the format “VideoName_Number” appears only in the Media Library of the screen corresponding to its

number.

® Adding a video with a “VideoName_Number” file name to a screen will add all other videos with the same format to their respective
screen playlists. This behavior will only occur if the quantity of “VideoName_Number” files corresponds to the number screens in the

BrightWall presentation.

Example

Your BrightWall project consists of four screens. The video is split into four files, each file representing ¥ of the entire wall:

“Intro_1.mpg”, “Intro_2.mpg”, “Intro_3.mpg”, and “Intro_4.mpg”. Only “Intro_1" will appear in the Media Library of Screen 1. Adding
“Intro_1" to Screen 1 will automatically add “Intro_2" to Screen 2, “Intro_3" to Screen 3, and “Intro_4" to Screen 4. If your BrightWall
project is expanded to six screens, then adding “Intro_1" will not affect the playlists of the other screens because there are only four

“Intro” video files.
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For a Stretched BrightWall

The entire video wall has the same playlist. Adding a video file, Streaming Video, Live Video, or
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RF Input to the playlist will split the video among the screens during playback.

Completing a BrightWall Presentation
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Before you can publish a BrightWall presentation, you will need to save it by navigating to File > Save or Save As. If you would like to publish a
BrightWall presentation using the BrightSign Network, click the Upload to network button once you've signed into your account. You can also
export a BrightWall presentation for use on another computer by navigating to File > Export.

When you're ready to publish to your video wall, navigate to the Publish tab and click the BrightWall Presentations option.
Creating a BrightWall on BSN
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Creating a BrightWall and distributing a BrightWall presentation to it via the BrightSign Network requires several steps within BrightAuthor. Follow
these steps to create a BrightWall group, create a BrightWall within the BrightWall group, and publish your presentation to the BrightWall group:

1. Sign in to your BrightSign Network account by navigating to Tools > Sign In to BrightSign Network.

2. After creating your BrightWall presentation, click the Upload to network button in the top-right. This will upload both the BrightwWall
presentation and BrightWall configuration file to the BrightSign Network.

3. Navigate to the Manage > Status tab.

4. Expand the BrightWall Groups section at the bottom of the screen.
5. Click Add BrightWall
Group. ) Standalone
6. Enter a BrightWall group () Networked with Local File Networking
name and select a Bright i@ Networked with the BrightSign Network
Wall configuration. The .
BrightWall configuration will () Group [CA Los Gatos - 4 ]
be applied to every @ BrightWall G Cube Wall : £ I
BrightWall created within A [ _ id
the group. Click OK when BrightWall Name [Left Cube - rig_htWaI_I_l
finished. i-(e h
7. Once you've created a frEElIT [l
BrightWall group, you will
need to set up players as Content Check Frequency: [E'.ﬂery 5 minutes hd ]
part of the BrightWall B -
configuration: Update Health Frequency: [E'.'\er_),ll 5 minutes ]
a. Navigate to Tools
> Setup

BrightSign Unit.

Select the BrightWall Group option under Networked with the BrightSign Network.

Use the BrightWall Group dropdown list to select the BrightWall group created in steps 5 and 6.

Click the Add BrightWall button to add a new BrightWall to the BrightWall group. Enter a BrightWall name and click OK.

Use the Screen Number dropdown list to specify the section of the BrightWall to which the player belongs. Screens are
numbered by row, starting from the top-left section of the BrightWall (the example diagram to the right shows the numbering of a

© 20T

4x3 Brightwall).
f. Enter the rest of the player configuration settings as desired and set up the player—see the Brigh - 2 3 4
tSign Network Setup page for more details.

8. Repeat steps 7a through 7f to set up every player in the BrightWall—make sure to use the same Bright 5 b 7 8
Wall Group and BrightWall Name for all players in the BrightWall.
g | 10| 11 | 12

9. Navigate to the Publish > BrightSign Network tab.
10. Select the BrightWall Presentations option.
11. Under Select BrightWall Group to Schedule, select the BrightWall group you created in steps 5 and 6.

12. Add one or more BrightWall presentations to the schedule—see the BrightSign Network publishing section for more details on
scheduling.

13. Click Publish schedule. Make sure all the players in the BrightWall are powered up and connected to the Internet. Allow time for the
players to download the content, reboot, and synchronize playback.
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Adding a New BrightWall to the Group

Use the Add BrightWall option during unit setup to add additional BrightWall(s) to the BrightWall group. A new BrightWall will use the same
configuration and be scheduled with the same presentations as other BrightWall(s) in the group.

Using Configuration Files

Each BrightWall presentation within a BrightWall group must use the same configuration file. If you want to create additional BrightWall
presentations with different configuration files, you will need to create additional BrightWall groups in the Manage > Status tab.

Retrieving Configuration Files from BSN

If you don’t have the original configuration file (for example, if the user who created the original configuration file is on a different PC), you will
need to retrieve it from BSN:

1. Navigate to the Manage > Presentations tab.

2. Expand the BrightWall Configurations section.

3. Right-click the original configuration file and select Download to save the file to your hard drive.

4. When creating a new BrightWall presentation, use the Browse button to locate and select this configuration file.

Publishing Presentations
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After you create and save a presentation, you're ready to publish it to your BrightSign player or players. You can use one of the following methods
to publish a presentation:

® |ocal Storage

® BrightSign Network
® Simple File Network
® Local File Network

The method you use to publish will depend on several factors, such as whether your player is networked, what kind of network you have access
to, and how many players you have.

Note
You can use any of the above methods to publish a BrightWall presentation as well. See the Publishing a BrightWall Presentation page
for more details.

Local Storage
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® Adding Presentations to Your Schedule

® Schedule Interrupts

® Debugging

® Publishing Options

® |ogging

® Firmware Updates

® Publishing the Scheduled Presentation(s)
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Tip
This tutorial video provides an overview of publishing via local storage.

Important
Unless a standalone player is connected to the Internet (or its clock is set manually), its internal clock will be inaccurate, and all
day-parted schedules (e.g. switching between presentations at a certain time of day) will be incorrect. Setting the schedule to Active all

day, every day is the only recommended practice in such instances.

Publishing a presentation using Local Storage lets you copy your presentations to an SD card or USB flash drive. When you want to update your
scheduled presentations, you must save the updated content on the SD card or USB flash drive and insert it into your BrightSign player.

Unless you are updating content, an SD card or flash drive should always remain connected to the BrightSign player. However, if your BrightSign
player has a USB port, we recommend that you create setup files with an SD card, leave it in the player permanently as internal storage, and use
a USB flash drive whenever you need to update content. You can publish updated content to the USB flash drive, insert it into the player to
update the SD card, and then remove the flash drive.

To publish via Local Storage, complete the following steps:

1. Save the presentations you want to publish by clicking File > Save... As. You will also be prompted to save a presentation if there are
unsaved changes to the presentation when you switch to the Publish tab.

. Click the Publish tab.

. Click Local Storage (below the Publish tab).

. Choose whether you want to publish Presentations or BrightWall™ Presentations.

. Click Browse under Presentations to navigate to and select the folder where your presentations are stored.

a b~ wN

Adding Presentations to Your Schedule

Follow these steps to add presentations to the player schedule:

1. Select a presentation from the list in the Presentations section.
2. Drag the presentation to a time slot during which you want it to play.
3. Click and drag the selection handles to adjust playing time within one day.

Note
Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open the Schedule Presentation win

dow.

If you want the presentation to be a recurring event, double-click the presentation timeframe in the
calendar. In the Schedule Presentation window, set the following parameters:

® Presentation: Specify which presentation you want to use in this schedule block.
® Active all day, every day: Check this box if you want the presentation to play at all times
(i.e. without day parting).
® Event time: Specify a timeframe during the day when you want the presentation to play:
® Start: Use the dropdown list to select a time when the presentation should begin
® End: Use the dropdown list to select a time when the presentation should end.
® Recurring Event: Check this box to have the presentation recur during specified days. If
you don't check this box, the Event time will only apply to the single day selected in the
schedule.
® Recurring pattern: Specify the frequency of the recurrence.
* Daily: Specify Every day, Every weekday, or Every weekend for
playback.
* Weekly: Check the boxes corresponding to the individual days of the
week when you want the presentation to play.

® Range of recurrence: Use this option to limit the recurrence of the scheduled
presentation.
® Start: Specify the start date of the scheduled recurrence. This date
defaults to the currently selected date in the schedule.
® End: Select No end to have the presentation recur indefinitely, or select E
nd by and specify the end date of the scheduled recurrence.
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Presentation: | My_First Presentation ']

Schedule Interrupts

You can create a day-parted schedule by scheduling presentations in separate time slots of a single
day (or a set of recurring days). Later on, you may need to schedule a new presentation in an ]
occupied time slot. This is where schedule interrupts are useful. Event time

Start: 10:00 AM ~

[C] Active all day, every day

If you would like to interrupt a scheduled presentation with another presentation, drag and drop the
new presentation into an occupied time slot (you can also schedule an overlap in the Schedule
Presentation window). A Schedule Conflict window will appear, providing the following options:

End: 400PM -

[T] Recurring Event
® Keep existing events, cancel new event: Cancels the new schedule presentation action.
® Keep existing events, adjust new event: Opens the Schedule Presentation window,

Recurrence pattern

allowing you to schedule the new presentation in an empty time slot. If you schedule the Lally EEE)
presentation in an occupied time slot, the Schedule Conflict window will appear again. Weekdy Every weekday
Every weekend

® Remove existing events, use new event: Completely removes the presentation currently
occupying the time slot.

® Interrupt existing events with new event: Schedules an interrupt in the presentation Range of recurrence
currently occupying the time slot. The date field will be split into two columns: The left Start | 127172014 |[[F]
column shows the primary scheduled presentation in blue; the right column shows the

interrupting presentation in green. Primary scheduled presentations can be interrupted with End: © No end date
multiple presentations, but interrupting presentations cannot overlap with each other. End by 12/19/2015 ]
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Debugging

Under Debugging, you may optionally enable the following:

® Enable serial debugging: The autorun script will output debugging information related to the presentation to the RS-232 serial port (as
well as over Telnet and SSH if these features are enabled).

® Enable system log debugging: The autorun script will output debugging information related to the presentation to the Log tab in the Dia
gnostic Web Server.
Publishing Options

Select among the following publishing options:

® Standalone Unit: Publishes the scheduled presentation(s) to the player using an SD card.
® Specify Password:(Optional) Click this button to set
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up, change, or remove password protection for USB i - )
content updates. The password protection feature ﬂn e Q

ensures that a player cannot be updated with the Pu
blish for USB update option unless the correct REETEE R 2 s e
password is supplied. 9 Keep Password
* Keep Password: Leaves the current content Set Mew Password
update password for the player unchanged.

Clear Passwaord
® Set New Password: Sets a new content

update password for the player. Enter the oK H Cancel
new password in the field.

® Clear Password: Removes the content . 4
update password. This allows USB updates
to be published to the SD card without
restrictions.

¢ Standalone unit with setup: Publishes both the scheduled presentation(s) and player setup files at the same time. When you click the P
ublish button, the BrightSign Unit Setup window will open, prompting you to configure the player for Standalone use.

® Setup unit for BrightSign Network: Includes player setup files for the BrightSign Network with the scheduled presentation(s). This

option is useful if you want to ensure that a newly set up player will run a presentation even if it cannot initially connect to the BrightSign

Network. Once the player connects to the BrightSign Network, it will update to the current presentation and schedule for its assigned

group. When you click Publish, you will be prompted to set up the player for the BrightSign Network.

Publish for USB update: Publishes the scheduled presentation(s) to a USB flash drive. You can then insert the flash drive into a

BrightSign player to update the SD card on the player. This allows you to update content on a Standalone player without ever needing to

remove the SD card. USB updates only work with players that are configured for Standalone publishing.

Important
A schedule must already be published to the SD card for the USB update to work. Publish an initial schedule via the SD card first; you
can then use the USB update feature for subsequent publishing operations.

Specify Password: Click this button if you are publishing a USB content update to a player or set of players with password protection.
Enter the USB Content Update Password. You must enter the same upgrade password designated for the player or else the player
content upgrade will fail. You can choose the password when you set the player up for standalone use or when you use the Set New
Password feature (see step 5a above).

Note
If no update password is currently set for the player, entering a phrase in this field will designate it as the new update password.

® USB update (FW only): Publishes a firmware update file to a USB flash drive. You can use this feature to update the firmware on a
player without ever needing to remove the SD card or publish a new schedule to the player. Use the Specify Firmware Update button
(described below) to determine the update version.

Logging
Click Specify Logging to enable/disable logs on the player:

® Enable playback logging: Records playback start and end times, zone names, media types, and file names.
® Enable event logging: Records timestamps, state names, zone names, event types, and event data.

® Enable state logging: Records current and last state names, timestamps, and media types.

® Enable diagnostic logging: Records timestamps, firmware and script versions, and the current presentation.

® Enable Variable logging: Records the current and default values of all User Variables in the presentation. This log is only generated
when logs are uploaded to custom log handler URL.

Firmware Updates

Click Specify Firmware Update to include a firmware update file with the published schedule. In the Firmware Update window, locate the
section corresponding to your BrightSign model and select one of the following:

® Production Release: The current official release of BrightSign firmware

® Beta Release: The current beta release of BrightSign firmware

®* Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The
minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.

® Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will download
the update file from BrightSign when the presentation schedule is published.



You can use the Update type dropdown menu to determine the behavior of the firmware update:

® Standard: The firmware update is applied, the player reboots, and the .bsfw update file deletes itself from the local storage.

¢ Different: The update will only be applied if the version of the .bsfw update file does not match the current firmware version of the player.
The file is not deleted after the update process is completed.

* Newer: The update will only be applied if the version of the .bsfw update file is newer than the current firmware version of the player. The
file is not deleted after the update process is completed.

® Save: The firmware update is applied, but the .bsfw update file is not deleted. The device will only reboot once the storage device
containing the update file is removed.

Publishing the Scheduled Presentation(s)

Once you've created the presentation schedule and configured the publishing options, follow these steps to publish the schedule to your
BrightSign player(s):

1. Insert an SD card or USB flash drive into your computer.

2. Under Publish to, click Browse. Navigate to and select the drive where your storage device is located. Make sure to select the root
folder of the SD card or USB flash drive (e.g. "SD:/").

3. Click Publish. When the Publish complete window opens, click OK.

4. Update your BrightSign player:
a. Turn off the BrightSign player by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
b. Insert the storage device into the player.
c. Turn on the BrightSign unit by reconnecting the power.

Note
If an SD card is already in the player and you are updating it via USB, you don’t need to turn off the player. Insert the USB flash drive
into the player, wait until the Update Complete message appears on the display, and then remove the flash drive.

BrightSign Network
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The BrightSign Network allows you to distribute presentations to your BrightSign players over the Internet.

The BrightSign Network requires a subscription, so you must first contact BrightSign to obtain an account name, user name, and password. Once
your BrightSign players are set up with the BrightSign Network, you can upload your presentations and assign schedules to groups. Your players
will then update their content automatically when they connect to the server.

The BrightSign Network distributes presentations and schedules to groups instead of players. Groups can contain any number of players, and you
can move BrightSign players from one group to another at any point. See Managing Your Network for details. To publish with BrightSign Network,
complete the following steps:

. Sign into BrightSign Network by clicking Tools > Sign in to BrightSign Network.

. Open the presentation you wish to publish by selecting File > Open presentation.

. Click Upload to network (in the upper-right portion of the screen) to upload the presentation to the server.:

. Click the Publish tab.

. Select BrightSign Network(above the calendar).

. Choose whether you want to publish Presentations or BrightWall™ Presentations.

. Under Selected Group to Schedule, use the dropdown list to specify the group to which you want to publish.
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Adding Presentations to Your Schedule

Follow these steps to add presentations to the group schedule:

1. Select a presentation from the list in the Presentations section.
2. Drag the presentation to a time slot during which you want it to play.
3. Click and drag the selection handles to adjust playing time within one day.

Note

Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open the Schedule Presentation win

dow.

If you want the presentation to be a recurring event, double-click the presentation timeframe
in the calendar. In the Schedule Presentation window, set the following parameters:

® Presentation: Specify which presentation you want to use in this schedule block.

® Active all day, every day: Check this box if you want the presentation to play at all
times (i.e. without day parting).

® Event time: Specify a timeframe during the day when you want the presentation to

play:
® Start: Use the dropdown list to select a time when the presentation should
begin
® End: Use the dropdown list to select a time when the presentation should
end.

® Recurring Event: Check this box to have the presentation recur during specified
days. If you don't check this box, the Event time will only apply to the single day
selected in the schedule.
® Recurring pattern: Specify the frequency of the recurrence.
* Daily: Specify Every day, Every weekday, or Every weekend for
playback.
® Weekly: Check the boxes corresponding to the individual days of
the week when you want the presentation to play.
® Range of recurrence: Use this option to limit the recurrence of the
scheduled presentation.
® Start: Specify the start date of the scheduled recurrence. This date
defaults to the currently selected date in the schedule.
® End: Select No end to have the presentation recur indefinitely, or
select End by and specify the end date of the scheduled
recurrence.

Schedule Changes

EB Schedule Presentation

B

Presentation: | My_First Presentation 'l

[T Active al day, every day
Event time
Start: 10:00 AM -
End: 400PM -

[ Recurring Event
Recurrence pattern

Daily Every day

Weekdy Every weekday

Every weekend

Range of recurrence
Start | 12/1/2014 ||

End: Mo end date
End by 1241972015

oK || cancel

If you drag and drop the new presentation into an occupied time slot (or schedule an overlap in the Schedule Presentation window), a Schedule

Conflict window will appear, providing the following options:

® Keep existing events, cancel new event: Cancels the new schedule presentation action.

® Keep existing events, adjust new event: Opens the Schedule Presentation window, allowing you to schedule the new presentation in
an empty time slot. If you schedule the presentation in an occupied time slot, the Schedule Conflict window will appear again.

® Remove existing events, use new event: Completely removes the presentation currently occupying the time slot.



D WebSignage - XD1230 - BrightAuthar = | G e
File Edit Tools Help
Publish Manage BrlghtAUthor Signed in to account: peterdemo
Local Storage » BrightSign Network Local Network Simple File Network
@ Presentations @ BrightWall Presentations . —
Apil19.25 2015 BE=ms P
Select Group to Schedule
NC Raleigh v] Sun, 4/19 Mon, 4/20 Tue. 4/21 Wed, 4/22 Thu, 4/23 Fri, 4/24 Sat. 4/25
non-stop | 1oR-5top event non-stop event non-stop event non-stop event non-stop event nan-stop event non-stop event
Presentations Advanced Audio Playlis Advanced Audio Playlis Advanced Audio Playlis Advanced Audio Playlis Advanced Audio Playlis Advanced Audio Playlis Advanced Audio Playlis
UV Test Presentation XD 2 am
UV Test Presentation XD230
UV Update Test 1
UV Update Test 2 9am
UV Update Test 3
UV Update Test 4 10 am
UV Update Test 5
WebSignage
XD Largeloop A 1t &1
XD SimpleLoop 3
XD Test 1 noon -
XD TimeClock Test 1 i
1pm
Debugging
[] Enable serial debugging 2 pm
["] Enable system log debugging
3 pm L
Specify Firmware Update 3
" 4 pm
Publish Schedule
5pm
6 pm
7 pm
8 pm -
Debugging

Under Debugging, you may optionally enable the following:

® Enable serial debugging: The autorun script will output debugging information related to the presentation to the serial port (as well as
over Telnet and SSH if these features are enabled).

® Enable system log debugging: The autorun script will output debugging information related to the presentation to the Log tab in the Dia
gnostic Web Server.

Firmware Updates

Click Specify Firmware Update to update the group firmware along the schedule. In the Firmware Update window, locate the section
corresponding to the BrightSign model type in the group and select one of the following:

® Production Release: The current official release of BrightSign firmware
® Beta Release: The current beta release of BrightSign firmware

®* Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The
minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.

® Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will use update
files stored on the BrightSign Network servers.

Publishing the Scheduled Presentation(s)

Once you've created the presentation schedule and configured the publishing options, click Publish Schedule. When the Publish Complete win
dow appears, click OK.

Simple File Network
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Simple File Networking allows you to distribute presentations to your BrightSign players using a web server. To use this publishing method,
players must be set up for Simple File Networking with the correct URL for web folder.

. In BrightAuthor, save the presentation(s) you want to publish by clicking File > Save... As

. Click the Publish tab.

. Select the Simple File Network option(above the Calendar).

. Choose whether you want to publish Presentations or BrightWall Presentations.

. Under Presentations, click Browse to navigate to and select the folder where your presentations are stored.
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Adding Presentations to Your Schedule

Follow these steps to add presentations to the player schedule:

1. Select a presentation from the list in the Presentations section.
2. Drag the presentation to a time slot during which you want it to play.
3. Click and drag the selection handles to adjust playing time within one day.

Note
Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open the Schedule Presentation win

dow.

@ Schedule Presentation Iﬁ

Presentation: | My_First Presentation 'l

If you want the presentation to be a recurring event, double-click the presentation timeframe
in the calendar. In the Schedule Presentation window, set the following parameters:

® Presentation: Specify which presentation you want to use in this schedule block.
® Active all day, every day: Check this box if you want the presentation to play at all [C] Active all day, every day
times (i.e. without day parting).

. . . . . Event time
® Event time: Specify a timeframe during the day when you want the presentation to
play: Start 10:00 AM ~
® Start: Use the dropdown list to select a time when the presentation should
begi P P End: 400PM -
egin
® End: Use the dropdown list to select a time when the presentation should
end. [T Recurring Event

® Recurring Event: Check this box to have the presentation recur during specified

; - - . R ttel
days. If you don't check this box, the Event time will only apply to the single day eeurrence pattem

selected in the schedule. Daily Every day
® Recurring pattern: Specify the frequency of the recurrence. Weekly Every weekday
® Daily: Specify Every day, Every weekday, or Every weekend for Every weekend
playback.

® Weekly: Check the boxes corresponding to the individual days of
the week when you want the presentation to play. IEIE s s

® Range of recurrence: Use this option to limit the recurrence of the S| L2 J

scheduled presentation. End: Mo end date
® Start: Specify the start date of the scheduled recurrence. This date defaults End by 1271972015 | |5
to the currently selected date in the schedule.
® End: Select No end to have the presentation recur indefinitely, or select En oK ” Cancel

d by and specify the end date of the scheduled recurrence.

Schedule Interrupts



You can create a day-parted schedule by scheduling presentations in separate time slots of a single day (or a set of recurring days). Later on, you
may need to schedule a new presentation in an occupied time slot. This is where schedule interrupts are useful.

f you would like to interrupt a scheduled presentation with another presentation, drag and drop the new presentation into an occupied time slot
(you can also schedule an overlap in the Schedule Presentation window). A Schedule Conflict window will appear, providing the following
options:

® Keep existing events, cancel new event: Cancels the new schedule presentation action.

® Keep existing events, adjust new event: Opens the Schedule Presentation window, allowing you to schedule the new presentation in
an empty time slot. If you schedule the presentation in an occupied time slot, the Schedule Conflict window will appear again.

® Remove existing events, use new event: Completely removes the presentation currently occupying the time slot.

® |nterrupt existing events with new event: Schedules an interrupt in the presentation currently occupying the time slot. The date field
will be split into two columns: The left column shows the primary scheduled presentation in blue; the right column shows the interrupting
presentation in green. Primary scheduled presentations can be interrupted with multiple presentations, but interrupting presentations
cannot overlap with each other.
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Debugging

Under Debugging, you may optionally enable the following:

® Enable serial debugging: The autorun script will output debugging information related to the presentation to theserial port (as well as
over Telnet and SSH if these features are enabled).

® Enable system log debugging: The autorun script will output debugging information related to the presentation to the Log tab in the Dia
gnostic Web Server.

Simple File Networking Parameters

If you wish to reconfigure some of the device
parameters, click the Set Parameters button.
These changes will only affect players that
receive the presentation schedule.

® URL for the web folder: Specify a new
location from which the player will
download content updates. Do not use
trailing slashes in your URL; some web
servers do not support trailing slashes.



Tip

See this FAQ if you're having
trouble getting players to
communicate with your web
server.

Content Check Frequency: Set how
often you want the player to check your
server for updates.

Simple File Networking
Authentication:(Optional) Enter a User
name and password to enable digest
authentication between the BrightSign
player and the web server.

® Enable basic authentication:
Check this box to have the
player pass credentials to the
web server in unsecured
packets. Use this option only if
it is absolutely required by the
configuration of your web
server.

Logging: Check the boxes to enable
any of the following:
®* Enable playback logging:
Records playback start and end
times, zone names, media
types, and file names.
® Enable event logging:
Records timestamps, state
names, zone names, event
types, and event data.

® Enable state logging: Records current and last state names, timestamps, and media types.

TSI CTECR T TE STy
Simple File Networking Authentication (optional)
User name:
Password:
Enable basic authentication

Limit content downloads

Start of range: 00 : |00
End of range: 00 : |00
Logging

| Enable playback logging

/| Enable event logging

| Enable diagnostic logging

/| Enable state logging
Enable Variable logging

Upload logs

| On startup
| At specific time each day

Upload time: E| : @|

Saveupto 50  images (1 - 100) on local storage.

JPEG quality level 50  {0- 100).

Display snapshots in portrait mode

()

® Enable diagnostic logging: Records timestamps, firmware and script versions, and the current presentation.
® Enable Variable logging: Records the current and default values of all User Variables in the presentation. This log is only
generated when logs are uploaded to custom log handler URL.
® Upload logs: Check either of the following:
® On startup: Uploads log files each time the player is powered on.
® At specific time each day: Uploads log files daily at the specified time. Use the dropdown lists to pick a time.

Enable remote snapshot: Check this box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of

the presentation display.

Note

The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

Remote snapshot every [ ] minutes: Specify how often the player should take a snapshot of the presentation display.
Save up to [ ] images (1 - 100) on local storage: Specify how many JPEG snapshot images can be stored on the local storage of the

player.

JPEG quality level [ ] (0 - 100): Specify the quality level (and thus the file size) of each image file.

Display snapshots in portrait mode: Check this box to have the player rotate the snapshots to portrait mode before saving and

uploading them.

Firmware Updates

Click Specify Firmware Update to include a firmware update file with the published schedule. In the Firmware Update window, locate the
section corresponding to your BrightSign model and select one of the following:

Production Release: The current official release of BrightSign firmware
Beta Release: The current beta release of BrightSign firmware

Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The

minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.
Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will download
the update file from BrightSign when the presentation schedule is published.
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You can use the Update type dropdown menu to determine the behavior of the firmware update:

® Standard: The firmware update is applied, the player reboots, and the .bsfw update file deletes itself from the local storage.

® Different: The update will only be applied if the version of the .bsfw update file does not match the current firmware version of the player.
The file is not deleted after the update process is completed.

® Newer: The update will only be applied if the version of the .bsfw update file is newer than the current firmware version of the player. The
file is not deleted after the update process is completed.

® Save: The firmware update is applied, but the .bsfw update file is not deleted. The device will only reboot once the storage device
containing the update file is removed.

Publishing the Scheduled Presentation(s)

Under Publish to, click Browse to navigate to and select the location where you want to store the files.

® |f you have a mapped drive or shortcut that points to your web folder, publish to that location.

® |f you use FTP to transfer files to your web folder, publish to a folder on your computer and then use FTP software to copy the files to
your web folder.

Click Publish. When the Publish Complete window opens, click OK.

Local File Network
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Local File Networking allows you to publish presentations to your BrightSign players without requiring a remote server or an Internet connection.
This is convenient if you only have a small number of BrightSign players that are all on the same local network. With Local File Networking,
BrightSign players do not poll a remote web server to receive updates. Instead, you select one or more BrightSign players in BrightAuthor and
push content directly to them. Updates will then be sent to the BrightSign player immediately.

Important

Local File Networking supports a maximum of 10 players on a local network. Exceeding this recommended number may cause
unreliable behavior when publishing to players. For larger deployments, we recommend using the Simple File Network or BrightSign
Network publishing methods instead.

. Save the presentation you want to publish by clicking File > Save As

. Click the Publish tab.

. Click Local Network (above the Calendar).

. Choose whether you want to publish Presentations or BrightWall Presentations.

. Under Presentations, click Browse to navigate to and select the folder where your presentations are stored.
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Adding Presentations to the Schedule

Follow these steps to add presentations to the player schedule:

1. Select a presentation from the list in the Presentations section.
2. Drag the presentation to a time slot during which you want it to play.
3. Click and drag the selection handles to adjust playing time within one day.

Note
Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open the Schedule Presentation win
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ﬂB Schedule Presentation L&J

If you want the presentation to be a recurring event, double-click the presentation timeframe
in the calendar. In the Schedule Presentation window, set the following parameters:

Presentation: | My_First_Presentation 'l

® Presentation: Specify which presentation you want to use in this schedule block.
® Active all day, every day: Check this box if you want the presentation to play at all [C] Active all day, every day
times (i.e. without day parting).

. . . . . Ewvent time
® Event time: Specify a timeframe during the day when you want the presentation to
play: Star: 10:00 AM ¥
¢ Start: Use the dropdown list to select a time when the presentation should
- P P End: 400PM ~
egin
® End: Use the dropdown list to select a time when the presentation should
end. [T Recurring Event
® Recurring Event: Check this box to have the presentation recur during specified FETrTETEEELET
days. If you don't check this box, the Event time will only apply to the single day
selected in the schedule. Daily Every day
® Recurring pattern: Specify the frequency of the recurrence. Weekly Every weekday
* Daily: Specify Every day, Every weekday, or Every weekend for Every weekend

playback.

®* Weekly: Check the boxes corresponding to the individual days of
the week when you want the presentation to play.

® Range of recurrence: Use this option to limit the recurrence of the Start: | 12/1/2014 ||[F]
scheduled presentation. End: g et T

® Start: Specify the start date of the scheduled recurrence. This date End by 12/19/2015
defaults to the currently selected date in the schedule.

® End: Select No end to have the presentation recur indefinitely, or oK H Cancel
select End by and specify the end date of the scheduled
recurrence. i

Range of recurrence

Schedule Interrupts

You can create a day-parted schedule by scheduling presentations in separate time slots of a single day (or a set of recurring days). Later on, you
may need to schedule a new presentation in an occupied time slot. This is where schedule interrupts are useful.

If you would like to interrupt a scheduled presentation with another presentation, drag and drop the new presentation into an occupied time slot
(you can also schedule an overlap in the Schedule Presentation window). A Schedule Conflict window will appear, providing the following
options:

® Keep existing events, cancel new event: Cancels the new schedule presentation action.

® Keep existing events, adjust new event: Opens the Schedule Presentation window, allowing you to schedule the new presentation in
an empty time slot. If you schedule the presentation in an occupied time slot, the Schedule Conflict window will appear again.

® Remove existing events, use new event: Completely removes the presentation currently occupying the time slot.

® Interrupt existing events with new event: Schedules an interrupt in the presentation currently occupying the time slot. The date field
will be split into two columns: The left column shows the primary scheduled presentation in blue; the right column shows the interrupting
presentation in green. Primary scheduled presentations can be interrupted with multiple presentations, but interrupting presentations

cannot overlap with each other.



ﬁn Project 10 - XD1230 - BrightAuthor
File Schedule Edit Tools Help
Publish BrlghtAUthor Signed in to account:
Local Storage BrightSign Network | # Local Network Simple File Network
@ Presentations ) Video Walls
January 26-1 2014
CA\BrightSign Content
Sun, 1/26 Mon, 1/27 Wed, 1/29 Thu, 1/30 Fri, 1/31 Sat, 2/1
UV Test Presentation XD .
UV Test Presentation XD230 non-stop Schedule
UV Update Test 1
UV Update Test 2 | Interrupt
UV Update Test 3 8am
UV Update Test 4
UV Update Test 5 9am WebSignag WebSignag WebSignage
‘WebSignage 09:00 AM - 05: 09:00 AM - 05: 09:00 AM - 05:00 PM
XD Largeloop A 10
XD SimpleLoop = am =
XD Simpleloop
KD Test1
XD TimeClock Test 1 v T MEALIOETIET
XD SimpleLoop
Debugging ET Pri 1 Project1 | 11:30 AM - 07:30 PM
1200 PM - 02: 12:00 PM - 021 B
Enable serial debugging
Enable system log debugging 1pm
Publish 2pm
Project 2
) New unit 2 R
@ Networked units B L
X0G38W000910 [
X2F2CX000035 = 4pm
LobbyX1F2CV000263 M
9w| s
- 6p .
Specify Firmware Update Prlmal’y
el Schedule
8 pm

Debugging

Under Debugging, you may optionally enable the following:

® Enable serial debugging: The autorun script will output debugging information related to the presentation to the RS-232 serial port (as
well as over Telnet and SSH if these features are enabled).

® Enable system log debugging: The autorun script will output debugging information related to the presentation to the Log tab in the Dia
gnostic Web Server.

Firmware Updates

Click Specify Firmware Update to include a firmware update file with the published schedule. In the Firmware Update window, locate the
section corresponding to your BrightSign model and select one of the following:

® Production Release: The current official release of BrightSign firmware
® Beta Release: The current beta release of BrightSign firmware

®* Minimum Compatible Release: The minimum firmware version that supports presentations created by your version of BrightAuthor. The
minimum compatible firmware will likely not support all features provided by a contemporary version of BrightAuthor.

® Select specific file: Use the Browse button to select a .bsfw firmware update file from your hard drive. The other options will download
the update file from BrightSign when the presentation schedule is published.

You can use the Update type dropdown menu to determine the behavior of the firmware update:

® Standard: The firmware update is applied, the player reboots, and the .bsfw update file deletes itself from the local storage.

® Different: The update will only be applied if the version of the .bsfw update file does not match the current firmware version of the player.
The file is not deleted after the update process is completed.

* Newer: The update will only be applied if the version of the .bsfw update file is newer than the current firmware version of the player. The
file is not deleted after the update process is completed.

® Save: The firmware update is applied, but the .bsfw update file is not deleted. The device will only reboot once the storage device
containing the update file is removed.

Publishing the Scheduled Presentation(s)

Under Publish, select a BrightSign player. You can publish to multiple players at once by holding down the Ctrl key while clicking each player.

® |f Bonjour is enabled in BrightAuthor: The player should appear in the Publish list automatically. If the player does not appear, ensure
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that it is set up for Local File Networking and that it contains an SD card or USB flash drive. Power cycle the unit, wait a minute, and click
to refresh the list. If you're still having trouble, see the Bonjour FAQ for further troubleshooting steps.

® |f Bonjour is disabled in BrightAuthor: You will need to add the player manually. Click to open the Add BrightSign Unit window. Enter IP
address of the new BrightSign unit, and click OK. The player will be added to the Publish list permanently (unless the player IP address
changes).

Select one of the following publishing options:

® New unit: The BrightSign Unit Setup window will open when you publish the presentation schedule, allowing you to configure (or
reconfigure) device properties associated with the player(s). See the Local File Network Setup page for more details.

* Networked units: The presentation schedule will be published without modifying the device properties associated with the player(s).

Click Publish. When the Publish Complete window opens, click OK.

Publishing a BrightWall Presentation

=~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

ON THIS PAGE

® Adding BrightWall Presentations to Your Schedule
® Schedule Interrupts
® Publishing the Scheduled BrightWall Presentation(s)
® | ocal Storage
® BrightSign Network
® Local Network
® Simple File Network

To publish a BrightWall™ presentation, navigate to the Publish tab, choose your desired publishing option (BrightSign Network, Standalone,
etc.), and select BrightWall™ Presentations in the top left. Note that BrightWall presentations and standard presentations cannot be placed on
the same schedule.

Adding BrightWall Presentations to Your Schedule

Follow these steps to add BrightWall presentations to the player schedule:

1. Select a BrightWall presentation from the list in the Presentations section.
2. Drag the BrightWall presentation to a time slot during which you want it to play.
3. Click and drag the selection handles to adjust playing time within one day.

If you want the BrightWall presentation to be a recurring event, double-click the presentation timeframe in the calendar. In the Schedule
Presentation window, set the following parameters:

® Presentation: Specify which BrightWall presentation you want to use in this
schedule block.

® Active all day, every day: Check this box if you want the BrightWall presentation to
play at all times (i.e. without day parting).
® Event time: Specify a timeframe during the day when you want the
BrightWall presentation to play:
® Start: Use the dropdown list to select a time when the
BrightWall presentation should begin
® End: Use the dropdown list to select a time when the
BrightWall presentation should end.
® Recurring Event: Check this box to have the BrightWall presentation recur during
specified days. If you don't check this box, the Event time will only apply to the
single day selected in the schedule.
® Recurring pattern: Specify the frequency of the recurrence.

® Daily: Specify Every day, Every weekday, or Every weekend for
playback.
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® Weekly: Check the boxes corresponding to the individual days of i @ Schedule Presentation & |
the week when you want the BrightWall presentation to play.

® Range of recurrence: Use this option to limit the recurrence of the Presentation: | My_First Presentation ~ |
scheduled presentation.
® Start: Specify the start date of the scheduled recurrence. This date
defaults to the currently selected date in the schedule. Eventhme
®* End: Select No end to have the presentation recur indefinitely, or
select End by and specify the end date of the scheduled

recurrence. End: 400PM ~

[C] Active all day, every day

Start: 10:00 AM -

Schedule Interrupts [ Recurring Event
You can create a day-parted schedule by scheduling BrightWall presentations in separate Recurrence pattern
time slots of a single day (or a set of recurring days). Later on, you may need to schedule a
new BrightWall presentation in an occupied time slot. This is where schedule interrupts are
useful.

Daily Every day
Weeldy Every weekday
. . . . . . Every weekend
If you would like to interrupt a scheduled BrightWall presentation with another presentation,
drag and drop the new BrightWall presentation into an occupied time slot (you can also
schedule an overlap in the Schedule Presentation window). A Schedule Conflict window Range of recurrence

will appear, providing the following options: —
Start: | 12/1/2014 | |8

® Keep existing events, cancel new event: Cancels the new schedule presentation
action. End: Mo end date

® Keep existing events, adjust new event: Opens the Schedule Presentation windo End by 12/15/2015
w, allowing you to schedule the new BrightWall presentation in an empty time slot. If
you schedule the BrightWall presentation in an occupied time slot, the Schedule QK H o
Conflict window will appear again.

® Remove existing events, use new event: Completely removes the .

BrightWall presentation currently occupying the time slot.

® Interrupt existing events with new event: Schedules an interrupt in the
BrightWall presentation currently occupying the time slot. The date field will be split into two columns: The left column shows the primary
scheduled presentation in blue; the right column shows the interrupting presentation in green. Primary scheduled presentations can be
interrupted with multiple presentations, but interrupting presentations cannot overlap with each other.

Publishing the Scheduled BrightWall Presentation(s)

Local Storage
Once you have finished scheduling your BrightWall presentation(s), click the Publish button to bring up the Publish BrightWall window:

® Publish each screen in a subfolder of a parent folder: The project and media files for each screen will be published in separate
subfolders of the specified parent folder. Use this option if you don’t want to publish to the SD cards of all the BrightWall players while in
BrightAuthor. This option is also useful if you'd like the entire BrightWall presentation contained in a package that can be easily
transported between directories, computers, etc.

® Publish each screen individually: You will be given a separate prompt for publishing the project files of each screen. Use this option if
you want to immediately set up the SD cards for players in the video wall.

Bri ght Si gn Net wor k

Select a BSN BrightWall Group using the dropdown menu under Select BrightWall Group to Schedule. The BrightWall configuration file
assigned to the group determines which presentations are available in the BrightWall Presentations list: A BrightWall presentation will not
appear in this list if it uses a different configuration file from the group.

If you haven't created a BrightWall Group yet, navigate to the Manage > Status tab to create one. Once you've created a BrightWall Group,
return to the Publish > BrightSign Network tab and click to refresh the dropdown list. See the Creating a BrightWall on the BrightSign Network
page for a complete outline of the BSN BrightWall process.

Once you've selected a BrightWall Group, click Publish Schedule to assign the schedule to the BrightWall Group.

Local Network
Once you have finished scheduling your BrightWall presentation(s), click the Publish button to bring up the Publish BrightWall window:

1. Select a networked player next to each Screen Name. Make sure the specified players correspond to the correct screen-location
numbers in the video wall. The screen-location numbers are shown in the screen layout window of the BrightWall presentation.



2. Click Refresh to refresh the dropdown lists of players currently active on the local network.
3. Click Add to add new networked players to the dropdown lists of players on the local network.
4. Once all of the target players have been specified, click Publish to publish the video wall.\

Create S - - @ Ppublish BrightWal™ 5
Dynamic Playlist Live Data Feed » ErightWal™ Screen name Unit to publish to
Screen Screen 1 [XBBDZOCKJIIZ 'l
Screen 2 | XDG38WO000910 -]
Screen 3 | X2F2CX000035 -]
Screen 4 | LobbyX1F2CV000263 -]
Media Library =[] @@
files | other | Publish || Cancel |

CABrightSign Content\Additional Conte Z/@

Sinple File Network
Once you have finished scheduling your BrightWall presentation(s), click the Publish button to bring up the Publish BrightWall window:

® Publish each screen in a subfolder of a parent folder: The project and media files for each screen will be published in separate
subfolders of the specified parent folder. You will then need to upload the parent file to your file server.

Presentation Properties

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

You can use the Presentation Properties window to edit a range properties for the current presentation. To edit presentation properties, open a
presentation project and navigate to File > Presentation Properties.

Main

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

The Main tab contains general presentation settings:

® Connector type: Use the dropdown list to indicate the type of connector you are using for your display.

® Screen resolution: Use the dropdown list to set a resolution supported by your display.

® Portrait Mode: Modify the monitor orientation of your portrait presentation. This option is only available if you selected a portrait mode in
the New Project window.

® Force Resolution: Check this box to have the player output the selected Screen resolution even if the display reports over HDMI/VGA
that it does not support this resolution. If this box is unchecked, the player will attempt to use the selected Screen resolution first, but will
then fall back to the highest resolution supported by the display if it is unsupported.

® Enable 4.2.0 10-bit output:(XTx42, 4Kx42 models only) Check this box to output a 4.2.0 10-bit 4Kp60 or 4Kp50 video signal to the
connected display. See the video encoding FAQ for more details on supported 4K color spaces and bit depths.

® Background screen color: Click Choose to select a background color for the presentation. This color will show through if there's no
content on an area of the screen, or if the content has some level of transparency (and is not located on top of other content).

® | anguage: Use the dropdown list to select a language for your presentation. This option affects the time/date display of Clock zones
only, and can be customized in the Edit > Preferences > Clock tab.

® RF channel scan file: Choose an RF channel scan XML file to associate with the presentation. All RF In states in the presentation will
use this channel scan file. If you specify a different channel scan file in an RF In state, the RF channel scan file in this tab will change as
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well.

Note
A player can only contain a single RF channel manifest at any one time. Playing the presentation associated with the RF channel scan

file will overwrite any previous RF channel configuration on the player. Furthermore, if you use a Tuner Scan state to create a new RF
channel manifest while the presentation is running, the RF channel manifest specified in Presentation Properties will be overwritten.

® Delay schedule change until current media item completes playback: Check this box to have a player wait until a media item
completes playback to switch to a new scheduled presentation. For multi-zone presentations, the first media item to complete playback,
no matter the zone, will trigger the scheduled presentation change. If this box is unchecked, a player will switch from one scheduled

presentation to another at the specified time, without taking into account where playback is in the current presentation.
=0

Main ‘ /O | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | upp |

@ Presentation Properties

Connector type: |HDMI A }

Screen resolution: [

3840x2160x60p -

Force Resolution:
O

Enable 4.2.0 10-bit output:

Background screen color: .
Language: |English ¥

["] Delay schedule change until current media item completes playback

E QK i [ Cancel

I/0

w BrightAuthor Version 4.7
® Version 4.6
® Version 4.4
® Previous Versions

Many BrightSign models feature a DA15 or Phoenix-style GPIO port for device communication and interactive input/output. Select Input or Outpu
t for each GPIO button to indicate whether it should be used to receive or send information.

Note
The "button" numbers described here are not the same as GPIO "pin" humbers: Some pins act as power supply or ground, so they are

not included in the button numbering scheme. See the hardware manual associated with your player model to view a mapping of
buttons to pins.
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Presentation Properties E‘Elg
| Main | /O | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |
GPIO Configuration
GPIO 0 @ Input ) Output
GPIO L: @ Input ) Output
GPIO 2: @ Input ) Qutput
GPIO 3: @ Input ) Output
GPIO 4: @ Input ) Qutput
GPIO 5: @ Input ) Qutput
GPIO 6 O Input @ Qutput
GPIO 7: ) Input @ Qutput
ok || Cancel
Interactive

~ BrightAuthor Version 4.7

® \ersion 4.6
® Version 4.4

® Previous Versions

ON THIS PAGE

® Serial

* UDP

® Synchronization
® Touch

Use the Interactive tab to configure settings for serial, USB, and UDP communications.

ﬂm Presentation Properties

=

Main | /0 | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

Serial

Parity: | none
Stop bits: | 1
uoe
UDP Destination Address

@ Specific IP address
255.255.255.255

UDP Destination Port 5000

UDP Receiver Port 5000

Touch

Cursor

() Always hide cursor

() Always display cursor
'@ Auto display cursor

[T Flip Coordinates

ort: - rotoco eceiver
Port: |2 P | |Asch [¥] GPS Recei

Baud rate: | 4800 Send EOL | CR+LF

Data bits: | & Receive EOL | CR+LF

(©) Al devices on the local subnet

Invert signals

Synchronization
[7] Enable enhanced synchronization
Master
Slave
Domain (a unique number between 0 and 127 for each group of units on a network):
0
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Serial

Use this section to configure serial port communications:

® Port: Select a serial port to configure. Most standard serial devices enumerate on port 0 (on the HO523, they will enumerate on port 1). If
you are connecting a USB-serial device (such as a GPS receiver), it will enumerate on port 2.

® GPS Receiver: Check this box if the port is being used to connect a USB-serial GPS device to the player.
® Baud rate: Set the baud rate for serial communications on the port.

® Data bits: Set the number of data bits.

® Parity: Set the parity.

® Stop bits: Select the number of stop bits.

® Protocol: Determine whether the serial data is formatted as Binary or ASCII.

® Send EOL: Select the end-of-line character when sending data to a serial device.

® Receive EOL. Select the end-of-line character when receiving data from a serial device.

® |nvert Signals: Check this box to invert the TX/RX signal levels on the serial port. This allows the player to communicate with devices
that use -12V to 12V signaling. Inversion is supported on the DE9 and USB ports only.

UDP

Use this section to configure UDP communications:

® UDP Destination Address: Specify where UDP commands generated by the presentation should be sent:
® Specific IP Address: Enter a single destination IP address in dotted quad form.
® All devices on the local subnet: Select this option to broadcast UDP messages to all devices on the local subnet.
® UDP Destination Port : Specify the destination port for UDP messages generated by the presentation.
® UDP Receiver Port: Specify the port used by the player to receive UDP messages (for triggering UDP Input events on the player).

Synchronization

Check the Enable enhanced synchronization box to use a player synchronization scheme similar to the BrightWall™ feature. When this feature
is enabled, interactive presentations using Synchronize events can be easily linked by a master/slave scheme: The presentation sending a Synch
ronize command acts as the master, while the presentation(s) using Synchronize events act as slaves. Synchronize events associated with slave
presentations will trigger within a few milliseconds of the Synchronize command associated with the master presentation.

® Master: Select this option to have the presentation send Synchronize commands. A master presentation cannot contain Synchronize
events (i.e. you cannot chain one master presentation to another).
® Slave: Select this option to have the presentation receive Synchronize commands (via Synchronize events).

® Domain: Enter a domain number between 0 and 127. This number needs to be unique for each set of master/slave presentations on the
local network. This will ensure that multiple groups of synchronized presentations can operate on the same local network without
synchronization messages interfering with each other.

Touch

Use this section to configure Rectangular Touch events:
® Cursor: Select a mouse display option for Rectangular Touch events:
® Always hide cursor: The mouse cursor will never appear with Rectangular Touch events.
® Always display cursor: The mouse cursor will always appear with Rectangular Touch events
® Auto display cursor: The mouse cursor will be present only if there is more than one touch region on the screen.

® Flip coordinates: Check this box to reverse the coordinates of the touchscreen input.

Buttons

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

Use the Button Panel dropdown list to select the type of button panel (BP200 or BP900) you wish to configure. The A, B, and C letters specify
which device is enumerated first; the B and C letters are only applicable if you are connecting more than one BP device of the same model
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number to the player.
Choose one of the following:

® Automatically configure which buttons are enabled: Only buttons that are configured with BP200/BP900 events in the presentation
will be enabled. All other buttons will not light up or react to button presses

® Specify which buttons are enabled: Only the specified buttons will be enabled regardless of whether there are BP200/BP900 events in
the presentation that are configured to use them. If this option is selected, a BP200/BP900 event set to the Any Button option will only
react to button numbers that have been enabled.

BB Presentation Properties = | G e

| Main | /O | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

Button Panel Configuration

Button Panel: |BPOODA ~

_) Automatically configure which buttons are enabled
@ Specify which buttons are enabled

Button 1

Button 2

Button 3

[C] Button 4

[C] Button 5

[C] Button 6

[C] Button 7

[] Button 8

[] Button 9

[] Button 10

[] Button 11

ok || cancel

.

Audio

~ BrightAuthor Version 4.7
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Use the Audio tab to configure audio mixing and output options:

® Audio Configuration: Configure the audio routing for the presentation:

® Mixed Audio PCM Only: Multiple PCM audio sources (for example, from a video and audio file playing simultaneously) will be
mixed into a single source for audio outputs. Differing volume levels will be normalized, and differing sampling rates (e.g. 44.1
kHz vs. 48 kHz) will be merged into a single rate of 48 kHz. This setting also allows for dynamic adding and removing of audio
sources while audio is already playing.

® Mixed Audio PCM / Compressed: The behavior is the same as the Mixed Audio PCM Only setting, but compressed audio is
supported as well.

® Fixed Audio: Audio sources are mixed only if their sampling rates match, and volume levels will not be normalized. If you
attempt to add or remove audio sources while audio is playing, playback will fail.

Note
The Mixed Audio options require firmware version 7.0.x or later, while the Fixed Audio option is the legacy behavior.

® Audio: Set the Minimum Volume and Maximum Volume for the audio output (0 — 100).
®* HDMI: Set the Minimum Volume and Maximum Volume for the HDMI output (0 — 100).
® SPDIF: Set the Minimum Volume and Maximum Volume for the SPDIF output (0 — 100).

Note
The Maximum Volume settings for Audio, HDMI, and SPDIF will be overridden by other volume settings in a presentation, including
the Initial Volume setting for a zone and volume commands attached to events or states.
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BB Presentation Properties E@ﬂ

| Main | 40 | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP | Beacons |

Audio Configuration
@ Mixed Audio PCM Only
) Mixed Audio PCM / Compressed
) Fixed Audio

Minimum Volume  Maximum Volume

Audio 0 100
HDME 0 100
SPDIF: 0 100
ok || Cancel
Media List

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

These settings pertain to Images List, Audio List, and Video List states:

® Return to start after inactivity: Check the Yes box to have Media List states play from the beginning upon reentry after a designated
period of inactivity. In this case, "inactivity" is defined as any time not spent within the Media List state.

® Inactivity timeout (seconds): Specify the period of inactivity before Media List states restart. If the presentation spends longer than this
amount of time outside the Media List, it will play from the beginning of the list upon reentry.

@ Presentation Properties E‘Elﬂ

| Main | /0 | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

Return to start after inactivity: [ Yes

Inactivity timeout (seconds): | 30

ok || Ccancel

Autorun

w BrightAuthor Version 4.7
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If you would like to specify a different autorun file for the presentation, click Select custom Autorun. Click Browse to locate and select the
autorun file.

Click Add Script Plugin to add a custom script to your BrightAuthor presentation. Script plugins are custom pieces of BrightScript code that
extend the functionality of BrightAuthor. Please see the BrightAuthor Plugins and Parsers tech note for more information.

Note
Because you must edit custom autoruns every time the firmware version changes, we recommend using script plugins (which are

mostly immune to changes in the system software) for advanced presentation development.
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@ Presentation Properties

| Main | /0 | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

@ Standard Autorun

() Selact custom Autorun

Script Plugins
(#) Add Script Plugin
Name Path
X Custom 1 C:\BrightSign Contenticustom.brs
ok | cancel

Image Cache

=~ BrightAuthor Version 4.7

® \/ersion 4.6

® Version 4.4

® Previous Versions
The Image Cache tab displays a list of all image files in your presentation. Selecting an image will preload it into player memory-it will then load
and display much faster during playback. Note that the Available cache space is displayed below—you cannot exceed the allowed space with
cached images.

Important
Cached images are always displayed at their full resolution—-they cannot be scaled up or down. Make sure the size of the image

matches the size of the zone.

You can preload up to 16MB of images. If an image is compressed (e.g. .jpeg, .png), then it will use more memory than its reported file size in
Windows/Mac, and BrightAuthor will show this larger file size when you add it to the Image Cache list. Since Bitmaps (.bmp) are not compressed,

the reported file size of a Bitmap image accurately represents how much memory it will use.
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@ Presentation Properties = | B |

| Main | /0 | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

Specify images to store in cache

Jupiter and Ganymede.jpg 9500 KB »
[T] Jupiter{large).jpg 8100 KB
] Neptune,jpg 5120 KB
[T] whirlpool galaxy.jpg 2525 KB

Used cache: 9600 KB
Available cache: 6784 KB

ok || Cancel

Variables

w BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

ON THIS PAGE

® Device Web Page Display

® User Variables

® Adding User Variables

® Integrating User Variables with Commands

Use this tab to configure the device web page, enable Media Counters, and create User Variables.

Device Web Page Display

The device web page allows you to view and edit User Variables over your local network. In order to display a standard or custom device web
page, you must first enable the Local Web Server during player setup.

* No device web page: Choose this option if you would like to enable the Local Web Server but do not want the User Variables webpage
to be accessible.

® Standard device web page: Choose this option to enable the default device web page, which lists all User Variables and their
default/current values on a sparsely formatted page.

® Custom device web page: Choose this option to use a device web page with custom appearance, formatting, and functionality. See the
Creating a Custom Device Web Page tech note for more information.

® Alphabetize variable names: Check this box to list variables on the Device Web Page alphabetically, rather than by order of creation.

Important
If you plan to use the device webpage, ensure that your User Variables do not have nhames containing an ampersand ("&") character. If
any User Variable name uses an ampersand character, the User Variables Webpage will fail to display any variables.

User Variables

User Variables are customizable values that can be used in commands, Live Text states, and Conditional Targets. When used in Live Text, User
Variables display the current value of the variable. The value can also be changed during a presentation using the Set Variable or Reset Variable
commands.

® Automatically create media counter variables: Check this box to create Media Counters for all media files in the presentation. Media
Counters record how many times a file has played in a presentation. They can be displayed in Live Text or extracted from the BrightSign
player via USB. For details on retrieving Media Counters via USB, see the Using Advanced Tools page.

® Reset variables to their default value on presentation start: Check this box to reset all User Variables to their default values
whenever the presentation begins. If this box is unchecked, User Variable values will be preserved on the SD card after the device
reboots, the presentation is switched, etc.

® Update frequency for networked variables: Use the dropdown list to determine how often networked User Variables should be
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refreshed by Data Feeds that are assigned to the presentation.

Adding User Variables

Click Add Variable to add a new User Variable to your presentation. Then, specify the following:

® Name: Enter a unique name for the User Variable.

® Default Value: Specify an initial value for the User Variable. Whenever a User Variable is reset (via the Reset Variable command), it will
return to this default value.

Note

Setting a new Default Value and republishing the presentation will not set the value of that variable to the new default value.
Instead, the variable will retain whatever value it had before the publish operation. To set variables to their new default values,
you will need to check the Reset variables to their default value on presentation start box before publishing the
presentation. To set a single variable to its new default value, use the Reset Variable command.

® Access: Select Shared to make the User Variable accessible to other presentations scheduled on the player. If two presentations use a
variable with the same name, the value of the variable with the Shared attribute will be used for the variable with the Private attribute.
®* Type: Select a User Variable type:
® Local: Local variables can be changed with the Set Variable/Reset Variable commands or via the Local Web Server. They can
also be set with properly formatted serial, UDP, and Plugin Message commands.

®* Networked: Networked variables are set and modified using Data Feeds (RSS, Live Data, or Dynamic Playlists). To create a
networked User Variable, you must first specify the Data Feed it will be linked to. Select the desired Data Feed from the
dropdown list and click Validate to ensure the link is operational and has correct RSS formatting.

Note
Every RSS entry has a <title> value and a <description> value: use the <title> value to designate the name of the User
Variable being modified; use the <description> value to change the value of the User Variable.

® SystemVariable: System variables are not determined by the user, but by independent system parameters, such as
firmware/autorun version number, IP address, RF channel count, and various types of EDID (extended display identification
data) information received from the display over HDMI.

Note
Displays will often lack a complete set of EDID parameters. Make sure to test the EDID values of a certain display
model before using them in a presentation.

To delete a User Variable, click the X beside the appropriate variable. You can also use the Delete Unused User Variables button to delete all
user variables that are not currently in use by Live Text states, commands, events, conditional targets, etc.


http://docs.brightsign.biz/pages/createpage.action?spaceKey=DOC&fromPageId=983582#Commands_ResetVariables

ﬂn Presentation Properties = | B S

| Main | /0 | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

Device Web Page Display

~) Mo device web page

@ Standard device web page
) Custom device web page

HTML site name

Location

Alphabetize variable names

] Automatically create media counter vaniables

[C] Reset variables to their default value on presentation start

Update frequency for networked variables:

(4 ) Add Variable
Name Default Value Access Type
x & Variable 1 5 [private ~| [Local -
x &4 Variable2 String [Shared = | [Networked  +| Data Feed: |TestFeed ~| [ validate |
X 4 Variable3 Number$20 [hared +| [SystemVariable +| (1P address (wired) +|

Delete Unused User Variables

-~

Integrating User Variables with Commands

User Variables can be used to dynamically set the parameters of many commands: Set Volume, Increment Volume, Decrement Volume, Send
UDP, Serial-send string (EOL), Serial-send string (no EOL), Serial-send byte, Serial-send bytes (comma separated), Synchronize, Send Zone
Message, Link Zones, GPIO On, GPIO Off, GPIO Set State, BrightControl — Send Ascii String, BrightControl — Philips Set Volume, and Pause.

For example, if you add a Set Volume command to your presentation and use a static value like 50, the volume will always be set to 50 when the
command occurs. If you use a User Variable instead, the volume will be set to the current value of the variable, which could be any value based
on Set Variable commands and any number of other factors.

To utilize a User Variable in a command, first add the command (see the Commands page for details). Then, in the Parameters field, enter the
name of the variable between two sets of dollar signs (e.g. “$$variable1$3$"). BrightAuthor will not recognize the variable without these dollar
signs.

Data Feeds

~ BrightAuthor Version 4.7

® Version 4.6
® \ersion 4.4
® Previous Versions

Use this tab to create and edit data feeds, which you can use to populate Live Text, RSS, and Media RSS / Dynamic Playlist states. Data feeds
can also be used to generate Networked User Variables.

Adding Data Feeds

To add a new data feed, click Add Live Data Feed and specify the following:

® Feed Name: Specify a name for the data feed. You will be able
to locate the data feed by this name when you are creating a
Live Text element, specifying an RSS, MRSS, or Dynamic
Playlist feed state, or creating a Networked User Variable.
® Feed Specification: Select a source for the data feed:
® Url: If you have an RSS or MRSS feed hosted on a
third-party server, enter the web address of the feed
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into this field. If you want the presentation to retrieve a | @ Data Feed ==z |
feed from an RSS .xml file on the SD card, use the “fil
e:/llpath” URL format (e.g. “file:///[filename.xml”).

X . . Feed name My New Feed
® Live Data Feed: If you have a BrightSign Network o
subscription, you can host RSS feeds on the BSN Feed specification
servers using the Live Data Feed feature. See the Live Ur
Text FAQ for more information. @ Live Data Feed New Feed -

® Live Media Feed: If you have a BrightSign Network

L Live Media Feed |New Feed 1
subscription, you can host MRSS feeds on the BSN e are s

servers using the Live Media Feed feature. Dynamic Playlist | Daily Playlist
* Dynamic Playlist: If you have a BrightSign Network Tagged Playlist | BATaggedPlaylistl
subscription, you can use Dynamic Playlists as media ; = e
feeds. Match Player Tags Disabled
* Tagged Playlist: If you have a BrightSign Network Validate| |Refresh|
subscription, you can use Tagged Playlists as media
feeds. Use the first dropdown list to select a Tagged E.ata feedicontentlizage
Playlist. If you plan to use player tags, use the second Text
MRSS Feed

dropdown list to specify the player-tag matching . . . ]
behavior for the Tagged Playlist: Support 4K images (use video plane to display images)
e Match Player Tags Disabled: All media in ! Content for Image List, Video List, Audio List, or PlayFile (see documentation)

the Tagged Playlist will be played, regardless

of player tags assigned to a player. Upeiate Intenval [Emy S = |
® Match ALL Player Tags to Media Tags: Plugin Seript = None — v

Media tags in the Tagged Playlist will be

matched against all player tags assigned to a Optimize Feed Updates (use HEAD calls)

player: A media file must have all tag names
and values that a player has; otherwise, that
media file will not be played. oK || cancel

® Match ALL Media Tags to Player Tags:
Player tags assigned to a player will be \
matched against all media tags assigned to a
media file. A player must have all tag names
and values that a media file has; otherwise, that media file will not be played.

[C] Automatically generate User Variables from Data Feed

Important
The Match ALL Media Tags to Player Tags option is not supported by BSNEE 4.4. This option will be
supported in the next version of BSNEE.

* Match ANY Player Tags: Media tags in the Tagged Playlist will be matched against any player tag: As long as a media
file has one tag name and value in common with the player, it will be played.

Refresh: Click this button to update the content of the Live Data Feed, Live Media Feed, and Dynamic Playlist dropdown lists.
Data feed content usage: Determine how you wish to utilize the data downloaded from the feed:
® Text: The feed will be displayed as text in a Ticker zone or Live Text feed.
® MRSS Feed: The feed will be used to download and play media in a Media RSS or Live Text state.
® Support 4K images: Check this box if you wish to use the MRSS feed to download and display 4K images. This feature
is only supported on 4Kx42 players. Displaying 4K images will use the 4K video decoder on the device (i.e. you cannot
display a 4K image and a 4K video at the same time).
® Content for Image List, Video List, Audio List, or Play File: The player will download and store media files specified in the
Data Feed. You can then play back the media files using a Media List or Play File state. Each media file must be specified as a
download URL in a <description> field of the RSS feed. Note that this mechanism is not compatible with the download and
playback features of MRSS feeds and Dynamic Playlists.
Validate: Click this button to ping the feed you specified in the Url, Live Data Feed, Live Media Feed, or Dynamic Playlist field. Use
this feature to check whether you entered the URL correctly, or whether the selected BSN feed still exists.
Update Interval: Specify how often you want the player to check the feed URL to determine if there are any updates.

Important
If the amount of time it takes to cycle through all the entries in the Data Feed is longer than the Update Interval, the presentation will
never display all items in the feed. Make sure to specify an Update Interval that is long enough to display the entire feed.

Plugin Script: Use the dropdown list to select a plugin script—you can add plugin scripts to your presentation using the Add Parser
Plugin button (see below).

Optimize Feed Updates: Check this box to have the player make an HTTP HEAD request before retrieving the contents of a feed
(unless it's the first time a feed is downloaded). This option will reduce network traffic related to feed downloads as long as the feed host
has implemented the HTTP header functionality.
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® Ifthe Last - Modi fi ed value has changed, or the server does not respond to the HTTP HEAD request, the player will make an
HTTP GET request to download the feed.

® |fthe Last - Modi fi ed value in the HTTP header has not changed since the last time the player checked in, the player will not
attempt to download the feed.

Note
The player ignores milliseconds when comparing the Last - Modi fi ed values.

® Automatically generate User Variables from Data Feed: You can use Data Feeds to populate a set of User Variables for HTML5
pages. The User Variables can then be retrieved using JavaScript. Use the <t i t | e> tag of the Data Feed to specify the Name of a
variable and the <descri pt i on> tag to specify its default value.

® Access: Select Shared to make the User Variable accessible to other presentations scheduled on the player. If two
presentations use a variable with the same name, the value of the variable with the Shared attribute will be used for the variable
with the Private attribute.

Adding a Parser Plugin

This is an advanced feature: You may optionally choose to have an RSS or MRSS feed parsed by custom BrightScript code. This occurs after the
feed is retrieved from the network and before it is provided to Live Text states, Media RSS Feed states, and other presentation features.

Click the Add Parser Plugin button to add a parser plugin to your presentation.

® Parser Script: Click Browse to locate and select the BrightScript (.brs) parser file.

® Feed Parser: Enter the name of the feed-parser function in the script.

® User Agent String: Enter the name of the parser function for user-agent strings.

® User Variable Parser: Enter the name of the user-variable parser function in the script.

HTML Sites

=~ BrightAuthor Version 4.7
® Version 4.6
® Version 4.4
® Previous Versions

Important
If you want to use the application cache for HTML5 sites (which allows the player to cache remote HTML content on the local storage),

you will need to enable the Limit storage space by function option in Edit > Preferences > Storage. HTML5 sites must be
configured properly for caching to work.

Use this tab to add HTMLS5 sites to your presentation. You must add sites in this tab before you can include HTML5 states in the playlist.

Adding an HTML Site

To add an HTMLS5 site, click Add HTML Site and specify the following:

® HTML site name: Enter a name for the HTMLS5 site.

® Local Content: Select this option to display HTML5 content using files located on the local storage of your computer. Click the Browse b
utton to locate the .html file that you wish to display.

® URL: Select this option if you wish to play an HTML5 page from a web address.

® Query string (optional): Enter a query string to be appended to the site URL using the following format: "http://www.example.com/over/t
here?my_query_string".

Tip

The URL and Query string fields accept User Variable values. To specify a User Variable, enter the name of the variable between two
sets of dollar signs. The variable value can be either standalone ("$$my_variable$$") or part of a static value
("http:/lwww.brightsign.biz/$$my_variable$$").
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@ Presentation Properties g

| Main | 10 | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

Settings
[C] Enable Javascript console

Site Specification
http://brightsign.biz

MName

¥ Home Page

Automatically generate user variables for the selected data feeds
Plugin Scnipt Parser Function Mame
[T] Content DL Feed 1 Browse
[T] Test Feed Browse
| ok || cancel
Settings

® Enable Javascript console: Check this box to enable the JavaScript console for HTML sites. To access the JavaScript console while
the player is running, open a web browser on a device connected to the same local network as the player. Then, enter the IP address of
the player, followed by port number 2999 (for example, “http://10.1.0.154:2999"). You will be able to inspect any page added to the HTML

Sites tab, not just those currently running.

Note
You must use a WebKit-based browser (e.g. Chrome, Safari) to access the JavaScript console.

Switch Presentations

w BrightAuthor Version 4.7
® \/ersion 4.6
® \ersion 4.4
® Previous Versions
Use this tab to publish additional presentations to the SD card along with the primary presentation. You can use the Switch to Presentation comm

and to switch to another presentation while a presentation is running.
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BB Presentation Properties lilﬂlg

| Main | /O | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

(4) Add Presenearion
MName Presentation Path
X Second Presentation CA\BrightSign Content\WebSignage.bpf
X Third Presentation CA\BrightSign Content\D LargeLoop.bpf

Lok || cancel

Files

~ BrightAuthor Version 4.7

® Version 4.6
® \ersion 4.4
® Previous Versions

Use this tab to publish additional files to the SD card along with the presentation. This feature is useful if you frequently publish files that are not
used in the presentation itself (for example, a media file being played by a custom script) and you want to automate the process of publishing both

presentation files and custom files.

Presentation Properties = | B g

| Main | /O | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP |

Specify additional files to publish

(+) AddFile

File Path
X CABrightSign Content\BlueChrema.ts

X CABrightSign Content\dK_Image.png

ok ]| cancel

ubpP

~ BrightAuthor Version 4.7

® \/ersion 4.6

® \/ersion 4.4

® Previous Versions
This tab provides an easy way to keep track of all UDP events within an interactive presentation. You can also edit the Label and change the Sho
w in BrightSign App option within individual UDP Input events.
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ﬂn Presentation Properties I.E‘Elﬂ
| Main | /O | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP

UDP Input Label Show in Bright5ign App

Clipl Clipl

Clip 2 Clip 2

Clip 3 Clip 3 ]

oKk || Cancel
Beacons

Use this tab to add BLE beacons to your presentation.

Tip
To configure persistent beacons (i.e. beacons that are enabled for all presentations), add the beacons during the player setup process.

A maximum of five beacons can be active simultaneously (each beacon broadcasts on an interval of 1 second). Up to two persistent beacons can
be set on a player, so three to five presentation beacons can be active at any one time. If more than this number is active, priority is determined
by descending order.

Presentation beacons can be enabled and disabled using commands.

w Presentation Properties [ilﬂlﬂ
| Main | 1/ | Interactive | Buttons | Audio | Media List | Autorun | Image Cache | Variables | Data Feeds | HTML Sites | Switch Presentations | Files | UDP | Beacons
(+) Add Beacon
Name Type Beacon Data Start
¥ Beaconl iBeacon UUID: 4fae7164-aa23-4e30-8204-1c3831b0a34b, Major: 128, Minor: 8 Yes
X Beacon2 Eddystone URL  URL: hitpy//www.brightsign.biz No
X Beacon3 Eddystone UD  Namespace: 63677a3f3cfbcb190744, Instance: ff No
ok || Cancel

Click the Add Beacon button to add a beacon to the presentation:

* Name: Enter a name for the beacon.
® Type: Use the dropdown list to select the beaconing mode/format:
® iBeacon: A simple beaconing format
* Automatically start with presentation: Check this box to activate the beacon when the presentation begins. You can
use commands to enable or disable beacons while the presentation is running.
® UUID: A string representation of a UUID, which can be in 16-bit, 32-bit, or 128-bit format. A 16-bit UUID must be exactly
four hex digits with no punctuation; a 32-bit UUID must be exactly eight hex digits with no punctuation; and a 128-bit
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UUID must be punctuated exactly as follows: "cd7b6f81-f738-4cad-aebf-d2a2ea36d996".
® Major: An integer specifying the 2-byte Major value (0 to 65535)
® Minor: An integer specifying the 2-byte Minor value (0 to 65535)

®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

® Eddystone URL: The Eddystone-URL format

® Automatically start with presentation: Check this box to activate the beacon when the presentation begins. You can
use commands to enable or disable beacons while the presentation is running.

® URL: The URL to encapsulate in the advertisement packet.

®* TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

® Eddystone UID: The Eddystone-UID format

® Automatically start with presentation: Check this box to activate the beacon when the presentation begins. You can
use commands to enable or disable beacons while the presentation is running.

® Namespace: A 6-byte value expressed as 12 hexadecimal digits
® |nstance: A 10-byte value expressed as 20 hexadecimal digits

® TxPower: An integer value that corresponds to the measurement of the Tx power level (in dBm) at 0 meters. The default
value is -19, which corresponds to a level of -60dBm at 1 meter. The recommended calibration practice is to measure
the RSSI in a circle at 1 meter from the beacon, then add 41 to the average measured signal strength to get the TxPow
er value: For example, measuring a -65dBm RSSI at 1 meter yields a TxPower value of -24.

Note

The TxPower value does not modify the power level of the Bluetooth transmitter (this requires physical attenuation). Rather, the TxPow
er value is transmitted to Bluetooth clients in the BLE advertisement. Clients can then compare this value to the current RSSI of the
signal to determine their approximate distance from the beacon.

Editing Preferences

~ BrightAuthor Version 4.7

® Version 4.6
® Version 4.4
® Previous Versions

ON THIS PAGE

® \/ideo
® |Images
® |nteractive
® Clock
® Live Text
® Networking
* Ul
® Content
® Publishing
® Save Properties
® Content Update Password Cleared Warning
® Transitions
® New BrightSign Presentation Initial Folder
® Backups
® Storage

Whenever you create a new project, various presentation properties will be set using the default settings. If you often use the same set of
properties, you can save time by changing the default settings to what you use most often. To edit default settings, navigate to Edit >
Preferences on the menu bar.

Changing default settings in the Video, Images, Interactive, Clock, and Live Text tabs does not adjust values in the current project. The
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Networking, Ul, Backups, and Storage tabs are related to other aspects of the publishing process, and will therefore apply to the current
presentation as well.

Video

The Video tab allows you to specify default settings for video states.
® Volume: Specify a default value between 0 and 100.
® Live video —time on screen: Set a default period for live videos to remain on screen (in seconds).

Images

The Images tab allows you to specify default settings for image states.

® Slide transition: Use the dropdown list to set an effect for image transitions.
® Slide delay interval: Set how long each image displays (in seconds).

Interactive

Use the Interactive tab to set a default timeout period for media files (in seconds).

Clock

Use the dropdown list to link the date and time format to a language. This option affects the date/time display in Clock zones. To customize the
format, click Customize to open the Clock Localization window.

® Date: Use the Edit field to customize the date format on the player (refer to the chart of terms for different abbreviation styles). Use the P
review date button to see an example of how the date format will look. You can also customize how months and days are displayed in
both Short and Long form.

® Time: Use the Edit field to customize how time is displayed on the player (refer to the chart of terms for different measurements). Use the
Preview time button to see an example of how the time format will look. You can also customize how the AM and PM abbreviations are
formatted.

Note

A BrightSign Network account can only have one date/time format setting: Changing the date/time format for one presentation, and then
uploading it to the BrightSign Network, will change the date/time format for all presentations on your account. Similarly, a standalone
player can only have one date/time format, even if there are multiple presentations scheduled on the player.

Live Text

Use the Live Text tab to edit default preferences for text fields in Live Text states:

® Alignment: Use the dropdown list to set whether the text is left aligned, right aligned, or centered.

® Foreground text color: Click Choose to select a color for the text.

® Background text color: Check this box to include a background color for text fields. Click Choose and set a default color for the
backgrounds.

® Transparency: Drag the bar to set the transparency for the background text color.

Note
Transparency does not appear in the Live Text image preview or in Presentation Preview. You will need to publish the presentation to a

BrightSign player to view the level of transparency.

Font: Click Browse to locate and select a font for the text. You can use any TrueType font. Click Reset to System Font to reset the font
to the default.

Font size: Select Automatic to fit the text to the height of the text field, or select Fixed point size to enter a value for the font size (1 -
500).



( BB Edit Preferences l._ghj\

| Video I Images | Interactive I Clock | Live Text | Networking | Ul |

Alignment: |Left aligned = |

Foreground Text Color:

Choose |
Example RSS Text

Shows Colors
Background Text Color: Choose |

Transparency: 0% (100% is fully transparent)
Font: System [ Browse | [ Reset to System Font |
Font Size: @ Automatic Fixed point size (1 - 500)
QK ] [ Cancel |

Networking

The Networking tab allows you to enable and disable networking options in BrightAuthor.

* Enable BrightSign Network: Check this box to enable BSN features in the Create, Publish and Manage tabs, as well as the BrightSig
n Unit Setup window.
® Enable BrightSign Local Networking: Check this box to enable Local File Networking (LFN) options in the Publish and Manage tabs,
well as the BrightSign Unit Setup window..
® Enable Bonjour: Check this box to enable Bonjour. BrightAuthor uses Bonjour to detect LFN players on the local network; if
Bonjour is disabled, you will need to enter the IP address of each LFN player manually to publish to it and manage it. See this
FAQ to learn more about installing Bonjour for Windows.
® Enable Simple File Networking: Check this box to enable Simple File Networking (SFN) options in the Publish tab and BrightSign
Unit Setup window.
® Use Proxy Server: Check this box if BrightAuthor needs to communicate through a proxy server to reach the Internet. Enter the Address
and Port of the proxy server. If the proxy server requires authentication, you will be prompted to enter login credentials. If the proxy uses
a Windows domain for authentication, you will also need to specify a domain name.

ul

The Ul tab allows you to edit various options related to the BrightAuthor playlist UI.

Content

® Show Image File Resize dialog?: Displays a dialog box whenever you add an image that is larger than the maximum image size
allowed by the player model. It will give you the option to either cancel the action or create a downscaled copy of the image to use in the
playlist.

® Resize image files for BrightSign: Automatically creates a downscaled copy whenever the original size of the added image is too large.

Publishing

® Show file overwrite dialog?: Displays a dialog box asking whether you want to overwrite preexisting files when publishing a
presentation.

® Copy and replace duplicate files when publishing locally?: Overwrites media files with the same name when publishing locally.

® Show Save Schedule dialog?: Displays a dialog box when you exit the Publish tab, asking if you would like to save the schedule as a
separate file. You can then use this schedule file with any presentation by navigating to Schedule > Open while in the Publish tab.

® Show read/write file system warnings dialog?: Displays a warning whenever you attempt to publish to a file system that is not fully
supported.

® Show read only file system warnings dialog?: Displays a warning whenever you attempt to publish to a file system that does not allow
file writes on the BrightSign player. Player logs and network updates are not supported on read-only file systems.

Save Properties

® Show Save Properties dialog: Displays a dialog box whenever you exit the Presentation Properties window having made changes to
the settings. The dialog box will ask you whether you want to apply the new settings to the current presentation or to all future
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presentations in addition to current presentation.

Content Update Password Cleared Warning

® Show Content Update Password Cleared Warning dialog: Displays a dialog box whenever you publish a content update that will clear
the Content Update Password.

Transitions

® Display Mode: Determine how BrightAuthor draws event connections between states in the interactive playlist area:
® Automatic: Displays either a line or a label, depending on the current playlist layout.
® Always display line: Displays event lines between states.
® Always display label: Displays numbered event labels that show connections between states.
® Label Location: Determine where numbered event labels are located:
® Bottom: Numbered event labels are located below states.
® Right: Numbered event labels are located to the right of states.

New BrightSign Presentation Initial Folder

This option refers to the Where save destination folder in the New Project window. Select one of the following:

® Last Folder Used: The destination defaults to the last folder used to save a presentation project.
®* My Documents: The destination defaults to the My Documents folder.

Backups

The Backups tab allows you to configure automated backup saves for projects (in case BrightAuthor closes without saving the presentation
project).

® Automatically backup BrightAuthor presentation files: Check this box to enable automated saving of BrightAuthor presentation files.
Specify how often you want backup saves to occur.

® Backup a maximum of this number of backups: Specify how many backup copies of a single presentation can exist. Once this limit is
reached, BrightAuthor will begin overwriting backup copies, beginning with the oldest file.

Storage

Checking the Limit storage space by function box allows you to divide the presentation storage device (SD card, USB drive, etc.) into different
segments. You can then allot maximum sizes to those segments to ensure that a certain type of data does not take up too much space on the
storage device.

Note that, if you select Specify absolute size, it is possible to specify a combined set of segments that is larger or smaller than the absolute size
of your storage device. If you select Specify percentages, you will need to ensure that the percentages add up to 100% (which is equivalent to
the absolute size of the storage device).

The segment types are specified as follows:

® Published data: The maximum size allotted to all presentation and content files that are written to the storage device during the publish
process. This includes audio, video, images, text, and HTML content files.

® Dynamic data: The maximum size of all dynamic content, including Dynamic Playlists and MRSS feeds. When this segment runs out of
space, dynamic content files will be deleted to create space, starting with the oldest files first.

® HTML data: The maximum size of the HTML application cache.
® HTML local storage: The maximum size of all JavaScript variables and data.
® HTML IndexedDB: The maximum amount of storage allocated to the IndexedDB web database application.
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ﬂn Edit Preferences ﬁ

| Video | Images | Interactive | Clock | Live Text | Networking | UI | Backups | Storage

Limit storage space by function?

| Specify absolute size

Published data (ME) 0
Dynamic data (ME) 0
HTML data (MB) 0

HTML local storage (MB) | O
HTML IndexedDB (ME) 0

@ Specify percentages
Published data (%) 40% -

Dynamic data (%)
HTML data (%)

HTML local storage (%)

HTML IndexedDE (%)

Total (%) 100%

OK I [ Cancel
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This section outlines advanced features offered by BrightAuthor.

Importing and Exporting

There are three types of import/export actions available from the File menu: Export Presentation, Import/Export User Variables, and Import/Export
User Events.

Export Presentation

Exporting a BrightAuthor presentation makes it easier to transfer that project between different PCs and versions of BrightAuthor. Navigate to File
> Export... and select a folder for export. All relevant presentation files, including media files and user defined events, will be placed in the target
folder. You can open the project by double-clicking the .bpf file that was exported.

Import/Export User Variables

You can transfer the User Variable set of one presentation to another. This saves time when you are creating multiple presentations that use the
same set of User Variables. The User Variable set is exported as a .buv file, which is also an editable XML document.

Note that importing networked User Variables to a new presentation does not import the Data Feeds to which those variables are linked. If you
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import networked User Variables, you will need to recreate the associated feeds in the Presentation Properties > Data Feeds tab and reassign
them to the variables.

Import/Export User Events

These actions allow you to transfer User Defined Events between presentations. This is useful when creating multiple presentations that use
many of the same or similar events.

Presentation Tree View

The Presentation Tree View feature allows you to view a presentation as a set of expandable/collapsible zones, states, events, and commands.
You can use this feature to easily navigate all state information in a presentation without double-clicking numerous icons and navigating through
tabs. You can access this feature by navigating to File > View Presentation Tree.

RF Channel Scanning

Before you can use the RF In state to display live video, you will first need to perform a channel scan. You can perform a channel scan either as
an independent action (similar to setting up a player) or as a state in an interactive presentation. The user interface for the Scan Setup window is
the same for both methods. See the Tuner Scan page for more information about using channel scanning in an interactive presentation.

Follow these steps to perform a channel scan as an independent action:

1. Navigate to Tools > Setup RF Channel Scan.
a. Channel Map: Select QAM, ATSC, or ATSC and QAM (consult your service provider for details).
b. Modulation Type: Select QAM 64, QAM 256, or QAM 64 and QAM 256 (consult your service provider for details).
c. First RF Channel (optional): You can choose to limit the range of the channel scan by selecting the first channel to scan.
d. Last RF Channel (optional): You can choose to limit the range of the channel scan by selecting the last channel to scan.
. Click OK and write the channel scan settings to an SD card or USB drive.
. Power off your BrightSign XD1230.
. Insert the SD card or USB drive into the player and power it back on. The progress of the channel scan will be displayed on screen.

. Once the scan is complete, the channel settings will be written to the internal registry of the player (i.e. the non-removable storage). You
can now use the RF In state to tune to any virtual channels that were detected in the channel scan.

a b~ wnN

Each channel takes approximately one second to scan. Specifying First RF Channel and Last RF Channel will reduce the amount of
time it takes to perform the scan. You should only use these two options if you are familiar with the channel map of the cable source.

z EB Scan Setup I&\

Channel Map | ATSC and QAM - |

Modulation Type [QAM 64 and QAM 256 - |

First RF Channel (optional)

Last RF Channel (ocptional)

OK ] [ Cancel

Publishing Channel Scan Results

If you are connecting multiple XD1230 players to the same cable source, you can transfer the results of a channel scan from one player to
another during the setup process.

. After performing a channel scan, reinsert the SD card or USB drive into your PC.

. In BrightAuthor, navigate to Tools > Setup BrightSign Unit.

. Specify device settings as desired (see the Setting up BrightSign Players for more details).

. Under RF Channel Scan Data (optional), click browse and locate the “ScannedChannels.xml” file in the SD card or USB drive directory.
Click Open.

A W DN PR



5. Publish the setup files to the player. The player will now have the same channel configuration as the original XD1230.

Managing Your Network
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You can use the BrightAuthor Manage tab to manage players on your BrightSign Network account, as well as the players on your local network.
The Advanced Tools window (accessible by navigating to Tools > Advanced) offers additional player management options.

If you don't see BrightSign Network features in the Manage tab or Advanced Tools window, ensure that the BrightSign Network is enabled in Edi
t > Preferences > Networking and sign in by navigating to Tools > Sign in to BrightSign Network.
Status
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The Status section allows you to view the statuses of players and groups on your BrightSign Network account.

Groups

You can use groups to distribute presentations to a set of BrightSign players. Publishing a presentation to a group delivers it to all BrightSign
players within that group. BrightAuthor includes two default groups: Default and LocalTest. However, you can create additional groups as needed:

® To create a group: Click Add Groups (beneath the Groups window). Type a name for the group and click OK.
® To delete a group: Right-click a group and click Delete.

® To move a player to a different group: Click the arrow next to the group that contains the player. Then click and drag the player to the
new group.

Click the arrow beside a group to view details about players within that group:

® Status: A range of colors (green, yellow, red) used to indicate the status of a BrightSign player. Please see this FAQ for more information
on what each color means.

® Name: The name of the player

® Description: The description given to the player

Active Presentation: The name of the current presentation being run on the player

Last connection: The last time the player checked in with the BrightSign Network servers

Checks for content every: The interval for synchronizing with the BrightSign Network servers to determine if there is new content to
download. This interval can be modified by right-clicking the player and selecting Edit.

Right-click a player to access options associated with it:
®* View Remote Snapshots: Opens a window that allows you to view Remote Snapshot images taken by the player. When the window

opens, the latest snapshot will be displayed. Past snapshots are displayed as thumbnails below. Double click a snapshot thumbnail to
view it as a full size image. The number, quality, and frequency of snapshots is determined during the Unit Setup process.

Note
The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

® Refresh: Click this button to get the most up-to-date snapshot(s) from the player.
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® Date/Time: The timestamp indicating when the snapshot was taken. The timestamp is formatted as follows: yyyy:mm:dd
hh:mm:ss

® Serial Number: The serial number of the player taking the snapshot
® Model: The model number of the player taking the snapshot
® Firmware: The firmware version of the player taking the snapshot

® Edit: Opens the Edit Unit window, which allows you to edit many of the parameters set during the Unit Setup process, including the
name/description, group, and Remote Snapshot settings.

® Tags: Opens the Device Tags window, which allows you to add tags to the player. You can use player tags to conditionally filter media
in Tagged Playlists on a player-by-player basis. See this section in the BSN WebUI documentation for more information about player
tags.

® Delete: Removes the player from the BrightSign Network. The player will continue playing content, but it can no longer be updated or
monitored.

® Info: Provides details about the player hardware, software, networking, and subscription status.

®* Download Progress: Displays the progress of the most recent content synchronization action.

D Regular BW 1 - XD1230 - BrightAuthor = | B i)
File Edit Tools Help
Create Edit Publish Manage Bri g htAuthor Signed in to account: peterdemo
» Status Presentations Library Dynamic Playlist Live Data Feed HTML Site Local Network Reiresh |
Status
*~ Groups
Status Group ¥ Device Count  Scheduled Presentations
~ ) WA Tacoma o
+ Unassigned 4] Looping Presentation 1
~) OH Akron 0
~ ) NC Raleigh 0 Advanced Audio Playlist 1
~ ) MD Baltimore o
~ MA Boston o
) LocalTest 0 B
v Default o
. - - n i
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[+ Add Group
# BrightWall Groups
Status BrightWall™ Group (BrightWall™ Configuration) v BrightWal™ Count  Scheduled BrightWall™ Presentations
L ] ~) Cube Wall (brightWallConfig_Ultimate) 1 Regular BW 1
Status  BrightWall -
~) Left Cube
Status  Number Name v Description Active Presentation  Last connection Checks for content every
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(4] Add BrightWall Group

BrightWall Groups

Use the BrightWall Groups section to manage players that are assigned to BrightWall video walls.
Note some important differences between BSN BrightWall groups and standard BSN groups:

® Each player is part of a BrightWall: It has a Number indicating the section of the BrightWall to which it belongs. Screens are numbered by
row, starting from the top-left section of the BrightWall (the example diagram to the right shows the numbering of a 4x3 BrightWall).

® Each BrightWall consists of a number of players: The Status will only display green if all players in the BrightWall are green, or red if all
players in the BrightWall are red. If the players are a mix of red, green, or yellow, the Status will display yellow.

® Each BrightWall group consists of one or more BrightWall(s): BrightWall(s) within the same BrightWall group use the same Configuration
File. This means that each BrightWall group represents a certain BrightWall configuration (for example, a 3x2 video wall using HDMI, with
a 3% bezel ratio). Like standard BSN groups, BrightWall(s) within the same BrightWall group are assigned the same schedule.

Note in the diagram below how each BrightWall within a BrightWall group has the same configuration, and how each player can only be assigned
to one BrightWall at a time.
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Creating a BrightVWall G oup
To create a BrightWall group, click Add BrightWall Group (located below the BrightWall Groups window) and enter the following:

® BrightWall group name: The name of the BrightWall group

® BrightWall configuration. The BrightWall Configuration file that will be associated with the BrightWall group. To add a BrightWall

Configuration file to the list, upload a BrightWall presentation that uses the configuration file to the BrightSign Network in the Create >
BrightWall tab.

Players and BrightWall(s) are added to a BrightWall group during the Unit Setup process.

Presentations

~ BrightAuthor Version 4.7
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The Presentations section allows you to view all presentations, BrightWall presentations, and BrightWall configuration files uploaded to the
BrightSign Network.

Presentations

Click the down arrow next to Presentations to view a list of all presentations uploaded to the BrightSign Network:

® Active: A checkmark will be displayed in this field if the presentation is currently assigned to one or more groups. Use the button to view
the Current Active Groups list.

® Name: The name of the presentation
® Date modified: The last time the presentation was modified in BrightAuthor or uploaded via the BrightSign Network WebUI
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Right-click a presentation to perform an action:

® Delete: Removes the presentation from your BrightSign Network account. This action cannot be performed if the presentation is currently
assigned to a group.

® Download: Downloads the presentation file and assets to the specified folder. You cannot download presentations that were created with
the WebUI.

BrightWall Presentations

Click the down arrow next to BrightWall Presentations to view a list of all BrightWall presentations uploaded to the BrightSign Network:

® Active: A checkmark will be displayed in this field if the BrightWall presentation is currently assigned to one or more BrightWall groups.
Use the button to view the Current Active BrightWall™ Groups list.

®* Name (BrightWall Configuration): The name of the BrightWall presentation, as well as the configuration file used for that presentation
® Date modified: The last time the BrightWall presentation was modified in BrightAuthor

Right-click a BrightWall presentation to perform an action:

® Delete: Removes the BrightWall presentation from your BrightSign Network account. This action cannot be performed if the BrightWall
presentation is currently assigned to a BrightWall group.

* Download: Downloads the BrightWall presentation file, configuration file, and assets to the specified folder.

BrightWall Configurations

Click the button next to BrightWall Configurations to view a list of all BrightWall Configuration files uploaded to the BrightSign Network:

Note
Currently, the only way to upload a BrightWall Configuration file to BSN is to upload a BrightWall presentation that uses the
configuration file.

® Active: A checkmark will be displayed in this field if the configuration file is being used for one or more BrightWall presentations. Use the
button to view the Current Active BrightWall™ Groups list.

®* Name: The name of the BrightWall Configuration file
® Creation date: The date that the BrightWall Configuration file was created in BrightAuthor

Right-click a configuration file to perform an action:

® Delete: Removes the BrightWall Configuration file from your BrightSign Network account. This action cannot be performed if a BrightWall
presentation that uses the configuration file is currently assigned to a BrightWall group.

® Download: Downloads the BrightWall Configuration file to the specified folder.

Library
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The Library section allows you to see all content files (images, audio, video) that have been uploaded to your BrightSign Network account. Files
with a green check mark are currently active. You can perform any of the following actions:

® Switch between thumbnail and list views: Click the icons in the upper-right portion of the screen.
® Refresh the library: Click the Refresh button in the upper-right portion of the screen.

® View item info: Right-click a file and click Info. Here you can view the file size, type, date modified, and date uploaded, as well as all
presentations and all Dynamic Playlists using the file.

® Delete an item: Right-click a file and click Delete. Keep in mind that you can only delete files that aren’t currently active.

® Edit Media Tags: Right-click a file and click Edit Tags to add or remove media tags from that media item. You can switch between
editing System and User tags:

® System tags have values that are defined by the BrightSign Network (such as the media file size and upload date); you cannot
edit the title or value of these tags.

® User tags have customizable titles and text values.

® Copy Media Tags: Right-click a file and click Copy Tags. Select one or more target media files for copying and click Save. This will copy
all tags that are associated with the original file; it will also overwrite any tags associated with the target media file(s).
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File Edit Tools Help

Manage BrlghtAUthor Signed in to account: PeterDema_2
Status Presentations | ® Library Dynamic Playlist Live Data Feed HTML Site Local Network
Library B
Used Name ¥ Size Type Date modified
[~ Neptune,jpg 792 KB image 1/9/2013 12:36:21 PM
@ MaleFig_resized jpg 466 KB image 1/27/2014 4:24:38 PM
@ Kittehs fighting.jpg 10KB image 2/15/2012 3:28:34 PM
[~] kitteh,jpg 149 KB image 12/13/2012 4:21:02 PM
[~] Kitteh 2jpg 102 KB image 2/15/2012 3:29:23 PM
@ Jupiter_Rotation.mp4 14,757 KB video 4/18/2013 3:57:31 PM
Q Jupiter{large).jpg 138 KB image 4/7/2014 2:14:53 PM
@ Jupiter and Ganymede,jpg 181 KB image 4/24/2013 11:46:06 AM
6 earth_1280x720.mov 149,824 KB video 4/24/2013 3:36:03 PM
BSAV.png 17KB image 11/21/2012 9:16:13 AM
Q Andromeda(1200by1600).jpg 542 KB image 6/12/2014 2:02:37 PM

Live Data Feed
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The Live Data Feed tab allows you to view all Live Data Feeds on your BrightSign Network account, as well as the presentations that contain
Live Data Feeds and the time/date when they were last modified. Live Data Feeds with a green checkmark are currently part of a presentation.
You can perform any of the following actions:

® Delete a feed: Right-click a Live Data Feed and select Delete.

* Download a feed: Right-click a Live Data Feed and select Download. Choose a save destination for the .xml data-feed file and click Sav
e.

® View info: Right-click a Live Data Feed and select Info. A window will display when the Live Data Feed was last modified, along with a list
of all presentations that contain the Live Data Feed.

® Sort the list: Click the column you want to use as the sort criteria. For example, click the Name column to sort by name, then click it again
to switch between ascending and descending order.

® Refresh the list: Click the Refresh button in the upper-right portion of the screen.
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Local Network -Re‘lresh

Manage

Status Presentations Library Dynamic Playlist » Live Data Feed HTML Site

Live Data Feeds

¥ Date modified

Used Name
Price Feed 2/12/2016 10:25:59 AM
@ Media Spec Feed 1 2/10/2016 3:25:33 PM

Dynamic Playlist
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The Dynamic Playlist tab allows you to view all Dynamic Playlists on your BrightSign Network account, as well as the presentations that contain
Dynamic Playlists and the time/date when they were last modified. Dynamic Playlists with a green checkmark are currently part of a presentation.
You can perform any of the following actions:

® Delete a playlist: Right-click a Dynamic Playlist and then select Delete.

* View info: Right-click a Dynamic Playlist and then click Info. A window will display when the Dynamic Playlist was last modified, along
with a list of all presentations that contain the Dynamic Playlist.

® Sort the list: Click the column you want to use as the sort criteria. For example, click the Name column to sort by name, then click it again
to switch between ascending and descending order.

® Refresh the list: Click the Refresh button in the upper-right portion of the screen.
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Status Presentations Library | » Dynamic Playlist Live Data Feed HTML Site Local Network
Dynamic Playlist
Used Name  Date modified
[~] New Media Playlist 2/12/2016 10:22:43 AM
Kitteh Playlist 2/10/2016 12:55:03 AM
HTML Site
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The HTML Site section allows you to view all HTML sites that have been uploaded to your BrightSign Network account, as well as the
presentations that contain the sites and the time/date when they were last modified. HTML sites with a green checkmark are currently part of a

presentation. You can perform any of the following actions:

® Delete a site: Right-click an HTML site and select Delete.

® View site info: Right-click an HTML site and select Info. A window will display when the site was last modified, as well as a list of all
presentations that contain the site.

® Sort the list: Click the column you want to use as the sort criteria. For example, click the Name column to sort by name, then click it again
to switch between ascending and descending order.

® Refresh the list: Click the Refresh button in the upper-right portion of the screen.
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HTML Sites
Used Name ¥ Date modified
@ Sushimenu 11/8/2013 2:37:47 PM
@ BrightSignHTML20141209223738 12/9/2014 2:40:10 PM
@ BrightSignApplicationServer 4/10/2015 8:14:10 AM

BrightPlatesPage20150715225710 7/15/2015 3:57:40 PM

BrightPlatesPage20150715225611 T/15/2015 3:56:43 PM
@ BrightPlatesPage20150715224834 7/15/2015 3:49:09 PM

Local Network
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The Local Network section allows you to perform a number of remote operations on players located on your local network. If Bonjour has been
installed on your PC and enabled in the Edit > Preferences > Networking tab, then players set up for Local File Networking will be discovered
automatically (see this FAQ for more details). If Bonjour is not enabled, you can populate the list of players by clicking the Add BrightSign button
in the bottom left and entering the IP address of the player.

Note
If you do not know the IP address of your player, you can obtain it by powering up the player without an SD card inserted: The IP
address, along with other information about the unit, will be displayed on screen once the unit boots.

To perform an operation, select a player from the list (or select multiple players by holding down Shift) and right-click the selection:

®* View Remote Snapshots: Opens a window that allows you to view Remote Snapshot images taken by the player. When the window
opens, the latest snapshot will be displayed. Past snapshots are displayed as thumbnails below. Double click a snapshot thumbnail to
view it as a full size image. The number, quality, and frequency of snapshots is determined during the Unit Setup process.

Note
The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

® Refresh: Click this button to get the most up-to-date snapshot(s) from the player.

® Date/Time: The timestamp indicating when the snapshot was taken. The timestamp is formatted as follows: yyyy:mm:dd hh:mm:ss

® Serial Number: The serial number of the player taking the snapshot.

® Model: The model number of the player taking the snapshot.

® Firmware: The firmware version of the player taking the snapshot.

®* Remove Unit(s): Removes one or more players from the Local Network list. This action only affects the BrightAuthor Ul; it does not
change the settings of players in any way.

® Show All Units: Adds back all players that have been removed from the list using the Remove Unit(s) command.
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* Info: Displays information about the selected player, including the Unit ID (i.e. serial number), IP address, Model, Firmware version,
and Autorun version.

® Specify User Name / Password: Attempts to access the player to obtain further information about it. This action should be used when
the player Name is listed as "Access to [player IP address] denied".

® Access Diagnostic Web Server: Opens a web browser window or tab to access the player Diagnostic Web Server.

® Access Device Web Page: Opens a web browser window or tab to access the player Device Web Page (i.e. Local Web Server).

Using Advanced Tools

~ BrightAuthor Version 4.7
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® Version 4.4
® Previous Versions

ON THIS PAGE

® Setup USB Drive
® Update Autorun
® Unit Control

Advanced tools (accessible by navigating to Tools > Advanced) let you remotely control units on your BrightSign Network account or set up a
USB flash drive to retrieve device data and perform device actions. The Advanced Tools window is divided into three tabs: the Setup USB Drive
tab, as well as the Update Autorun and Unit Control tabs, which are only available if you have a BrightSign Network account.

Setup USB Drive

The Setup USB Drive tab allows you to configure a USB flash drive to extract data or perform specified actions (e.g. reboot the player) on a
BrightSign player. The following checkboxes determine what actions will occur when the USB flash drive is inserted into the player:

® Copy variables database: Extracts the data for all User VVariables and Media Counters.

® Copy log files: Extracts all log files.

® Delete log files: Deletes all log files on the BrightSign player.

® Reset Variables: Resets all User Variables to their default values.

®* Reboot: Reboots the BrightSign player.

® Display status on screen during data capture: Displays the status of the above actions on the display while the USB flash drive is
inserted into the BrightSign player.

Once you've selected the desired USB actions, follow these steps to carry them out:

Click Setup drive and navigate to the location of the USB flash drive on your computer. Click OK.

. When the Setup Complete window opens, click OK.

. Remove the USB flash drive from your computer and insert it in the player.

. If you are extracting data from the player, reinsert the USB flash drive into your computer to retrieve the data.

AW NP

Note
You can retrieve data from multiple players using a single USB flash drive. The filename of each variable, media counter, and log
record will include the serial number of the applicable player, so the number of unique player records you can put on a USB flash drive

is limited only by storage space.

Update Autorun

Use the Update Autorun tab to update the Autorun on players linked to your BrightSign Network account. Check the boxes corresponding to the
groups you wish to update. Then click Update now to update the Autorun version for players in the group(s).

See this FAQ to learn how to distribute custom Autorun scripts using the BrightSign Network.
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@D Advanced Tools ﬁ

Setup USE Drive | Update Autorun | Unit Contral |

Select BnghtSign Network groups

[ CA Los Gatos

[] cA San Francisco
[T Disabled Players
[+] ma Boston

[ MD Baltimore

[C] NC Raleigh

[ OH Akron

[] Unassigned

[] WA Tacoma

|U|:|date nc:rw]

Unit Control

Use the Unit Control tab to send commands to players linked to your BrightSign Network account.

1. In the Serial Number field, type the serial number of the player you want to control.
2. Click the Action dropdown list to select the action you want the player to perform.
a. Reboot unit: Restarts the player.
b. Upload logs: Uploads the current log files on the player (based on the Logging settings selected when setting up the unit.). Log
files can then be retrieved in the BrightSign Network WebUI.
c. Recover —reformat: Puts the player into recovery mode and reformats its storage device.
d. Recover —don’t reformat: Puts the player into recovery mode and downloads the latest Autorun script to the storage card
without reformatting it.
3. Click the Add action button to have the player perform the action the next time it checks in with the BSN servers.

You can add multiple actions to a single player. You can also use the Remove action button to cancel an action before the next check-in.

@ Advanced Tools ﬁ

| Setup USB Drive | Update Autorun | Unit Control

Enter the BrightSign serial number
Serial Number: L2D4CH000018

Action [Recmnery - reformat - ]

EAdd actiuni [ Remove action ]

Close

Using the Diagnostic and Local Web Servers
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The Diagnostic Web Server gives you the ability to perform various system functions—such as rebooting the player, changing display settings,
and retrieving log files—from a web browser.

The Local Web Server is necessary for Local File Networking. It also gives you access to the User Variables webpage, which allows you to modify
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User Variables using a web browser or the BrightSign App. Both features are enabled during the player setup process.

Follow these steps to connect to the Diagnostic Web Server and User Variables webpage using a web browser: Note that your PC or mobile
device must be connected to the same local network as the BrightSign player.

1. Power off the BrightSign player.
2. Remove the SD card and USB drive (if applicable).

3. Power on the player and wait several minutes. The IP address of the player, along with the serial number and firmware version, will
appear on the display.

4. To access the Diagnostic Web Server, enter the displayed IP address into the address bar of the browser on your PC or mobile device
(for example, “10.0.1.199"). To access the User Variables web page, enter the displayed IP address plus port 8008 (for example,
“10.0.1.199:8008").

5. Enter your user name and password (if applicable).

Frequently Asked Questions
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For additional Frequently Asked Questions, visit the BrightSign Support website.

Can | use BrightAuthor 4.0 or later with the HD210, HD410, HD810, HD1010, HD1010w, or TD1012?

No, these legacy models are only supported by BrightAuthor versions 3.8 and earlier.

Can | open the autoplay.xm file using BrightAuthor?

No. The autoplay.xml file that is generated when you publish a presentation is a playlist file. This file includes only the information required for
playback on a BrightSign player. It is not the same as a presentation project file.

How do | use a different font?

To use a different font, browse to a folder on your computer that has a true type font (e.g. in a Ticker zone, click Zone Properties, and then click
Browse beside font). This font will be copied to the SD card when you publish the presentation. You can use your own custom fonts or download
free TrueType fonts from the web.

Can | export a tenplate?

Yes. Although there isn’'t a template export option, you can save a presentation project with the desired template layout, and then transfer it to
another computer. You can then open the project in BrightAuthor, and then save the template (Layout > Save Template).

Why does Bright Author take a long tine to process ny fol der?

If the folder you selected has a large number of images and videos, the Media Library may take a few minutes to update. Please be patient.

Way can’t BrightAuthor |locate nmy files when | try to publish ny presentation?

If you copy a presentation project from one computer to another, or move or rename files used in a BrightAuthor project, BrightAuthor cannot
locate the files, and you will receive an error message when you try to publish. To resolve the error, you must remove the files from each zone’s
playlist in the presentation and then add them again.

Wiy are sonme of ny videos missing thunbnails in the Files tab?

The thumbnails are generated by codecs installed on your computer. You can download codecs to resolve the problem. For example, if you're
missing thumbnails for your transport streams, you can try downloading a codec such as K-Lite.

What do | do if BrightAuthor crashes while |'"musing it?

For any errors or crashes you encounter while using BrightAuthor, please post a description of the problem in the forums (http://support.brightsign
.biz/hc/en-us/community/topics) or send us an email at support@brightsign.biz and include the following information:

® Steps to duplicate the problem (or indicate that you can’t duplicate it)
® Any error dialogs you saw, including text in the dialog
® The contents of your event log right after the crash. You can find the log in this folder:
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C:\Users\Owner\AppData\Local\BrightSign\BrightAuthor\
® Look for a subfolder named after the BrightAuthor version number, such as 2.4.0.
® A copy of the presentation project where you experienced the problem
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