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INTRODUCTION 
The BrightSign App for iPad and iPhone allows you to broadcast commands to BrightSign players and 
other compatible network devices over your local network using UDP (User Datagram Protocol) packets. 
The app automatically retrieves UDP events in BrightAuthor presentations that are currently active on 
the network, allowing you to access and activate them using a straightforward UI. You can also use the 
App to modify User Variables and create new UDP Commands on the fly. 
 
The BrightSign App is compatible with all networked BrightSign players, including the XD230, XD1030, 
XD1230, HD220, HD1020, and HD1010. 
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USING THE BRIGHTSIGN APP 
UI Overview 
Once you download the BrightSign App from the Apple 
Store, opening it will take you to the BrightSign App UI. 
The first time you open the app, the main window will be 
blank because you have not added any BrightSign 
players to the app database yet. 
• Back / Forward: Navigates the 

Diagnostic Web Server or Local 
Web Server similar to a web 
browser. 

• Refresh: Reloads the page data 
of the Diagnostic Web Server or 
Local Web Server. 

• Player Name: The name of the 
player that is currently 
connected to the app. The 
player name is designated 
during the player setup process 
in BrightAuthor. 

Note: The BrightSign App can only 
connect to one player at a time.  
• Diagnostic/Local Web Server: 

Switches between the pages of 
the Diagnostic Web Server and 
the Local Web Server. These 

pages will only be available if they are enabled 
during the player setup process in BrightAuthor.  

• Settings: Opens the settings menu, which allows you 
to add players to the app, select players that have 
been added, and add or edit the UDP Commands 
for a player. 

The BrightSign App main page for iPad 
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• Web Server Page: The main area of the App displays 
either the Diagnostic Web Server or the Local Web 
Server of the selected player if they were enabled 
during the player setup process. 

• Command Buttons: Send commands to the 
connected player with the press of a button. In the 
Settings menu, you can designate the title of each 
button, as well as the UDP string that is sent. 

• (iPhone only) Actions Menu: Displays the 
Command Buttons. 

Adding Players to the App 
Once you are connected to a local network, the App will 
automatically detect BrightSign players on the network. 
However, there may be instances when you need to 
manually add a new player to the App database. To do 
so, follow these steps: 

1. Ensure that your iPad or iPhone is connected to the 
same local network as your BrightSign player. 

2. Open the BrightSign App. 
3. Press the Settings button. 
4. Press the button in the BrightSign Unit field. 

Adding a new player in the Select Unit window 

The Command Button display for iPhone 
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This will take you to the Select Unit window, which 
displays all currently active BrightSign players. 

5. Press the button in the Add Unit field. 
6. Enter the IP address of the BrightSign player you 

wish to add to the app database and press Search. 
If you haven’t manually specified the IP address of 
the player during setup, or if you don’t know the IP 
address of the player, you can find it by following 
these steps: 
a. Power off the player by unplugging the power 

supply. 
b. Remove the SD card (as well as  the internal 

µSD card if you are using an XD player). 
c. Power on the BrightSign player by reconnecting 

the power supply. 
d. Wait for the player to boot up: The IP address of 

the player, along with the serial number and 
firmware version, will be displayed on the 
screen. 

7. After searching, the app will return the name and ID 
of any player or other device matching the IP 
address you entered.  

8. Press the Add button to add the player to the app 
database, and then press Done. 

Switching between Players 
You can create a list of locally networked BrightSign 
players by adding units using the method described 

above. To choose a player to send commands and User 
Variable updates to, follow these steps: 

1. Press the Settings button. 
2. Navigate to the Select Unit window by pressing 

the button in the BrightSign Unit field. 
3. Tap the unit you wish to connect to. A checkmark 

will appear next to that unit. 
4. Return to the Settings page using the button in 

the top left. 
5. Save your new selection by pressing the Save 

button in the top right. 

Deleting a player in the Select Unit window 
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The BrightSign App will not automatically detect changes 
made to your networked BrightSign players. For 
example, if you modify the IP address of a player or 
remove it from the local network, that player will remain 
as a selectable item in the Active BrightSign Units list. 
You will need to manually remove players from the 
Active BrightSign Units list: 

1. In the Select Unit window, press the Edit button 
in the top right. Each player should now have a 

button next to its name. 
2. Press a button to turn it. You will now be able to 

delete a player from the list by pressing the Delete 
button to the right of the player name. 

3. Press the Done button in the top right to save the 
changes you’ve made. 

Note: Deleting players only removes them from the 
app database. The configuration settings of the 
players themselves are not changed in any way. 

Sending Commands 
You can send UDP Commands using the Commands 
field in the UI. Simply touch one of the command buttons 
to send the UDP Command string to the currently 
connected player.  
 

Adding a new Command button in the Settings window 

Editing the Action Name and Action Data of a Command 
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If you would like to affect multiple players with a single 
command, please see the UDP Commands with Multiple 
Players section. 

Creating and Editing Commands 
After adding a player to the app database, the BrightSign 
App will automatically populate a list of UDP Commands 
that are being used in the current BrightAuthor 
presentation. However, in some cases you may need to 
manually add command buttons (for example, when 
using the BrightSign App to send UDP commands to 
other types of networked devices). 

1. Press the Settings button. 
2. Use the Small, Medium, and Large Size buttons 

to edit the size of the action buttons in the 
Commands field. Making the Command buttons 
small allows you to fit more buttons on the screen.  

3. Add a new UDP Command button to the UI by 
pressing Add Button…. This will bring up a 
window that allows you to enter an Action Name, 
as well as Action Data. 

a. Action Name: The name of the button as it 
is displayed in the Commands field and the 
Settings menu. 

b. Action Data: The command parameter that 
is sent to the player in the form of a UDP 
packet. For the BrightSign App to activate 
the BrightAuthor UDP event, this text must 

match exactly the text in the Specify UDP 
input field of the UDP Input Event in 
BrightAuthor.  

4. Press the Save button once you are finished 
inputting the Action Name and Action Data. 

 
When the App connects to a player, it assigns a name to 
each command based on the data of that command. If 
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you would like to edit these default names, click the 
button to the right of a command in the Settings 

window. You can then edit both the Action Name and 
Action Data. 

Changing User Variables 
You can also use the BrightSign App to change the value 
of User Variables. User Variables have various uses in 
BrightAuthor presentations: You can display them on 
screen like dynamic price tags, or you can use them as 
conditionals in a presentation (for example, by setting the 
presentation to play a different video once the variable 
reaches a certain value). 
 
By default, the home page of the BrightSign App displays 
the Diagnostic Web Server. To change the values of 
User Variables, you will need to switch to the Local Web 
Server page. 
 
The title above a field reflects the name of the User 
Variable. The number in the field reflects the default 
value of the User Variable. To change the value of a User 
Variable, tap the field, enter a new value, and then press 
Set Value. 
Note: Like UDP Commands, you can only work with User 
Variables that are available on the player that the app is 
currently connected to. 

Using the Diagnostic Web Server 
The Diagnostic Web Server is a helpful tool for managing 
and monitoring networked players. It is included with the 
BrightSign App to increase the overall utility of the App, 
but it is not directly related to the interactive capabilities 
of UDP Commands or User Variables. Please see the 
Diagnostic Web Server User Guide to learn more about 
using this tool. 
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BRIGHTAUTHOR AND THE BRIGHTSIGN APP
This chapter details how to create BrightAuthor 
presentations that work with the BrightSign App. The 
following sections are intended as quick setup 
instructions. For a more comprehensive explanation of 
BrightAuthor features, please see the BrightAuthor User 
Guide. 

Diagnostic and Local Web Servers 
In order to use the Diagnostic Web Server and Local 
Web Server pages in the BrightSign App, you will need to 
first enable them for a player during the setup process in 
BrightAuthor.  

1. Create new setup files for a BrightSign player by 
navigating to Tools > Setup BrightSign Unit. 

2. Check the Enable diagnostic web server and 
Enable local web server boxes. 

3. (Optional) Enter a User name and Password for 
the Diagnostic/Local Web Server for additional 
security. 

4. Specify other settings for the BrightSign player as 
needed.  

5. Click Create Setup Files to publish the setup files 
to an SD card. 

Using UDP Events 
You can use UDP Events triggered through the 
BrightSign App to create a wide range of interactive 
events. Here we’ll demonstrate how to create a simple 
media transition event using UDP input: 

Enabling the Diagnostic Web Server and Local Web Server 

http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
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Connecting media items with a UDP Input Event 

1. Make your presentation interactive by clicking the 
Edit > Playlist tab and then selecting the 
Interactive option under Playlist type. 

2. Drag two media items (images or videos) into the 
playlist area from the Media Library.  

3. Click the Events tab under the Media Library. 
Drag and drop the UDP Input Event onto the first 
media item. 

4. Specify a desired command parameter in the 
Specify UDP input field. This is the same as the 
parameter in the Action Data field in the BrightSign 
App: Sending this text from the BrightSign App 
(using a command button) will activate the UDP 
Input Event. 

5. Select Transition to new state. Make sure the 
second media file is chosen. 

6. Press OK. 
 

You have now created an interactive presentation that 
will transition from one media item to another with the 
press of a button in the BrightSign App. When you use 

the app to connect to the player, the app will 
automatically retrieve and display the UDP Input Event 
as a Command Button.  
 

UDP Commands with Multiple Players 
The BrightSign App can only connect to, and send UDP 
Commands to, one player at a time. However, you can 
use Zone Message commands and events to broadcast a 
received UDP command from one player to multiple 
players. This is useful if you want, for example, to change 
the content of an entire video wall with a single command 
from the BrightSign App. 

1. Double-click an existing UDP Input Event (like the 
event created in the previous example). 

2. Navigate to the Advanced tab and click the Add 
Command button. 

3. Under Commands, choose the Link category. 
4. Under Command Parameters, select Send Zone 

Message and enter a command parameter 
(similar to a UDP Command). 

5. Navigate to File > Presentation Properties and 
click the Interactive tab. In the UDP section, 
choose one of the following: 

a. Select Specific IP address if you want 
Zone Message commands to be sent to 
only one player on your local network. Enter 
the IP address of the player. 
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b. Select All devices on the local subnet if 
you want Zone Message commands to be 
sent to all players on your local network. 

6. Change the default UDP Destination Port if 
desired. 

Note: All UDP ports for BrightSign players are set to 
5000 by default. If you change the destination port for 
this presentation, you will need to change the receiver 
ports for all presentations linked to it. 
7. Create a new presentation for the player(s) that 

will be linked to the first player. 
8. Add two media items of your choosing to an 

interactive presentation (similar to the previous 
example). 

9. Click the Events tab under Media Library. Drag 
and drop the Zone Message event onto the first 
media item. 

10. In the Specify zone message field, enter the 
same command parameter that you used in Step 
4.  

 
Now, when you send a command to the first player using 
the BrightSign App, it will send a similar command to the 
other player(s) on the local network. 

Creating User Variables 
To modify User Variables in the BrightSign App, you 
must first create them in a BrightAuthor presentation: 

1. Go to File > Presentation Properties. 
2. Navigate to the Variables tab and click the Add 

Variable button. 
3. Specify a Name for the variable. This will be 

displayed above the value field in the BrightSign 
App. 

4. Select a Default Value for the User Variable. 
5. (Optional) Check the Networked box if you want 

the User Variable to also be updatable via RSS, 
Live Text, or Dynamic Playlist (see the BrightAuthor 
User Guide for more details). 

Using Link Zones to match the UDP event in another presentation 
Creating a User Variable  

http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
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6. Repeat the above process to add as many User 
Variables as needed. 

 
You can display User Variables in Live Text states to 
create price tags, menus, and schedules that are 
dynamic and updatable from the BrightSign App. You can 
also utilize User Variables to set conditional targets and 
change the volume of media files on the fly. 


